Visit Our UNIX and Linux User Community


X86 solaris10 suddenly stopped mounting flashdrive


 
Thread Tools Search this Thread
Operating Systems Solaris X86 solaris10 suddenly stopped mounting flashdrive
# 1  
Old 03-18-2013
X86 solaris10 suddenly stopped mounting flashdrive

I can't mount flash drives and dvd drives on my x86 solaris 10.

The error message appears after login; sd_media_watch_cb: dev gone.

When I issue #mount /usb, it first shows disk is mounted or busy, and
'/dev/dsk/c3t0d0p1 - there is no such device or address' when I repeat
it. But the device is in /dev/dsk dir.

It was working but has suddenly stopped working. I can't even mount
dvd drive as it shows the similar message and fails.

Please tell me what has gone wrong.

Thank you
# 2  
Old 03-18-2013
The common denominator between USB device and CD/DVD device mounting is the volfs service.

Try:

Code:
 
svcadm disable volfs
svcadm enable volfs


Last edited by hicksd8; 03-19-2013 at 09:06 AM.. Reason: Correct stupid error
# 3  
Old 03-19-2013
Quote:
Originally Posted by hicksd8
The common denominator between USB device and CD/DVD device mounting is the autofs service.

Try:

Code:
 
svcadm disable autofs
svcadm enable autofs

Thank you. I've tried but problem remains the same
# 4  
Old 03-19-2013
autofs?
I think it is rather volfs.
Code:
svcadm restart volfs

This User Gave Thanks to MadeInGermany For This Post:
# 5  
Old 03-19-2013
@MadeInGermany.....Yes, of course. What was I thinking?? Thanks for correcting my stupid mistake.

Last edited by hicksd8; 03-19-2013 at 09:13 AM..
# 6  
Old 03-24-2013
I apologies for being late.

I tried all the commands you asked me but problem persists. One message I get no matter what command related vol;"pattern volfs does not match any instances"

It can't mount volfs.
When I use vold, it says mount /vol fails.
I can't see permission of /vol as it suspends cursor (seems for ever) until I ctrl c to get
the cursor back.

Why I can't see/search/execute /vol directory?

Previous Thread | Next Thread
Test Your Knowledge in Computers #154
Difficulty: Easy
Inspur K-UX is a Linux distribution certified as UNIX 03 compliant.
True or False?

9 More Discussions You Might Find Interesting

1. Solaris

Solaris10(x86) display goes blank

Hi all, Installed Solaris10(1/13) on a normal Lenovo Thinkcenter desktop. The installation could proceed only in text mode (4). Install is success, but not able to get the login window after the grub screen. The screen goes blank. (as was the case when selecting desktop mode during... (7 Replies)
Discussion started by: Solaris_Begin
7 Replies

2. UNIX for Dummies Questions & Answers

FTP batch file suddenly stopped working

Hello, we have a UNIX system the runs our business data. We have 4 users that use a particular batch command file to extract data for use in the Windows side of the fence: (despreg.bat) ftp ftp> open danapak (database name) connected to danapak ftp> user ccsb password ccsb ftp>... (29 Replies)
Discussion started by: Mick_Dundee
29 Replies

3. Solaris

solaris10 x86 stop at GRUB

Dear All I am using Core2Duo processor on G31 chipset motherboard with 1 Gb RAM and 20 GB IDE HDD. I tried to install Solaris 10 from DVD and it installs Successfully without any error. after the first reboot it stop at GRUB prompt. I tried to many times with different partitions layout,... (9 Replies)
Discussion started by: jineetech
9 Replies

4. Solaris

Solaris10 x86 - How to find out the CPU model and speed?

Please let me know if there is any way I can find out (either via command line or SMF) the following: 1.CPU model (eg. Pentium 4,Celeron) 2.CPU speed (eg. 1GHz) for this I could get the output through psrinfo -v, but still is there any other way? 3.Hard disk model (eg. Seagate). When I... (9 Replies)
Discussion started by: saagar
9 Replies

5. Solaris

How to load a Sunix/Initio Sata card on Solaris10/x86

Hi All, Anyone has configured a Sunix Sata S150 card (AKA Initio Inic-1622) + disk in a Solaris10/x86 05/09 system? I wondered what to do to get it running. The Sunix card does not come with a Solaris driver ;-( The card is seen by the system as the prtconf -v output shows (see below at the... (0 Replies)
Discussion started by: longwave
0 Replies

6. UNIX for Dummies Questions & Answers

anyone know if backup exec 11d agent run on solaris10 x86?

anyone ? i install and it just fail to startup. (0 Replies)
Discussion started by: kakabobo
0 Replies

7. Solaris

mounting 1TB hard disk with Solaris10 X86

I have a 1TB hard disk that I had partitioned on a Sun clone and had 7 partitions of 137GB a piece. (Using a USB to SATA adaptor) I then had loaded a new hard disk on my laptop (T60...Lenova) with Solaris 10 X86. I tried to mount the hard disk but it kept telling me the mount point was busy and I... (2 Replies)
Discussion started by: mndavies
2 Replies

8. Solaris

mounting floppy on x86 - help

hello from newbie :) i have a question : i've just installed sol-10 on x86 - and i cant access my floppy/cdrom. the device naming totally different from those in bsd or linux - where it was much more difficult to understand :( the mntab/vfstab - i know where it was pointing at - but from... (2 Replies)
Discussion started by: rossonieri#1
2 Replies

9. Solaris

Solaris10 x86 on external drives

Hi guys. Am about to install Solaris10 x86 and I was wondering if there are any news as to whether it is possible or not to install the os on an external drive, especially firewire, I suppose I will have to open my tower and put in the drive to install it..the machine I want to put it on,... (0 Replies)
Discussion started by: BSDDomi
0 Replies

Featured Tech Videos