Visit Our UNIX and Linux User Community


SUN SOLARIS boot: start daemons


 
Thread Tools Search this Thread
Operating Systems Solaris SUN SOLARIS boot: start daemons
# 1  
Old 07-14-2005
SUN SOLARIS boot: start daemons

Hi,

I have a problem on a Solaris 9 server! After a restart some daemons don't start and I have to start them manually!

I thing that everything is ok in the /sbin/rc3 script! And if I run manually the "/etc/init.d/xxx start" the services start without problem.

I didn't find anything in "/var/adm/messages" (dmesg).

I tried to redirect the output in /sbin/rc3 :
-
echo $f >> /tmp/boot.log
case $f in
*.sh) . $f >> /tmp/boot.log ;;
*) /sbin/sh $f start >> /tmp/boot.log ;;
-
The result is (for example UC4) in /tmp/boot.log :
-
/etc/rc3.d/S97UC4
Sun Microsystems Inc. SunOS 5.9 Generic May 2002
setting sys environment uc4 - scnpapp1 (SunOS)
setting x11 environment

Starting OpenWindows in 5 seconds (type Control-C to interrupt)
-

I am lost! Someone could say to me what can be the problem and how can I analyze it in more details?

Tank's and best regards
# 2  
Old 07-14-2005
check the default runlevel in /etc/inittab

you should see this line:

is:3:initdefault:

if instead you see:

is:2:initdefault:

your default runlevel is 2.

If this looks to be correct you could post the output of 'ptree'.

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Start /SYS on SUN SPARC does not start machine [SUN SPARC ENTERPRISE T-5240]

-> start /SYS Are you sure you want to start /SYS (y/n)? y Starting /SYS ]-> show HOST /HOST Targets: bootmode diag domain Properties: autorestart = reset autorunonerror = false bootfailrecovery = poweroff ... (29 Replies)
Discussion started by: z_haseeb
29 Replies

2. Red Hat

iptables does not start on boot

Hello, I have an issue with iptables. The rules are already configured in /etc/sysconfig/iptables but when i reboot the node the service is not running or at least i can't see my rules. Below the configuration i did to start the service during boot. # chkconfig --list iptables iptables... (1 Reply)
Discussion started by: @dagio
1 Replies

3. Solaris

Command to list down all daemons in Solaris

Hi All, Is there any command to list all running daemons in Solaris. I should able to see only running daemons. Regards, SKumar (5 Replies)
Discussion started by: nskumar
5 Replies

4. Solaris

How to boot a sun Solaris server?

Hi everyone, I have searched on google and sun documentation but it's still not clear for me; how do we boot a sun Solaris server? I know what to do but only from this step: 1- start /SYS 2- start /SP/console The system go to to the prompt OK, then we use the BOOT command. My... (9 Replies)
Discussion started by: adilyos
9 Replies

5. Solaris

Sun Blade 150 will not boot off harddrive after install of solaris 10

Hello, I cant get my blade box to boot off the harddrive after installing solaris 10.I can get to a root prompt after issuing "boot cdrom -s".I tried booting off disk0 and disk1,but I get "the file just loaded does not seem to be executable".Thanks for any help.:wall: (4 Replies)
Discussion started by: chucky
4 Replies

6. Solaris

Solaris x86 installation using jumpstart does not local boot ( boot from hdd)

I am trying to install Solaris x86 using the Jumpstart server. I run the add_install_client command with appropriate options, and reboot my x86 Target box. The installation starts fine and unattended. After the installation completes and the target goes for a re-boot, it does not boot from the HDD... (9 Replies)
Discussion started by: hemalsid
9 Replies

7. Solaris

Using LOM port to start boot solaris 10

Hi. Hopefully a question with a very short answer. Previously I have been using a windows hyperterminal to boot solaris 10 systems (SunFire) over a serial lom cable. I want to perform the same operation from a solaris 8 machine to boot solaris 10. Can anyone tell me what commands I should... (2 Replies)
Discussion started by: RottingBadger
2 Replies

8. SuSE

Start Asterisk at boot?

Hello, I am running a SuSe 9.3 server. That have Asterisk. Asterisk are working fine/perfect. But what I want to do is to make it start up at boot. When I have started the computer can I type: sudo /root/Asterisk-1.0.8/Asterisk And it goes of. No problem. But I want it to do that by itself... (4 Replies)
Discussion started by: hast5
4 Replies

9. Solaris

solaris boot problem boot error loading interpreter(misc/krtld)

When I installed the SOLARIS 10 OS first time, the desktop would not start up, this was because of network setup. Reinstalled worked. After a week due to some problem I had to reinstall OS, installation went fine and but when i reboot I get this error. cannot find mis/krtld boot error loading... (0 Replies)
Discussion started by: johncy_j
0 Replies

10. Solaris

boot problem in Installation i86 sun solaris

Hello everybody, I installed sun solaris i86 , the programme installation install the "Mini Root" and after that he doing shutdown. the camputer coming up and he can't boot. how i can to resuled this problem ??? Thenk you in advence..... (2 Replies)
Discussion started by: yanly
2 Replies

Featured Tech Videos