Problem with GUI login on Ultra 45


 
Thread Tools Search this Thread
Operating Systems Solaris Problem with GUI login on Ultra 45
# 1  
Old 02-10-2011
Problem with GUI login on Ultra 45

I have a Sun Ultra 45 that was working perfectly until i upgraded it to Update 9 with a zfs filesystem. The box is sparc based and has an internal video card. When i boot it up, i receive an X server error and, while checking /var/dt/Xerrors, the following message is displayed

Code:
Fatal server error:
InitOutput: Error loading module for /dev/fb
XIO: fatal IO error 146 (Connection Refused) on X server ":0.0"
         after 0 requests (0 known processed) with 0 events remaining.

error (pid 749): Server for display :0 terminated unexpectedly 1
The loadable module for the display device SUNWnfb is not installed.

I've checked for the SUNWnfb package and it is indeed installed on the system. Are they any ideas on how to fix this problem?

---------- Post updated at 04:19 PM ---------- Previous update was at 04:14 PM ----------

Also, when i do a ls -l on /dev/fb this is the output:

Code:
lrwxrwxrwx 1 root root 42 Feb 10 22:43 /dev/fb -> /devices/pic@1f,700000,XVR-300@0:nfb0


Last edited by Scott; 02-10-2011 at 07:40 PM.. Reason: Code tags for Code; Table tags for Tables
# 2  
Old 02-11-2011
have you checked for partially installed packages? was "pkginfo -p" if i remember right... also have you installed the latest patch-cluster after the installation? maybe the error is a bug un u9 and a patch will fix this... if nothing works, i would try a new installation (maybe on another disk) for testing and see if the fb is running.
# 3  
Old 02-11-2011
I ran the pkginfo -p command and the system returned nothing. I also started the OS reinstallation last night, before leaving for the day and it finished up. After rebooting the system this morning the issue remains.
# 4  
Old 02-11-2011
and a patch update with latest patch cluster didn't fix the problem?
# 5  
Old 02-11-2011
I'm negotiating through the Oracle/Sun webpage maze Smilie now trying to find the correct link to the cluster.
# 6  
Old 02-11-2011
i've found the patch clusters here:
https://support.oracle.com/CSP/ui/fl...g=search%29%29
# 7  
Old 02-11-2011
I'm on the phone with an Oracle engineer and we've ran through several checks and it appears that there was a good install, all of the packages are there with only one non-essential package that was not completely installed. He initially thought that it was an error with the mouse or keyboard not being plugged in correctly, but i've replaced and reseated both and they seem to be working fine.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

Found a Sun Ultra 10 Elite3D workstation, and it boots to a login screen. How can I reset the OS?

I just got moved to a new office building, and as I was unpacking my stuff I saw an odd tower PC in the nearby recycling heap. It turned out to be a Sun Ultra 10 Elite3D workstation, complete with keyboard, mouse, and monster-sized CRT with the wacky Sun video cable. I just set everything up and... (4 Replies)
Discussion started by: wowbobwow
4 Replies

2. Shell Programming and Scripting

Unable to login into GUI mode.

hii all, I am unable to login into GUI mode in solaris 10. It is only prompting me to command mode credentials not going further to GUI mode.. Please help.. Thanks & regards, Bhagi (3 Replies)
Discussion started by: bhargav90
3 Replies

3. UNIX for Dummies Questions & Answers

login via gui

I am not too new with linux. Since I installed a new version (2011) of Mandriva, I am unable to login via the gui (I'm currently using the live version of the same dvd free with Linux Format mag). I can login from a console as it has picked up the previous version's /home, but when I try to login... (2 Replies)
Discussion started by: richardmellersh
2 Replies

4. Solaris

Solaris machine is at # prompt not able to login in GUI mode

Solaris machine is at # prompt not able to login in GUI mode : I want to login solaris server in GUI mode from # prompt. ---------- Post updated 12-30-11 at 11:36 AM ---------- Previous update was 12-29-11 at 02:23 PM ---------- Hi, Please send me some guidelines regarding this.... as... (2 Replies)
Discussion started by: sunray
2 Replies

5. Fedora

can't login via GUI but can via Putty

Hi all, I am able to login via putty to a fedora 10 workstation. But when i try to login via physical screen connected to workstation, it just gives me a blank screen and i cant see any options to enter username and passwd. How do i get the physical GUI to work. $ who -r ... (4 Replies)
Discussion started by: lramsb4u
4 Replies

6. UNIX for Advanced & Expert Users

Not able to login from GUI

Hi, When I installed Ubuntu on my laptop, I had chosen "automatic login" . So i was not asked ofr username and password everytime I switched on. I later wanted to change the settings. So I went to systems-->administration-->login window-->security. There I disabled automatic login and I reboot the... (3 Replies)
Discussion started by: vishwamitra
3 Replies

7. Solaris

Queries on cron and GUI login...

I have 2 queries: 1.how do we monitor failed GUI logins...? I think the /var/adm/loginlog will log only failed logins happened at /dev/console and virtual terminals.. 2.How to use cron scheduler to display a message when a user is working in GUI Terminal window irrespective of in which... (1 Reply)
Discussion started by: saagar
1 Replies

8. Linux

how to root gui login enable

hi iam installed mandriva spring 2009 iam unble to login into gui using root how to enable it where the settings are stored (5 Replies)
Discussion started by: seshumohan
5 Replies

9. Solaris

Solaris 8 login GUI doesn't come up.

Hi experts, I've installed Solaris 8 to Sunfire V480. After installation I only could login to the server using CLI command. Can you show me how to start the login GUI? I use standard SUN graphic monitor and keyboard. Thanks in advanced. VN (26 Replies)
Discussion started by: vntiger
26 Replies

10. SCO

pswd change on sco GUI login

Can i change the password on the SCO GUI interface login page and if so how? When I try to login it just goes right back to the login screen. If anyone has any suggestions, please reply. :confused: (3 Replies)
Discussion started by: qphillips
3 Replies
Login or Register to Ask a Question

Featured Tech Videos