Visit Our UNIX and Linux User Community


Compile php with curl on solaris 10 question


 
Thread Tools Search this Thread
Operating Systems Solaris Compile php with curl on solaris 10 question
# 1  
Old 11-04-2010
Compile php with curl on solaris 10 question

I have curl compiled into /usr/local. I needed to install another version into /usr/local/curl-7.19.5 and compile php using that directory. I believe I had done that but an ldd run against php shows it is using /usr/local/lib. I have my configure script below showing how it was built and php -i shows the same (see below). Do I need to specify the lib directory on the php --with-curl line? I don't see that in a lot of docs. Does my LD_RUN_PATH override what ldd indicates? Unfortunately the version in /usr/local/ is the same as the version in /usr/local/curl-7.19.5 so I can't tell that way what it is using.

Thanks for any help.

Code:
# ldd /usr/local/bin/php | grep curl
        libcurl.so.4 =>  /usr/local/lib/libcurl.so.4
#

# more ConfigurePHP
#!/bin/sh

#PATH=/opt/SUNWspro/bin:/usr/bin:/usr/ccs/bin:/usr/sbin:/usr/sfw/bin; export PATH
PATH=/opt/SUNWspro/bin:/usr/local/bin:/usr/bin:/usr/ccs/bin:/usr/sfw/bin:/usr/dt
/bin:/usr/openwin/bin:/usr/sbin; export PATH
LD_RUN_PATH=/usr/local/curl-7.19.5/lib:/usr/sfw/lib:/usr/local/lib; export LD_RUN_PATH

env     CC=cc CXX=CC  \
        ./configure \
        --with-apxs2=/usr/local/apache2/bin/apxs \
        --with-mysql=/usr/local/mysql \
        --with-pear \
        --with-libxml-dir=/usr \
        --with-mysqli=/usr/local/mysql/bin/mysql_config \
        --enable-mbstring \
        --with-curl=/usr/local/curl-7.19.5 \
        --with-gd \
        --with-jpeg \
        --with-jpeg-dir=/usr/lib

#!/end
#

# php -i | grep curlConfigure Command =>  './configure' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql=/usr/local/mysql' '--with-pear' '--with-libxml-dir=/usr' '--with-mysqli=/usr/local/mysql/bin/mysql_config' '--enable-mbstring' '--with-curl=/usr/local/curl-7.19.5' '--with-gd' '--with-jpeg' '--with-jpeg-dir=/usr/lib'


Last edited by pludi; 11-04-2010 at 06:50 PM.. Reason: code tags, please...
# 2  
Old 11-04-2010
Are they different versions of curl, or just different configurations of it? It may be possible to differentiate them based on file name, i.e. linking to libcurl.so.4.2.0 instead of libcurl.so. Usually things'd link to .so or .so.4 on the theory that minor differences in version don't matter...

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

Samba compile issue on Solaris 9

Hi all :) I've been given a task to try and upgrade Samba on our legacy Solaris 9 (SunOS 5.9) sparc system. Its currently running samba 3.5.3 but we'd like to try and install 3.6.0 (or 3.6.25) to have minimal protocol smbv2. When trying to install from source, it appears to configure fine,... (4 Replies)
Discussion started by: jimbob01
4 Replies

2. Solaris

Compile PHP as an Apache module on Solaris

Hi, I need to install php 5.5.30 as an apache (2.4.17) module on Solaris 10. Please any help is wellcome. Some aditional info: /usr/sfw/bin/gcc -v Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs bash-3.2# g++ -v Reading specs from... (0 Replies)
Discussion started by: lbslbs
0 Replies

3. Solaris

Curl failing on Solaris-10 zone

H, I have Solaris-10 non-global zone (sparse), which is complaining about curl, I am not sure why. Background is - dev-box-23 is a non global zone, I migrated from other physical box to my current physical box. After that, curl is broke. I am not sure, what soft link I should make on global host... (3 Replies)
Discussion started by: solaris_1977
3 Replies

4. Programming

nss compile on solaris 10

so I am trying to build "directory server 389" on solaris 10. I am using this as i guide: 389 Directory Server (Open Source LDAP) I am using solaria studio as my compiler. I built NSPR with no issues. the problem is NSS (Network Security Services) I simply can't find instruction... (0 Replies)
Discussion started by: robsonde
0 Replies

5. Solaris

Compile PHP 5.3.6 with MySql on Sun Blade 1500 Solaris 10

Hello, I'm trying to compile PHP 5.3.6 with Apache2 and MySql 5.5.12. I hit a problem that I can't seem to resolve by myself and I could not find a solution on the web. It looks like Apache and MySql installed ok, I can start/stop them with no problem. When I try to compile PHP the... (4 Replies)
Discussion started by: pn8830
4 Replies

6. Solaris

PHP 5.3 compile on Solaris 10 : make distclean :: fatal error

I'm trying to install PHP 5.3 on Solaris 10 . I'm using etc/apache2 and installed mysql 5.1.39. When I tried to compile PHP 5.3, with the following configure text, ./configure --with-mysql=/usr/local/mysql \ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-zlib-dir=/usr/local \... (21 Replies)
Discussion started by: ppa108
21 Replies

7. Solaris

Errors trying to compile PHP for use with MySQL on Solaris 10

have installed and am using the GNU based tools from the Sunfreeware site to compile PHP. I already have Apache, MySQL, and Oracle compiled and working properly. Below is my configure string for my PHP build: ./configure --prefix=/usr/local/php5 \... (2 Replies)
Discussion started by: sunsysadm2003
2 Replies

8. Solaris

Compile Scilab 5.0.2 on Solaris 9

Hello, I'm trying to build scilab 5.0.2 on a Solaris 9 Sparc After more than one hour of compiling, this error msg appear, what could be the problem? if you need any more info i'm here. Thanks for your help. Error msg :... (0 Replies)
Discussion started by: wolfhurt
0 Replies

9. Programming

client/server compile question

Hi, I have 2 files-->server.c and client.c My server.c takes local ip as saying: *.sin_addr.s_addr=INADDR_ANY; client.c is in the same machine.It has a line like: *.sin_addr.s_addr=inet_addr(argv); I don't know how to compile.I tried ./client 127.0.0.1 It used port 7777 in both client... (2 Replies)
Discussion started by: mlhazan
2 Replies

10. UNIX for Dummies Questions & Answers

libnet does not compile on Solaris 9

Hi I'm trying to compile libnet in Solaris 9, but it seems to have syntax errors. I got it from www.packetfactory.net/libnet/ which is the address the computer suggested me to download it. I downloaded the 1.1.2.1 version which is supposed to be stable Anybody knows if the code has... (3 Replies)
Discussion started by: eldiego
3 Replies

Featured Tech Videos