Visit Our UNIX and Linux User Community


Curious MPxIO problem


 
Thread Tools Search this Thread
Operating Systems Solaris Curious MPxIO problem
# 1  
Old 09-21-2010
Curious MPxIO problem

Hello folks,
I have a newly installed Solaris 10 system running on a T6320 blade. I have set up LDM with the intent to move an ldom from another blade to this one. So far, so good.

I had the SAN folks make the LUNs belonging to the ldom visible to my new blade and I can see them, all 4 paths. I have run stmsboot and I still see all 4 paths. I have disabled and re-enabled multipath with stmsboot (reboots both times).

On the old blade I see a single path, and the ldom config is based on that, so I want to get mpxio to work, but obviously I need to be careful not to trash the existing data on the LUNs. Anyone have any ideas to try?

Code:
root@Antinous:~#mpathadm list initiator-port
Initiator Port:  iqn.1986-03.com.sun:01:00144fefa2b0.4c98c071,4000002a00ff
Initiator Port:  2101001b32a12a83
Initiator Port:  2100001b32812a83
Initiator Port:  2101001b32a15183
Initiator Port:  2100001b32815183
root@Antinous:~#mpathadm list lu
root@Antinous:~#cfgadm -la
Ap_Id                          Type         Receptacle   Occupant     Condition
PCI-EM0                        fibre/hp     connected    configured   ok
PCI-EM1                        fibre/hp     connected    configured   ok
c0                             scsi-sata    connected    configured   unknown
c0::dsk/c0t0d0                 disk         connected    configured   unknown
c1                             fc-fabric    connected    configured   unknown
c1::500a098597e9755e           disk         connected    configured   unknown
c1::500a098887e9755e           disk         connected    configured   unknown
c2                             fc           connected    unconfigured unknown
c3                             fc-fabric    connected    configured   unknown
c3::500a098587e9755e           disk         connected    configured   unknown
c3::500a098897e9755e           disk         connected    configured   unknown
c4                             fc           connected    unconfigured unknown
usb0/1                         unknown      empty        unconfigured ok
usb0/2                         unknown      empty        unconfigured ok
usb0/3                         unknown      empty        unconfigured ok
usb1/1                         unknown      empty        unconfigured ok
usb1/2                         unknown      empty        unconfigured ok
usb2/1                         unknown      empty        unconfigured ok
usb2/2                         unknown      empty        unconfigured ok
usb2/3                         usb-hub      connected    configured   ok
usb2/3.1                       unknown      empty        unconfigured ok
usb2/3.2                       unknown      empty        unconfigured ok
usb2/3.3                       unknown      empty        unconfigured ok
usb2/3.4                       unknown      empty        unconfigured ok
usb2/4                         unknown      empty        unconfigured ok
usb2/5                         unknown      empty        unconfigured ok
usb3/1                         unknown      empty        unconfigured ok
usb3/2                         unknown      empty        unconfigured ok
usb3/3                         unknown      empty        unconfigured ok
usb4/1                         unknown      empty        unconfigured ok
usb4/2                         unknown      empty        unconfigured ok
usb5/1                         unknown      empty        unconfigured ok
usb5/2                         unknown      empty        unconfigured ok
usb5/3                         unknown      empty        unconfigured ok
usb5/4                         unknown      empty        unconfigured ok
usb5/5                         unknown      empty        unconfigured ok

# 2  
Old 09-22-2010
To enable it, edit the file /kernel/drv/fp.conf file. At the end it should say:

HTML Code:
mpxio-disable="yes"

Just change yes to no and it will be enabled:

mpxio-disable="no"
Hope this works
# 3  
Old 09-22-2010
I've yet to see a Solaris 10 install that has MPxIO disabled out-of-the-box in /kernel/drv/fp.conf.

Do the LUNs show up under format?

Have you run devfsadm?

What's the output from fcinfo? See the man page of that command for options.

If you're still stumped, it may be easier to just "reboot -- -r".
# 4  
Old 09-23-2010
who's the SAN vendor ?

I recently faced a similar problem with HP storage and stms on Solaris. There're some known issues.
# 5  
Old 09-23-2010
I could have sworn I posted this yesterday . . .

I have resolved the problem. The SAN storage administrator had forgotten to enable ALUA on the NetApp end. Once he did that, and I disabled and re-enabled with the stmsboot command, I've got single images of the LUNs and everything is fine.

Previous Thread | Next Thread
Test Your Knowledge in Computers #333
Difficulty: Easy
Linux was first developed as an alternative to Windows XP.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

MPxIO Multipathing Problem

Hi, I believe this is an OS multipathing issue - Solaris 10 We have x2 Dual port 8GB Qlogic HBA's installed in our SOlaris 10 host. HBA0 (IOU0) Port WWN's - 09f4 (pci@3,700000/SUNW,qlc@0) 09f5 (pci@3,700000/SUNW,qlc@0,1) HBA1 (IOU1) Port WWN's... (2 Replies)
Discussion started by: jamba1
2 Replies

2. Shell Programming and Scripting

Curious

I dont get something about sed If i have a text file inside contain a:a:a:a:a sed "s/"$title:$author:$price:$qtyAvailable:$qtySold"/"$Ntitle:$author:$price:$qtyAvailable:$qtySold"/" This work!! but If i have a text file inside contain Tom Tom:La La:Di Di :Do Do :De DE It cannot work... (2 Replies)
Discussion started by: GQiang
2 Replies

3. Solaris

MPXIO

Hi Kudo, I wanna to know that how can I do mpxio device name to os native name mapping without using stmsboot -L I tried everything still not able to got the solution till I able to get these o/p here is native disk info as well physical wat is the logical OS name of the disk ... (1 Reply)
Discussion started by: tarunn.dubeyy
1 Replies

4. UNIX for Advanced & Expert Users

AWK sub function curious problem under bash

I need to detect the number of pages in a print job when it is available so I can warn users when they try to print a report much larger than they expected. Sometimes they are trying to print 1000 page reports when they thought they were getting a 10 page report. Under linux I am scanning the... (5 Replies)
Discussion started by: Max Rebo
5 Replies

5. UNIX for Advanced & Expert Users

mpxio in Solaris10 with NetApp FAS3140 problem

we have a v440 SUN machine with a NetApp FAS3140 SAN storage, the v440 got 2 HBA qlogic cards both connected to the switch side in NetApp 3140, zoning in netapp configured proberly and luns are adversitesed to the SUN machine, the problem i am facing is that when i try to configure the mpxio i am... (7 Replies)
Discussion started by: q8devilish
7 Replies

6. Filesystems, Disks and Memory

MPxIO question

Greetings Forumers!! I was given a T2000 with one, dual port, HBA card. The card had one fiber connection to the SAN and the former admin enabled MPxIO. Yesterday, I learned that the other port was connected to the same SAN. This system is in another city so I don't have physical access to... (1 Reply)
Discussion started by: bluescreen
1 Replies

7. Filesystems, Disks and Memory

VxVM and MPxIO

:confused: Last week I read that VxVM won't work with MPxIO (i don't recall the link) and that it should be unconfigured when installing VxVM. Today I read that VxVM works in "pass-thru" mode with MPxIO and DMP uses the devices presented by MPxIO. If I create disks with MPxIO and use VxVM to... (1 Reply)
Discussion started by: bluescreen
1 Replies

8. Solaris

Mpxio

Hi, I have a quick question. How can I see MPXIO statistics (like errors, how many I/O|throuput per path, ....) on Solaris 10? Does maybe a ready dtrace script exist (I do not have the knowledge to write one myself)? I would be happy if somebody knows some good documentation/links (with... (1 Reply)
Discussion started by: victorinox
1 Replies

9. Solaris

Mpxio

Hi All, I have one question. I found out that my system setting for mpxio-disable=yes. Sun recommend to change it to mpxio-disable=no and run stmsboot -e command. But no one can tell will it affect the system or not and the system is sol-10 and using veritas volume manager and attached... (3 Replies)
Discussion started by: mailbox80
3 Replies

10. Shell Programming and Scripting

curious

sorry, just simple question: how can i do this in bash> foreach i( 1 2 3 ) sed 's/Hello/Howdy/g' test$i > test$i.new mv test$i.new test$i end (6 Replies)
Discussion started by: kurosaki
6 Replies

Featured Tech Videos