Visit Our UNIX and Linux User Community


NIS slave unable to copy the data bases


 
Thread Tools Search this Thread
Operating Systems Solaris NIS slave unable to copy the data bases
# 1  
Old 08-01-2010
NIS slave unable to copy the data bases

Hi,

I'm learning for my Solaris 10 sys-admin part 2. I'm now trying to get nis working because for the exercise. I run in to a problem.

Setup:
Three Systems
solaris101 (client)
Nothing wrong here havent made any config changes yet.

solaris102 (master server)

Interfaces
Code:
bash-3.00# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 192.168.1.6 netmask ffffff00 broadcast 192.168.1.255
        ether 0:c:29:17:ee:db
e1000g1: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 3
        inet 192.168.2.10 netmask ffffff00 broadcast 192.168.2.255
        ether 0:c:29:17:ee:e5

notice that e1000g1 is setup with dhcp.

Hosts
Code:
bash-3.00# cat /etc/hosts
#
# Internet host table
#
::1     localhost
127.0.0.1       localhost
192.168.1.5     solaris101
192.168.1.7     solaris103      loghost
192.168.2.10    solaris102      # Added by DHCP
bash-3.00#

routing table
Code:
bash-3.00# netstat -rn
Routing Table: IPv4
  Destination           Gateway           Flags  Ref     Use     Interface
-------------------- -------------------- ----- ----- ---------- ---------
default              192.168.2.1          UG        1          0 e1000g1
192.168.1.0          192.168.1.6          U         1          7 e1000g0
192.168.2.0          192.168.2.10         U         1         24 e1000g1
224.0.0.0            192.168.2.10         U         1          0 e1000g1
127.0.0.1            127.0.0.1            UH        3        118 lo0

Ok, so the NIS master server was installed succesfully.

solaris103 (slave server)

Interface
Code:
bash-3.00# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 192.168.1.7 netmask ffffff00 broadcast 192.168.1.255
        ether 0:c:29:d7:de:2f

Hosts
Code:
bash-3.00# cat /etc/hosts
#
# Internet host table
#
::1     localhost
127.0.0.1       localhost
192.168.1.7     solaris103      loghost
192.168.1.6     solaris102
192.168.1.5     solaris101

routing
Code:
bash-3.00# netstat -rn
Routing Table: IPv4
  Destination           Gateway           Flags  Ref     Use     Interface
-------------------- -------------------- ----- ----- ---------- ---------
192.168.1.0          192.168.1.7          U         1          7 e1000g0
224.0.0.0            192.168.1.7          U         1          0 e1000g0
127.0.0.1            127.0.0.1            UH        1        136 lo0

Problem statment:
When I run the
Code:
bash-3.00# ypinit -s solaris102

command I get the following errors.

Code:
bash-3.00# ypinit -s solaris102

Installing the YP database will require that you answer a few questions.
Questions will all be asked at the beginning of the procedure.
Do you want this procedure to quit on non-fatal errors? [y/n: n]  n
OK, please remember to go back and redo manually whatever fails.  If you
don't, some part of the system (perhaps the yp itself) won't work.
The yp domain directory is /var/yp/local.com
Can we destroy the existing /var/yp/local.com and its contents? [y/n: n]  y
There will be no further questions. The remainder of the procedure should take
a few minutes, to copy the data bases from solaris102.
Transferring audit_user...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring user_attr...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring prof_attr...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring exec_attr...
^CTransferring auth_attr...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring ageing.byname...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring auto.home...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring timezone.byname...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring netmasks.byaddr...
bind_to_server __clnt_create_rsvd error: RPC: Rpcbind failure - RPC: Timed out
Transferring auto.master...

ping to the solaris102 (master) from the solaris103 (slave) produces the following.
Code:
bash-3.00# ping solaris102
ICMP Host Unreachable from gateway solaris103 (192.168.1.7)
 for icmp from solaris103 (192.168.1.7) to solaris102 (192.168.2.10)
ICMP Host Unreachable from gateway solaris103 (192.168.1.7)
 for icmp from solaris103 (192.168.1.7) to solaris102 (192.168.2.10)
ICMP Host Unreachable from gateway solaris103 (192.168.1.7)
 for icmp from solaris103 (192.168.1.7) to solaris102 (192.168.2.10)
^C

Weird, why the dhcp adres from the solaris102 (master)?
I thought maybe NIS is already working and getting an adress from solaris102 (master) so I reconfigured the nsswitch.conf file just to use files.

Code:
bash-3.00# cat /etc/nsswitch.conf
#
# /etc/nsswitch.nis:
#
# An example file that could be copied over to /etc/nsswitch.conf; it
# uses NIS (YP) in conjunction with files.
#
# "hosts:" and "services:" in this file are used only if the
# /etc/netconfig file has a "-" for nametoaddr_libs of "inet" transports.
# NIS service requires that svc:/network/nis/client:default be enabled
# and online.
# the following two lines obviate the "+" entry in /etc/passwd and /etc/group.
passwd:     files nis
group:      files nis
# consult /etc "files" only if nis is down.
hosts:      files nis
# Note that IPv4 addresses are searched for in all of the ipnodes databases
# before searching the hosts databases.
ipnodes:    nis [NOTFOUND=return] files
networks:   files
protocols:  files
rpc:        files
ethers:     files
netmasks:   files
bootparams: files
publickey:  files
netgroup:   nis
automount:  files nis
aliases:    files nis
# for efficient getservbyname() avoid nis
services:   files nis
printers:       user files nis
auth_attr:  files nis
prof_attr:  files nis
project:    files nis

Code:
bash-3.00# ypinit -s 192.168.1.6

Can't enumerate maps from 192.168.1.6. Please check that it is running.

Any help would be apriciated.

Last edited by jld; 08-01-2010 at 03:07 PM..
# 2  
Old 08-03-2010
Solved it my self.

What i've done is.

I thought that the problem resided in the fact that the primary interface was het interface on which dhcp was running. That explains when I pinged ik got the dhcp outside adress e1000g1 and not the static inside adress e1000g0.
So I wanted to change this and edited the hosts file to match the inside ip with the inside interface also changed the hostname.e1000g0 with the hostname of the master, this was previous just an ip configured in that file.

rebooted.

That still didnt work. the primary interface was still the dhcp address and it kept overruling my static ip in the hosts file.

I put this in
Code:
#
# Internet host table
#
::1     localhost
127.0.0.1       localhost
192.168.1.5     solaris101
192.168.1.7     solaris103      loghost
192.168.1.6    solaris102

but the result after a reboot was:

Code:
#
# Internet host table
#
::1     localhost
127.0.0.1       localhost
192.168.1.5     solaris101
192.168.1.7     solaris103      loghost
192.168.2.10    solaris102      # Added by DHCP

So I struggeld a bit with that but finally I thought

Code:
sys-unconfig

will do the trick. rebooted and configured all a new setting the primary interface to e1000g0 the static ip.
Also made the dhcp a static ip and the hosts file now looks like this.

Code:
bash-3.00# cat /etc/hosts
#
# Internet host table
#
127.0.0.1       localhost
::1     localhost
192.168.1.6     solaris102
192.168.2.10    solaris102-1
192.168.1.5     solaris101
192.168.1.7     solaris103

Notice I made a different name for the e1000g1 interface, think that is commonly used like this.

After all configurations.

Code:
ypinit -s solaris102

Worked fine and the slave could contact the NIS master server.

Previous Thread | Next Thread
Test Your Knowledge in Computers #484
Difficulty: Medium
A compiler transforms source code into object code, a floating point number format that machines understand.
True or False?

9 More Discussions You Might Find Interesting

1. Solaris

Testing NIS slave server

Hi guys, In my Sol-10 i setup NIS server following the oracle doc and setup a Linux as NIS client all went ok. I added another Sol-10 and configure it as a NIS slave server following the oracle doc again. and added the server on the yp.conf on my NIS client How do i test if my NIS slave... (3 Replies)
Discussion started by: batas
3 Replies

2. Shell Programming and Scripting

unable to configure NIS client server

Dear all, I am using solaris 10 OS. I configured NIS server and i also configured NIS client server but when i use the command ypinit -s sunserv1 in NIS client it is showing me the below error. Enumerates maps from sunserv1. please check that it is running. (2 Replies)
Discussion started by: bhargav90
2 Replies

3. UNIX for Advanced & Expert Users

NIS setup: Mastr on AIX and slave on Solaris?

Hello - This could be a stupid question. But can we configure NIS with different flavors of UNIX. Like Master on AIX and slave on Solaris? ---------- Post updated 09-06-11 at 04:17 AM ---------- Previous update was 09-05-11 at 06:34 AM ---------- Hi - Can anyone please answer this? (1 Reply)
Discussion started by: manju--
1 Replies

4. Solaris

How to bind from a NIS slave server

Hi All, I have a client already binded with a NIS master server. Now, I want to bind this particular client to one of NIS slave. How to do it? Thanks, Deepak (2 Replies)
Discussion started by: naw_deepak
2 Replies

5. AIX

Slave NIS server configuration change

Hello Everybody, I have a question regarding SLAVE NIS SERVER in aix. We are using NIS master of Sun Solaris 9.0 which is on different subnet i.e. 10.197.93.0. And Our slave server is having AIX 5.3 installed which is on 10.207.13.0 subnet. I have a query regarding its name and ip address... (0 Replies)
Discussion started by: jit15975
0 Replies

6. SuSE

Automount on NIS slave

I am setting up the NIS slave server to automount the home directory just like its master server on suse linux (SLES 10). Since the master will be the first to mount the /home on the client. I have not been able to mount the /home on the on the slave when the master NIS server is unavailable.... (1 Reply)
Discussion started by: ibroxy
1 Replies

7. UNIX for Advanced & Expert Users

Automount on NIS slave

I am setting up the NIS slave server to automount the home directory just like its master server on suse linux (SLES 10). Since the master will be the first to mount the /home on the client. I have not been able to mount the /home on the on the slave when the master NIS server is unavailable. How... (0 Replies)
Discussion started by: ibroxy
0 Replies

8. UNIX for Advanced & Expert Users

NIS master / slave problems

Our NIS master server went down. We have since fixed it and brought it back up. However all of are machines still point to the slave server when looking at it with ypwhich. My question is how do i point the servers back to the master. Frank (2 Replies)
Discussion started by: frankkahle
2 Replies

9. Solaris

Unable to Log In to Sun NIS server

Greetings, I have recently inherited 3 sun servers from a shop that my parent company closed. One of these servers is an old Ultra 1 running SunOS 5.6 that acts as a NIS server for the other two servers. This NIS server seems to boot OK and function properly as a NIS server. However, I can't... (6 Replies)
Discussion started by: SevenFortyOne
6 Replies

Featured Tech Videos