Solaris don't boot without mouse and keyboard

Thread Tools Search this Thread
Operating Systems Solaris Solaris don't boot without mouse and keyboard
# 1  
Old 01-18-2010
Solaris don't boot without mouse and keyboard

Hi guys,

I've installed Solaris 10 (SunOS 5.10) in a x86 box. I will put this box as a home server to store my files/backups/whatterver shared stuff replacing my old NetBSD machine. But, after installed and correctly configured, when I tried to boot this box without keybord and mouse (USB both), the system freezes after the Grub screen.

I've already configured in the x86 bios the option "Halt On: [No errors]. Smilie

The system start booting, shows the "SunOS 5.10 Solaris (etc...)" banner message on the top, but stops and don't display any error log. Putting the USB mouse/keyboard again and rebooting, it starts and works perfectly, and show all your boot message as it should. Later I've checked in /var/log and didn't found any related error message.

I've already try adding the "-m verbose" option in Grub, to get a verbose boot and see the system messages, but it still stops after show the "SunOS 5.10 Solaris (etc...)" in the top.

I've still try touching the /reconfigure file and reboot the system without the USB keyboard and mouse, enforcing the system to re-check my hardware devices, but it stops again after the top banner message.

Have Solaris some configuration file where I would configure the system to ignore the keyboard and mouse absence?

Lucas Timm.

Last edited by pludi; 01-18-2010 at 07:44 PM..
# 2  
Old 01-19-2010
what h/w type are you using?
# 3  
Old 01-19-2010
Hi Incredible,

My box is a Intel Pentium 3 1.13GHz (Tualatin), 1.5GB Ram (SDRam PC-133), motherboard Asus TUV4-X, Realtek 8139, two IDE HDDs (80 and 120GB) and generic USB Mouse and Keyboard. I've installed Solaris 10 32bits, and it's running with excelent performance. If you need I can paste my prtconf. When this box was running Linux (CentOS 5.2) it works perfectly without keyboard and mouse, I've controlled it by SSH and XDMCP. That's what I want with Solaris.

Do you have some idea?

Lucas Timm
# 4  
Old 01-19-2010
If you tried to boot from cdrom to single user level, does it bypass the banner stage eg..?
# 5  
Old 01-19-2010
Originally Posted by Timmerman
I've already try adding the "-m verbose" option in Grub, to get a verbose boot and see the system messages
You haven't actually. "-m verbose" is enabling SMF verbose messages, not kernel ones which might help better in your case.
I would try these options instead:
-rv -m milestone=none


"man kernel" for details.
Login or Register to Ask a Question

Previous Thread | Next Thread

7 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Strange Keyboard and Mouse Issue

Hello All, PC: CuBox-i (*i.MX6) Mini-PC OS: openSUSE 13.1 (Bottle) (armv7hl) Kernel: 3.14.14-cubox-i # uname -a Linux CuBox-HQ 3.14.14-cubox-i #1 SMP Sat Sep 13 03:48:24 UTC 2014 armv7l armv7l armv7l GNU/LinuxSo I've been having this random issue happen on this PC where a few strange... (12 Replies)
Discussion started by: mrm5102
12 Replies

2. What is on Your Mind?

Keyboard vs mouse

Which Input device do you use the most ? for me... keyboard ofcourse !! (56 Replies)
Discussion started by: vpraveen84
56 Replies

3. SCO

X Server -> keyboard and mouse are freezing

hi I've configured X Server using Video Configuration Manager on SCO 5.0.6, but the keyboard and mouse are freezing after 5 minutes on the graphical login mask. ---------- Post updated at 01:59 PM ---------- Previous update was at 02:43 AM ---------- BTW I finished the configuration,... (2 Replies)
Discussion started by: ccc
2 Replies

4. UNIX for Advanced & Expert Users

Check keyboard and mouse activity

I need help from someone that is good at making scripts. I'm trying to make a script file that checks for keyboard and mouse activity during 1 am to 8 am and logs you off if it detects activity. I can't find anything useful in google. ---------- Post updated 06-30-10 at 12:33 AM ----------... (1 Reply)
Discussion started by: cokedude
1 Replies

5. UNIX for Dummies Questions & Answers

keyboard and mouse dont work after sometime from boot in linux.

when i started booting linux ,after sometime both the mouse and the keyboard are getting freeze and wont respond(also the system gets hanged and all the process running dont go forward) ,nothing seem to work. Keeping in mind that it will work after sometime ,i waited for one hour also ,but... (1 Reply)
Discussion started by: sanjay.login
1 Replies

6. What is on Your Mind?

mouse/keyboard wrist lesions.

Anyone ever had any problem related to wrist lesions caused by keyboard or mouse? Tendinitis? Tenosynovitis? How long it lasted? How did it go away? (3 Replies)
Discussion started by: redoubtable
3 Replies

7. HP-UX

HP-UX 11.11: X doesn't recognize mouse and keyboard

hi folks, i've got a blank hp visualize C3000 workstation and installed HP-UX 11.11. When I want to start X, I get the following error message: # X Fatal server error: Couldn't open X pointer device! Is one attached? I've connected an mouse and a keyboard with an usb/ps2 connector.... (5 Replies)
Discussion started by: grisu
5 Replies
Login or Register to Ask a Question

Featured Tech Videos