Visit Our UNIX and Linux User Community


Solaris 10 CDE hang issue


 
Thread Tools Search this Thread
Operating Systems Solaris Solaris 10 CDE hang issue
# 1  
Old 09-29-2009
Solaris 10 CDE hang issue

Hi,

I am facing some issues on Solaris 10 (SPARC 5.10 Generic_118833-36). The issue is when I try to connect/login through CDE it hangs (hangs at login screen). I tried connecting thourgh VNC client also but that also not helped. I had done no configuration change or modified any kernel parameter but this suddenly happened on my Solaris 10 server. This machine is in production.

Below is the error message that appears when I try to login from CDE environment on this server

"/usr/dt/bin/ttsession[1110]: [ID 161973 daemon.error] t_connect(): An event requires attention".

Also if I try to open Gnome/Java environment on this machine it works fine. The only issue is with the CDE session. The CDE vesion installed is 1.6 on my server.
I tried googling this error but most of the search suggested to install patch 119955-05 for CDE but this also not helped. Please help.

Regards, kunal
# 2  
Old 09-29-2009
Have a look at the CDE error logs (~/.dt/something)
# 3  
Old 09-30-2009
Solaris 10 CDE hang issue

Hi thanks for the reply, below is the log file that I found ~/.dt/startlog

########
bash-3.00# cat startlog
--- Wed Sep 30 09:01:36 IST 2009
--- //.vnc/xstartup starting...
--- starting /usr/dt/bin/dthello &
/usr/dt/bin/dthello: display :1.0 doesn't know font -dt-interface system-medium-r-normal-m*-*-*-*-*-*-*-*-*:
--- Xsession started by
--- setting font path...
--- starting /usr/dt/bin/dtsession_res -load -system
--- sourcing //.dtprofile...
--- sourcing /usr/dt/config/Xsession.d/0010.dtpaths...
--- sourcing /usr/dt/config/Xsession.d/0015.sun.env...
--- sourcing /usr/dt/config/Xsession.d/0020.dtims...
--- sourcing /usr/dt/config/Xsession.d/0030.dttmpdir...
--- sourcing /usr/dt/config/Xsession.d/0040.xmbind...
--- sourcing /usr/dt/config/Xsession.d/1001.swupnot...
--- sourcing /usr/dt/config/Xsession.d/1099.br...
//.vnc/xstartup[624]: date.: not found
--- could not read //.profile
--- starting /usr/dt/bin/dtsearchpath
--- starting /usr/dt/bin/dtappgather &
--- starting /usr/dt/bin/dsdm &
--- session log file is /dev/null
--- DTSOURCEPROFILE is 'true' (see //.dtprofile)
--- execing /usr/dt/bin/dtsession with a /sbin/sh login shell ...
--- starting desktop on /dev/pts/9
Sun Microsystems Inc. SunOS 5.10 Generic January 2005
You have new mail.
/usr/dt/bin/ttsession[27308]: starting
The Sun Notification Application is disabled, To enable it,
use the Preferences menu in the Sun Update Manager.
########

else there are no logs that I found in .dt

Previous Thread | Next Thread
Test Your Knowledge in Computers #841
Difficulty: Medium
Push technology, or server push, is a style of Internet-based communication where the request for a given transaction is initiated by the publisher or central server.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

How to solve hang issue in script?

i have one function block in the beginning of my script and there are some commands inside that function which will perform some operations. And i am invoking that function from my main script by passing some values. Sometimes it is hanging in the middle for some value. For example: For 1st... (3 Replies)
Discussion started by: thomasraj87
3 Replies

2. Solaris

Solaris 10 VMs hang after about a week

Hi all, We're been having issues with quite a few Solaris 10 VMs hanging after about a week of uptime. These VMs are running on VMware ESXi 4.1 U1 hosts and the issue does not occur on any specific host. We also running CentOS VMs and are not experiencing any issues with those VMs. The VMs that... (5 Replies)
Discussion started by: derekivey
5 Replies

3. Solaris

Solaris 11 and OpenSolaris both hang at Configuring Devices

Hi, Any help would be appreciated, when I attempt to install either OpenSolaris or Solaris 11 the install hangs right after the copyright where normally it would be "configuring devices" . If it is SOL 11 it just hangs if it is OpenSolaris it starts spitting out the following: WARNING: hubdi:... (0 Replies)
Discussion started by: jk121960
0 Replies

4. Programming

A system hang issue in porting an old fs to kernel 2.6.32.*

Hi, I ported a file system from Kernel version 2.6.18.* to 2.6.32.46 as VFS implementation has changed and prepare_write/commit_write are replaced by write_begin/write_end pairs. Implemented the feature by writing a wrapper for write_begin and write_end and calling original functions for... (0 Replies)
Discussion started by: Praveen_218
0 Replies

5. UNIX Desktop Questions & Answers

How to migrate Solaris 10 CDE config to HP-UX CDE.

Hello, Do you guys by any chance know what is the best (if any ) way to move CDE configuration from a SOLARIS 10 machine to HP-UX? Just the config (actions, text files etc). Thanks in advance! (0 Replies)
Discussion started by: binary0x01
0 Replies

6. Solaris

Zone hang issue

I have a solaris10 zone running an oracle db in it. The zone hangs after some time the db is started and i 'm unable to log into the zone after that so i have to halt and restart the zone along with db .. but after few hrs again it hangs. What would be the reason for it. I did svcs -xv and got... (13 Replies)
Discussion started by: fugitive
13 Replies

7. AIX

Port hang issue in AIX Version 5.3

On AIX platform we are having Weblogic 8.1 as the middleware for an application. The application is deployed in Weblogic on AIX platform and the server is having 2 dedicated listening ports for any incoming requests. Output for netstat -an command for the port 30001 is as follows:- tcp4... (7 Replies)
Discussion started by: subharai
7 Replies

8. Solaris

CDE Issue In Solaris 10

Hi All, I have solaris 10 on X86 and I need to connect this through X-Manager or similar software. I have googled a lot and tried the following : root@sol10x86 # ps -ef |grep dtlogin root 1825 4718 0 13:38:50 pts/1 0:00 grep dtlogin root@sol10x86 # svcs cde-login STATE ... (2 Replies)
Discussion started by: pintu_asim
2 Replies

9. Solaris

solaris 5.8 hang on boot

I have an ultra 10 system, and am trying to install and verify a previously cloned hard drive, to make sure it works, that it really is a duplicate of the hard drive currently on an other server, etc. I plugged in this cloned hard drive as master, only drive in the system. No network LAN... (2 Replies)
Discussion started by: HikerLT
2 Replies

10. UNIX for Dummies Questions & Answers

Solaris 8 CDE gone?

Help! I performed a sys-unconfig as suggested in one of the other threads to set up IP on hme0. Unfortunately after all is said and done, it no longer boots to the CDE but sits at a command prompt. Any ideas (I don't know Unix). Thanks in advance! Rob Cluett (3 Replies)
Discussion started by: cluettr
3 Replies

Featured Tech Videos