Visit Our UNIX and Linux User Community


Solaris10 on vmware - Internet connection failed


 
Thread Tools Search this Thread
Operating Systems Solaris Solaris10 on vmware - Internet connection failed
# 1  
Old 07-09-2009
Solaris10 on vmware - Internet connection failed

Installed Sun Solaris 10 (5/09) on vmware 6.0 but system is not connecting to internet.
when I check "ipconfig /all" I do not get any DNS Suffix name -- neither for vmnet1 and vmnet8 nor for local ethernet IP. Default gateways are 192.168.1.1 and 192.168.1.2
1. Created /etc/resolv.conf
domain localdomain
search localdomain
nameserver 192.168.1.1
nameserver 192.168.1.2

2. modified /etc/nsswitch.conf -- "dns" is added
# hosts files dns

3. /etc/inet/hosts and /etc/inet/ipnodes are same
127.0.0.1 localhost
192.168.1.2 johnjerry localhost

4. reboot...

Is there anything I am missing here? Ineternet is not working on my Solaris 10.
# 2  
Old 07-11-2009
Wow, 38 views but NO reply!

Anyway, I have resolved this issue -- just scrapped Sun Solaris 10. My primary objective was installation of oracle 11g on linux environment and today I did it successfully on RHEL5.

Well, there are some glitches on RHEL 5 too. It does not work properly on virtual machine (resolution issue). After painful struggle I was able to identify actual kernel and resolved that error. Afterwards, Database installation was smooth.

Now I feel that though Linux is very strong OS, very few people are here in linux world who can actually resolve issue or assist in some way. Otherwise, most of Linux forums have plethora of problems/questions and limited relevant/presumptive answers.

In another thread, I will post how to resolve Resolution Issue on RHEL 5? (applicable only on virtual machine)

Previous Thread | Next Thread
Test Your Knowledge in Computers #903
Difficulty: Medium
There are less than 10 million lines of code in the Linux kernel as of 2018.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX and Linux Applications

VMware View Client Connection Issues

I installed the VMware View Client for Linux in Ubuntu and whenever I try and connect I recieve: Untrusted View Connection: Failed to connect to the View Connection Server. The server provided an invalid certificate. The certificate authority is invalid or incorrect. Having access to... (2 Replies)
Discussion started by: metallica1973
2 Replies

2. Red Hat

ssh connection keep disconected , how to find way? in CentOs vmware

Hello i have CentOS installed on vmware , few days ago every thing was working fine. today every time im connect with putty to the CentOs server after few minutes it disconnect me , how can i find what is the reason ? (5 Replies)
Discussion started by: umen
5 Replies

3. Solaris

Internet connection failed on solaris 10

Hi, i am new bie on solaris ,i just installed it on vmware. i tryed to connect to the internet from solaris but it failed. during the installation i ignore the DHCP and i assign a fixed ip address to the host. is that has an impact on internet access ? and if so how to add another interface... (3 Replies)
Discussion started by: Mirsol
3 Replies

4. Solaris

internet on solaris10 running on vmware workstation...

HI Admins, I am trying to run internet on solaris 10 on vmware workstation 6.5.. I have vista on my laptop. I tried following: 1. enabling DHCP and NAT on virtual network editor...for NAT I tried vmnet host:vmnet0 start/stop. 2. ifconfig -a showing pcn0 running for both ipv4 and ipv6....... (1 Reply)
Discussion started by: snchaudhari2
1 Replies

5. Virtualization and Cloud Computing

Installing Solaris10 from ISO image in VMware

While installing solaris10 from iso dvd image in vmware on windows i get the follworing error right after i select solaris 10 from grub menu panic/thread=fec20160: page_unlock: page fe2b5730 is not locked why is it doing this? installation does work if i have the physical dvd into... (1 Reply)
Discussion started by: dplinux
1 Replies

6. Solaris

Solaris10..Open boot diagnostic failed

Hi all, when am rebooting the server (SF v890) we are facing "open boot diagnostic failed". Thanks in Adv. (5 Replies)
Discussion started by: arjunreddy3
5 Replies

7. Solaris

Internet setup on solaris10

Hi all, Can anyone please tell me how to setup internet on solaris10, b72? I own an airtel broadband, with a beetel 220BXI modem. I am new to solaris so was wondering as to how it can be done? Thanks (23 Replies)
Discussion started by: wrapster
23 Replies

8. UNIX for Dummies Questions & Answers

Solaris 10 internet access on VMware

Hi, I have Solaris 10 running in VMware on a winxp box so I can learn unix. I can 'ping' all the boxes on our network and yahoo.com (but only if I use the IP address I get back from pinging from an xp box). The error message from the terminal window is unknown host and from a browser www.sun.com... (2 Replies)
Discussion started by: Technomot1
2 Replies

9. UNIX for Dummies Questions & Answers

Howto setup terminal connection Solaris10?

Hello, Which services and daemons are used in Solaris in order to connect to Solaris10 from windows-Reflection ? Please just give me a brief information, I can read details from other resources. Thanks (0 Replies)
Discussion started by: XNOR
0 Replies

10. UNIX for Dummies Questions & Answers

Need help connecting to the internet with solaris10

I am using solaris 10 with pentium 3. I have two network cards but none of them come up when i run <ifconfig -a> in command line. The two cards I have are : Linksys LNE 100TX and Netgear FA311. Does solaris 10 support these NICs or do I have to dowload the drivers for them. If so, can anyone... (1 Reply)
Discussion started by: fidjouss
1 Replies

Featured Tech Videos