Visit Our UNIX and Linux User Community


Keyboard problem


 
Thread Tools Search this Thread
Operating Systems Solaris Keyboard problem
# 1  
Old 05-30-2009
Keyboard problem

Hi to everyone I am new at Solaris world so I need little help.
I can not put my keyboard to Croatian layout.
I tried to edit /etc/default/init and in that file I changed LC_ALL=hr_HR. Also I tried to change my language settings over GUI (input methods and SCIIM) but with no results.
Also tried to change keyboard layout with following commands
setenv LC_ALL hr_HR
but when I restart my PC all changes are restored to default C:POSIX

So my question is : how to change keyboard layout and to apply new configuration that will work
in the future.

P.S I used google but with no successSmilie
# 2  
Old 05-30-2009
The keyboard layout isn't related to the locale.

You can switch to a Croatian layout with these commands to be run in single user mode:
Code:
# kbd -s
...
Select Croatian which should be choice #5
...
# loadkeys

Alternatively, you can run the command
Code:
eeprom keyboard-layout=Croatian

and reboot.
# 3  
Old 05-30-2009
Ok that worked fine, but I do not have special signs that usually I get in combination
alt Gr + others letters
(\|@{}^ł) I am writing it from Ubuntu where my keys works fine

-----Post Update-----
# 4  
Old 05-31-2009
What return these commands for you on both Solaris and Ubuntu:
Code:
xmodmap
xmodmap -pk | grep "(at)"

?

You need to have /usr/openwin/bin in your PATH under Solaris.

What Solaris release are you using (cat /etc/release).
# 5  
Old 05-31-2009
hi

for my ubuntu it retuns
for xmodmap
Code:
xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x69)
mod1        Alt_L (0x40),  Meta_L (0xcd)
mod2        Num_Lock (0x4d)
mod3
mod4        Super_L (0xce),  Hyper_L (0xcf)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)

and for the second command
Code:
 55         0x0076 (v)      0x0056 (V)      0x0076 (v)      0x0056 (V)     0x0040 (at)      0x0060 (grave)

Now I will boot into my Solaris and I will post what do I have under my PATH .

-----Post Update-----

Ok I am now in solaris

for cat /etc/release

Code:
Solaris Express Community Edition snv_113 X86
           Copyright 2009 Sun Microsystems, Inc.  All Rights Reserved.
                        Use is subject to license terms.
                             Assembled 20 April 2009

for xomdmap

Code:
xmodmap:  up to 4 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Meta_L (0x9c)
mod2        Num_Lock (0x4d)
mod3        Mode_switch (0x5d)
mod4        Meta_L (0x73),  Meta_R (0x74),  Super_L (0x7f),  Hyper_L (0x80)
mod5        Mode_switch (0x5d),  ISO_Level3_Shift (0x7c)

and the last command

Code:
55        0x0076 (v)    0x0056 (V)    0x0076 (v)    0x0056 (V)    0x0040 (at)    0x0060 (grave)    0x0040 (at)    0x0060 (grave)

and for the path I have /usr/openwin/bin
# 6  
Old 05-31-2009
Hmm, this looks odd for both Ubuntu and Solaris. I don't understand why you have the symbols repeated, unless the Croatian keyboard has more than two modifiers in use. Shift and AltGr are the one I'm familiar with.

Anyway, assuming you normally get "@" by typing AtlGr+v, you can try to see if this workaround works:

Code:
xmodmap -e "keycode 55 = v V at grave"

# 7  
Old 05-31-2009
Thanks it worked just fine
and now how to resolve other keys , i need others signs which i have on my keyboard
alt gr + qwe bnm kl

PS. Crotian keyboard has support for UTF8 and for ISO 8859-2, but oly UTF8 works

Last edited by microbot; 05-31-2009 at 11:40 AM..

Previous Thread | Next Thread
Test Your Knowledge in Computers #216
Difficulty: Easy
A network operating system is a specialized operating system for a social media company, like Facebook or Google.
True or False?

7 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Problem getting vertical bar with British keyboard layout on US (physical) keyboard

Hi, I've got a bit of a ridiculous problem and wasn't sure where to post it. I need to use the vertical bar for piping in Bash but, as per the title, am using a UK layout on a US (physical) keyboard which doesn't have a key for it in the place I'd expect. I've tried using xbindkeys and Unicode... (7 Replies)
Discussion started by: crunchgargoyle
7 Replies

2. Shell Programming and Scripting

Problem with script invoked from a keyboard shortcut

-EDIT- I have solved my problem below by using a different program. Instead of xsel I am using xclip which basically does the same thing and works fine from a script invoked by a global hotkey. -END EDIT- Hi, I've written a simple script to copy my email address into both the... (0 Replies)
Discussion started by: gencon
0 Replies

3. OS X (Apple)

keyboard problem how to insert --> {} \

I have MACOSX Leoparad and MacBook Pro but I am unable to insert the above letters when I am in terminal any help please? e.g. to insert them I need to press alt+shift+) == } but if I do so pressing alt+shift+) nothing works :( ---------- Post updated at 03:54 AM ---------- Previous update was... (2 Replies)
Discussion started by: c_lady
2 Replies

4. Programming

keyboard type

hi I am using a GUI language (based on C/C++) for my application. Now i need to identify the "Again" key in the Sun keyboard. I tried to do this by getting the ascii value (4155)of it . it was fine. but it is clashing with F12, whose ascii is 4155 in normal keyboards. Due to this either one of... (0 Replies)
Discussion started by: nimishm
0 Replies

5. UNIX for Dummies Questions & Answers

Linux 7.2, Keyboard Problem!

I recently tried to install Linux 7.2 on my home PC (Compaq), and it did not recognise my keyboard. I could not proceed with the installation as I could not type anything. I installed 6.2 and it worked fine???????????. I was wondering if anybody has encountered this problem (very frustrating). ... (4 Replies)
Discussion started by: camerja1
4 Replies

6. UNIX for Advanced & Expert Users

How can I map Unix keyboard for PC keyboard

A Solaris AXI 440 machine with Solaris 8 version. I have PC users who use an emulation to login to the Solaris server. How can I change the keyboard mapping of the Sun keyboard to fit to the PC keyboard ? Any comment will be appreciated. Thanks (1 Reply)
Discussion started by: simhab
1 Replies

7. UNIX for Advanced & Expert Users

Unix and keyboard

Hi, I need to set Unix I/O terminal such as once key "," is pressed charcter "." is shown. Do you have any suggesion? The best to me is to accomplish this feauture with an environment variabile if it is possible. Michele Ferrero (3 Replies)
Discussion started by: micfer
3 Replies

Featured Tech Videos