Visit Our UNIX and Linux User Community


ls command not working


 
Thread Tools Search this Thread
Operating Systems Solaris ls command not working
# 1  
Old 02-09-2009
ls command not working

Hi,

I have installed opensolaris 10 in VMware. Everything is fine except ls command is not working. It is not displaying any files and directories. Sorry if the question is soo trivial.
# 2  
Old 02-09-2009
Is there any error message? Are you sure that the directory contains files or other directories? Because ls won't display anything that isn't there. You can test it with this:
Code:
$ touch foo.bar
$ ls

# 3  
Old 02-09-2009
yeah sorry for giving details. ls is not working even in / ( root ) and also when applied with full path. $PATH is set correctly. It is working when used in GUI but not working when applied in CLI ( commnd line interpreter ).
# 4  
Old 02-09-2009
ls command is not at all working when used in CLI. In opensolaris 10 GUI,
it is working when logged as any user other then root. It is not working when the user is root. sorry for updating the question again n again.
# 5  
Old 02-09-2009
So ls is working when you start it in an xterm (or similar), but returns to the prompt without any output when you start it on the console? Are you starting it as the same user? Is there any difference if you run 'which ls' in the GUI vs the console?
# 6  
Old 02-09-2009
thanks pludi for ur care. there is no difference between 'which ls' in console and gui ( both r displaying /usr/bin/ls ). In xterm, ls is working but after switching to root with su - root, it is not working. In console it is not at all working irrespective of the users.
# 7  
Old 02-09-2009
What happens if you type only ls (enter) as root? Does it give any error message?

Previous Thread | Next Thread
Test Your Knowledge in Computers #98
Difficulty: Easy
Unix was the first operating system that was written in a high-level programming language (C Language).
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Execute ssh command with additional terminal command to any remote user not working script

Hello i am having an issue with bash script and this is the code now=$(cat hosts1.txt | awk '{print $2;}') while read n ;do ssh root@$now 'useradd test1; echo -e "test1\ntest1" | passwd test1 && echo "test1 ALL=(ALL:ALL) ALL" >> /etc/sudoers' When i execute only part with cat, it... (8 Replies)
Discussion started by: tomislav91
8 Replies

2. UNIX for Dummies Questions & Answers

Shell script not working but command works in command prompt

Hi everyone I have a problem with my script If I try directly this command /usr/bin/nice -n 19 mysqldump -u root --password="******" wiki_schneider -c | nice -n 19 gzip -9 > /point_de_montage/$(date '+%Y%m%d')-wiki-db.sql.gz It works But if I simply add this command in a script and... (8 Replies)
Discussion started by: picemma
8 Replies

3. Shell Programming and Scripting

Maxdepth command not working in AIX.Need alternative solution for this command

Hi All, I am trying to select 30 days older files under current directory ,but not from subdirectory using below command. find <Dir> -type f -mtime + 30 This command selecting all the files from current directory and also from sub directory . I read some documention through internet ,... (1 Reply)
Discussion started by: kommineni
1 Replies

4. Shell Programming and Scripting

Working of command

What does the command do lpr -Pqpr *.jpg do ? (1 Reply)
Discussion started by: Nabeel Nazir
1 Replies

5. Shell Programming and Scripting

help with shell script: cp command not working, but mv command works...

Hello. I would like to ask your help regarding the cp command. We are using a cp command to create a back-up copy of our file but to no avail. It's just not working. We already checked the file and directory permissions and all seems correct. We have a script (ftp.script) which calls on... (1 Reply)
Discussion started by: udelalv
1 Replies

6. Shell Programming and Scripting

Need help! command working ok when executed in command line, but fails when run inside a script!

Hi everyone, when executing this command in unix: echo "WM7 Fatal Alerts:", $(cat query1.txt) > a.csvIt works fine, but running this command in a shell script gives an error saying that there's a syntax error. here is content of my script: tdbsrvr$ vi hc.sh "hc.sh" 22 lines, 509... (4 Replies)
Discussion started by: 4dirk1
4 Replies

7. UNIX for Advanced & Expert Users

command for recently modified files - "find" command not working

I have three files a.txt , b.txt , c.txt in a directory called my_dir1 .These files were created before two or three months . I have a tar file called my_tar1.tar which contains three files a.txt , b.txt , d.txt . Somebody untarred the my_tar1.tar into my_dir1 directory. So existing two files were... (1 Reply)
Discussion started by: joe.mani
1 Replies

8. Shell Programming and Scripting

cp command not working

Hi Guys, I have about 12000 files in a folder and I want to copy these to another folder. I am using the cp command to do this but it errors out saying cp -- argument list too long. Is there any way to get around this? I don't want to do a mv but use only cp. Thanks (9 Replies)
Discussion started by: npatwardhan
9 Replies

9. Shell Programming and Scripting

Here command not working

The below is a simple script, but doesnt work. #!/bin/ksh cat <<XYZ -h help -T Test (required) -D Develop (required) XYZ Help is appreciated (5 Replies)
Discussion started by: pinnacle
5 Replies

10. Solaris

last command not working

I have a Solaris 8 Ultra 1 on my network that we use as a utility server. The last command, which looks in the /var/adm/wtmpx file, is not working. When I do a last, the latest entry is dated June 3, but the /var/adm/wtmpx file is dated whenever a login is successful (verified by typing a... (3 Replies)
Discussion started by: antalexi
3 Replies

Featured Tech Videos