Compatibility problem of Tk Module in different versions


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Compatibility problem of Tk Module in different versions

Hi,

I am using Tk module in perl 5.6 and it is working fine. Now when i installed the newer version 5.10.0 then getting error that Tk module not found. But i will have to work on this newer verison only to use some other modules of perl.

I want to know why Tk module is not working in newer version of perl.

Thanks
Kunal
# 2  
You are sure the include path @INC includes the directory where the previous Tk was installed and it's still there?
# 3  
I searched for my problem and found that instead of Tk in 5.6 , 5.10 uses Tkx module. I think I will have to change my code according to the syntax of Tkx module.
# 4  
This is a known problem. The solution is to get the source for the Tk module from https://svn.perl.org/modules/Tk/trunk and rebuild it
# 5  
I am facing one more problem. I want to connect oracle database through perl. For it i am using DBI module which is not working for perl 5.6 so do i need to install some driver for it?

Thanks
Kunal

Last edited by kunal_dixit; 07-31-2008 at 04:40 AM..
# 6  
Please provide sample code so we can see what you are doing
# 7  
sample code:------------


use DBI;
use DBD::Oracle qw(Smiliera_types);

my $dbh = DBI->connect( "dbi:Oracle:SILAB", "tdbu01", "tdbu01",@t1)
|| die( $DBI::errstr . "\n" );


my $sth = $dbh->prepare( "SELECT * FROM employee" )
or die "Can't prepare SQL statement: $DBI::errstr\n";


$sth->execute
or die "Can't execute SQL statement: $DBI::errstr\n";

my @row;
while ( @row = $sth->fetchrow_array( ) ) {
print "Row: @row\n";
}


the problem is not in this code as it works fine with perl 5.10.
But as I wrote my complete code for 5.6(as already mentioned using module Tk not Tkx for GUI interface), I want to hit the database using 5.6 only.

Advance Thanks for your suggestions
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #302
Difficulty: Easy
The GNU website is the official repository for Slackware.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Rsync problem versions out of sync

Hello, I have a report which I am writing as a .tex file, and I am editing from two computers (office and home laptop). I use rsync over ssh connection to synchronise between them and all the rssync commands are written in a Shell script. #synchronise from office computer to home laptop... (2 Replies)
Discussion started by: ajayram
2 Replies

2. Shell Programming and Scripting

problem during perl module installation

Hi 'm getting error while installing perl mdule on linux.can any one tell me how to resolve that error? problem is: CPAN: File::Temp loaded ok (v0.22) CPAN.pm: Going to build J/JD/JDB/Win32-OLE-0.1709.tar.gz OS unsupported Warning: No success on command Warning (usually harmless):... (1 Reply)
Discussion started by: kavi.mogu
1 Replies

3. UNIX for Advanced & Expert Users

Problem loading cpufreq module

I'd like to install cpufreq modules on my server . I tried sudo modprobe acpi-cpufreq but got the error FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.18-238.12.1.el5xen/kernel/arch/x86_64/kernel/cpufreq/acpi-cpufreq.ko): No such device cat /proc/cpuinfo gives this ... (11 Replies)
Discussion started by: vishwamitra
11 Replies

4. AIX

apache/tomcat compatibility with AIX versions

Hello, Where can i find the information about the compatibility versions of tomcat with AIX? for example, AIX 5.2 supported tomcat versions?? (1 Reply)
Discussion started by: balareddy
1 Replies

5. SCO

SCO unix binary compatibility problem

Hi I am looking for sco xenix binary compatibility utility "cvtomf",(convert omf object to COFF object) Would you please help me ? tnx (3 Replies)
Discussion started by: javad1_maroofi
3 Replies

6. Linux

problem with kernel module loading

Hi masters, I am new to linux and unix forum and this is my first forum. So please excuse if I am not giving sufficient information. I will give them on request. I have created a bandwidth manager module. I am using a 2.6.9 kernel and in Red Hat 3.4.3 distribution. But when i run make... (1 Reply)
Discussion started by: iamjayanth
1 Replies

7. Red Hat

Problem with kernel-module-ntfs

Hi All Im trying to access the my windows XP NTFS from Redhat linux 4.0 Enterprise edition I have downloaded the respective rpm And im able to install it successfully Then i have given the following command , but got an error Here are my partitions And when i give the below... (1 Reply)
Discussion started by: balumankala
1 Replies

8. Programming

Basic multi module problem

I am trying to learn how to use multiple modules and hearder files. I have tried a little experiment but cannot get it to work. Here is my code and compilation attempt. Any help with finding my problems appreciated. The main function (main01.c) calls a function located in another file... (9 Replies)
Discussion started by: enuenu
9 Replies

9. Filesystems, Disks and Memory

having problem in understanding namei module

can anyone give me some idea on unix filesystem namei's algorithsm (2 Replies)
Discussion started by: kangc
2 Replies

10. Shell Programming and Scripting

compatibility problem ??!!

hi! i have two problems with the following script who prepares a date (removes the heading zero from day if day<10) for arithmetical operations: <script> #!/usr/bin/sh DAY=`date +%d`; echo 1 - $DAY;#i.e. 06 DAY=${DAY#0}; echo 2 - $DAY;#i.e. 6 </script> 1. every time i run this... (3 Replies)
Discussion started by: oti
3 Replies

Featured Tech Videos