newer version of the parser installed,yet get the older one itlself,hows it possible?


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
Top Forums Shell Programming and Scripting newer version of the parser installed,yet get the older one itlself,hows it possible?
# 1  
newer version of the parser installed,yet get the older one itlself,hows it possible?

Hi all,

I downloaded a XML parser lib from blastwave.org...
Its the "libxml2",but i am having trouble initializing it(or so it feels)...I kind of need it badly as the OSE version of the virtualbox 1.6.2 will not install unless i have one

The version was 2.6.3...
The min requirement from virtualbox was 1.6.23
But even after an installation when i try to install virtualbox it still show me that i need a higher version of libxml2.
I am very sure that i have downloaded the higher version,reason being that the download link states its a ver 2.6.3
So how do i counter this?

Is there a way to check the version of my newly installed parser?

Thanks
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #480
Difficulty: Easy
Memory addresses are represented using hexadecimal, which is a base-8 counting system.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Bash find version of an installed application but if none is found set variable to App Not Installed

Hello Forum, I'm issuing a one line bash command to look for the version of an installed application and saving the result to a variable like so: APP=application --version But if the application is not installed I want to return to my variable that the Application is not installed. So I'm... (2 Replies)
Discussion started by: greavette
2 Replies

2. Shell Programming and Scripting

Removing older version files

Hi, I have a direcory as mentioned below: /development/arun/cycdt/ unser the above i have directories /2013 /2012 /2011 ...... ..... /2000 I need to write a script which can delete the nth version of the directories. as in if n=10 then the script should arrange the directories in... (2 Replies)
Discussion started by: Arun Mishra
2 Replies

3. Ubuntu

Installation of older version of rsyslog

Hi, I am trying to downgrade the version of rsyslog to the older version (i.e) and when i issue the below command to check the packages i dont see the required package (i.e) and when i try to install it is complaining about package not found. Please advise on how to install the... (1 Reply)
Discussion started by: prash358
1 Replies

4. Shell Programming and Scripting

installed java version ?

Hi, I want to know what version of the java is installed? Please let me know the command or process to identify the installed java version in sun solaris box. Thanks in advance for all your support. (3 Replies)
Discussion started by: sridhardwh
3 Replies

5. Shell Programming and Scripting

For loop in older version of ksh

When I am trying to use below code of for loop on older version of ksh it not working,and I just want to use only FOR loop ----------------- for i in (1..5) do echo $i done ----------------- please suggest.it really stoping me. FYI: i want to do this only by for loop (2 Replies)
Discussion started by: RahulJoshi
2 Replies

6. Shell Programming and Scripting

how to find a file then overwrite with a newer version

This should be a simple script, but can't find one with google search. I just need to find the file that is in many directories, then overwrite that file with a newer version i.e. find file.jar then overwrite with /root/file.jar All I get in searches is substitute text with new test inside... (1 Reply)
Discussion started by: haircat
1 Replies

7. Shell Programming and Scripting

recently introduced to the newer option for find...does an older option exist?

To find all the files in your home directory that have been edited in some way since the last tar file, use this command: find . -newer backup.tar.gz Is anyone familiar with an older solution? looking to identify files older then 15mins across several directories. thanks, manny (2 Replies)
Discussion started by: mr_manny
2 Replies

8. UNIX for Dummies Questions & Answers

.profile has been replaced and need to get the older version

Hi All, .profile has been replaced with a new one. I need to know the variables used in the older version of .profile. I have a session opened using the old .profile. Is there a way that I can get the exact file. I had some luck by using set command. But is there any way that I can get the... (5 Replies)
Discussion started by: shash
5 Replies

9. Shell Programming and Scripting

Which version of perl is installed on my system?

Hi, With the command perl -v i can see the perl version, but it's like a text file.. is there a command which could give me just the perl version number? i.e.: "5.8.1" thanks!! (6 Replies)
Discussion started by: kfad
6 Replies

10. UNIX for Advanced & Expert Users

How to Find the OS version Installed

Hi, I wanted to know how can I get the version of underlying HP-OS installed on a HPUX workstation. The output required is "June 2001" version or "March 2003" version etc whatever OS is present. Thanx in advance for your help. Regards, Pankaj (3 Replies)
Discussion started by: pankschawla
3 Replies
SAX::ParserFactory(3)					User Contributed Perl Documentation				     SAX::ParserFactory(3)

NAME
XML::SAX::ParserFactory - Obtain a SAX parser SYNOPSIS
use XML::SAX::ParserFactory; use XML::SAX::XYZHandler; my $handler = XML::SAX::XYZHandler->new(); my $p = XML::SAX::ParserFactory->parser(Handler => $handler); $p->parse_uri("foo.xml"); # or $p->parse_string("<foo/>") or $p->parse_file($fh); DESCRIPTION
XML::SAX::ParserFactory is a factory class for providing an application with a Perl SAX2 XML parser. It is akin to DBI - a front end for other parser classes. Each new SAX2 parser installed will register itself with XML::SAX, and then it will become available to all applications that use XML::SAX::ParserFactory to obtain a SAX parser. Unlike DBI however, XML/SAX parsers almost all work alike (especially if they subclass XML::SAX::Base, as they should), so rather than specifying the parser you want in the call to "parser()", XML::SAX has several ways to automatically choose which parser to use: o $XML::SAX::ParserPackage If this package variable is set, then this package is "require()"d and an instance of this package is returned by calling the "new()" class method in that package. If it cannot be loaded or there is an error, an exception will be thrown. The variable can also contain a version number: $XML::SAX::ParserPackage = "XML::SAX::Expat (0.72)"; And the number will be treated as a minimum version number. o Required features It is possible to require features from the parsers. For example, you may wish for a parser that supports validation via a DTD. To do that, use the following code: use XML::SAX::ParserFactory; my $factory = XML::SAX::ParserFactory->new(); $factory->require_feature('http://xml.org/sax/features/validation'); my $parser = $factory->parser(...); Alternatively, specify the required features in the call to the ParserFactory constructor: my $factory = XML::SAX::ParserFactory->new( RequiredFeatures => { 'http://xml.org/sax/features/validation' => 1, } ); If the features you have asked for are unavailable (for example the user might not have a validating parser installed), then an exception will be thrown. The list of known parsers is searched in reverse order, so it will always return the last installed parser that supports all of your requested features (Note: this is subject to change if someone comes up with a better way of making this work). o SAX.ini ParserFactory will search @INC for a file called SAX.ini, which is in a simple format: # a comment looks like this, ; or like this, and are stripped anywhere in the file key = value # SAX.in contains key/value pairs. All whitespace is non-significant. This file can contain either a line: ParserPackage = MyParserModule (1.02) Where MyParserModule is the module to load and use for the parser, and the number in brackets is a minimum version to load. Or you can list required features: http://xml.org/sax/features/validation = 1 And each feature with a true value will be required. o Fallback If none of the above works, the last parser installed on the user's system will be used. The XML::SAX package ships with a pure perl XML parser, XML::SAX::PurePerl, so that there will always be a fallback parser. AUTHOR
Matt Sergeant, matt@sergeant.org LICENSE
This is free software, you may use it and distribute it under the same terms as Perl itself. perl v5.16.3 2009-10-10 SAX::ParserFactory(3)

Featured Tech Videos