Installing RPM package using alien on WSL Ubuntu


 
Thread Tools Search this Thread
Top Forums Shell Programming and Scripting Installing RPM package using alien on WSL Ubuntu
# 1  
Old 10-17-2018
Installing RPM package using alien on WSL Ubuntu

I was just flirting with the idea of installing one package (bcl2fas2) on my WSL:Ubuntu using alien. However, when I run
Code:
sudo alien bcl2fastq2-v2.20.0.422-Linux-x86_64.rpm

I get the following error:
Code:
Package build failed. Here's the log:
dh_testdir
dh_testdir
dh_testroot
dh_prep
dh_installdirs
dh_installdirs: Compatibility levels before 9 are deprecated (level 7 in use)
dh_installdocs
dh_installdocs: Compatibility levels before 9 are deprecated (level 7 in use)
dh_installchangelogs
find . -maxdepth 1 -mindepth 1 -not -name debian -print0 | \
        xargs -0 -r -i cp -a {} debian/bcl2fastq2
dh_compress
dh_compress: Compatibility levels before 9 are deprecated (level 7 in use)
dh_makeshlibs
dh_installdeb
dh_installdeb: Compatibility levels before 9 are deprecated (level 7 in use)
dh_shlibdeps
dh_shlibdeps: Compatibility levels before 9 are deprecated (level 7 in use)
dh_gencontrol
dpkg-gencontrol: warning: Depends field of package bcl2fastq2: unknown substitution variable ${shlibs:Depends}
dh_md5sums
dh_builddeb
dpkg-deb: error: control directory has bad permissions 777 (must be >=0755 and <=0775)
dh_builddeb: dpkg-deb --build debian/bcl2fastq2 .. returned exit code 2
dh_builddeb: Aborting due to earlier error
debian/rules:17: recipe for target 'binary-arch' failed
make: *** [binary-arch] Error 2

Is there any way to accomplish this task on WSL?
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

Does not appear to be a RPM package

Hi Guys I got this error when I try to install perl-5.24.0-1.aix6.1.ppc.rpm package rpm -ivh perl-5.24.0-1.aix6.1.ppc.rpm error: perl-5.24.0-1.aix6.1.ppc.rpm does not appear to be a RPM package (4 Replies)
Discussion started by: khaled_ly84
4 Replies

2. UNIX for Advanced & Expert Users

Protected RPM package

Is there a way to create a protected RPM package without giving up your source code? (2 Replies)
Discussion started by: cokedude
2 Replies

3. Emergency UNIX and Linux Support

Problem when trying to remove a package using rpm command - error: package is not installed

Hello, i have installed a package by using the command sudo rpm -i filepackage.rpm package filepackage is already installed when i try to remove it, i get an error saying "is not installed": sudo rpm -e filepackage.rpm error: package filepackage is not installed How can... (4 Replies)
Discussion started by: g_p
4 Replies

4. UNIX for Dummies Questions & Answers

Can't install rpm package with --prefix in new path.Error: package is not relocatable

Hello, i have downloaded an rpm package "hadoop-0.20.205.0-1.amd64.rpm" in /usr/local/ directory. I'm trying to install the rpm package in a new path/location (/usr/local/hadoop-0.20.205), but i can't. I did: 1st try: Didn't work sudo rpm -i --prefix=/usr/local/hadoop-0.20.205... (1 Reply)
Discussion started by: g_p
1 Replies

5. Ubuntu

Installing md5 package into ubuntu

Hi i want to install md5 package into ubuntu. any idea how? Apparently applying md5sum and md5 on a string (not a file) gives a different value! The one that I need to use is the md5 command, but it says command not found when i type md5 in bash. (2 Replies)
Discussion started by: jremio
2 Replies

6. UNIX for Advanced & Expert Users

How to find dependancies of .dstream package (Solaris) & .rpm package( linux)

Friends, Please let meknow, How we can find the dependancies of .dstream package & .rpm package before installation ? For AIX, We can use the inutoc . command to create the .toc file for the bff package, What about Solaris & Linux ? (0 Replies)
Discussion started by: yb4779
0 Replies

7. Red Hat

RPM package installation

Hi, can someone help me with this? How do we apply a new version of s/w package without disrupting the processes & daemons running with the old version? Thanks (1 Reply)
Discussion started by: naan
1 Replies

8. Ubuntu

Rpm package

Hi All, I just recently installed UBUNTU 2.6.24-16 and i installed my phone software which is a RPM package (it's a similiar package with MSN). The software called MXIE. I managed to install it successfully but i can't run the software. When i try to run it, i received... (8 Replies)
Discussion started by: c00kie88
8 Replies

9. Linux

how to restore original package after uninstalling the upgraded package using rpm

have following package installed rpm -qa |grep ADMIN It will give the following package installed: ADMIN-4.0.0.1 Now I will upgrade the ADMIN package using the following command. rpm --upgrade ADMIN-4.1.0.1 It will upgrade the ADMIN packagge to ADMIN-4.1.0.1 Now I want that... (0 Replies)
Discussion started by: amitpansuria
0 Replies

10. Shell Programming and Scripting

User installing a rpm package

Hi, I have an application to be installed and I want a user to be able to install it. But I meet the following issues: Removing MyApp error: cannot get exclusive lock on /var/lib/rpm/Packages error: cannot open Packages index using db3 - Operation not permitted (1) error: cannot open... (1 Reply)
Discussion started by: potro
1 Replies
Login or Register to Ask a Question

Featured Tech Videos