mailx not working on SunOS 5.9


 
Thread Tools Search this Thread
Top Forums Shell Programming and Scripting mailx not working on SunOS 5.9
# 1  
Old 08-23-2012
mailx not working on SunOS 5.9

I m trying to send o/p of one file using mailx command but is not working

PFB command :


Code:
 
cat healthchecklog | mailx -s "HEALTH CHECKS" abc@jkl.com

also I have checked the ps -ef for mailx which is giveing below o/p

Code:
 
ps -ef | grep mail

    root   364     1  0   Jun 08 ?        1:09 /usr/lib/sendmail -bd -q15m
   smmsp   365     1  0   Jun 08 ?        0:09 /usr/lib/sendmail -Ac -q15m

please help this out urgently
# 2  
Old 08-23-2012
try using...

Code:
/bin/mail -s

# 3  
Old 08-23-2012
Look at /etc/syslogd.conf and find out where your mail log is.
Providing that you didn't actually get an error message from the mailx command, the diagnostics should be in the mail log.
# 4  
Old 08-23-2012
i reffered the syslogs and its giving below error at many places.

Quote:
Deferred: Connection refused by def.abc.com
# 5  
Old 08-23-2012
I'm assuming that def.abc.com is different from abc@jkl.com .

This suggests that the mail relay host referred to in the DS line in sendmail.cf is broken or misconfigured in some way. If this has never worked, then perhaps the mail relay host is not listening for SMTP mail or does not know that your server exists.

You should be able to see how much mail you have queued with the mailq command.

Btw. If you get an error message, please post the whole error message (blotting anything confidential like email addresses or machine names with Xs).
# 6  
Old 08-23-2012
o/p of mailq command

Code:
 
-----Q-ID----- --Size-- -----Q-Time----- ------------Sender/Recipient-----------
q7ND06XW004652    35745 Thu Aug 23 14:00 <qrs@a.b.com>
                 (Deferred: Connection refused by def.abc.com )
                                         <abc@jkl.com >
q7NC06XW006578    30147 Thu Aug 23 13:00 <qrs@a.b.com>
                (Deferred: Connection refused by def.abc.com )
                                         <abc@jkl.com >

# 7  
Old 08-23-2012
Is this a new configuration, or one which used to work?

You can try to see if the mail relay server is listening at all and if so, what Operating System it is:
Code:
telnet def.abc.com 25

(Use ctrl/] to get out of the telnet).

Before long you are going to need to talk to the administrator of the SMTP mail relay server.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

--SunOS 5.10 nawk for paragraph not working

The machine is using bash: ================== bash -version GNU bash, version 3.2.51(1)-release (i386-pc-solaris2.10) Copyright (C) 2007 Free Software Foundation, Inc. ========================= I have the following xml file. am trying to get a whole paragraph if it meets certain criteria.... (9 Replies)
Discussion started by: gilgamesh
9 Replies

2. Solaris

Sendmail not working in SUNOS

Hi All i am trying to send a mail from SunOS to my outlook mail but it is not working neither giving any error please suggest # uuencode /tmp/t.txt t.txt | mailx -s test v.com # # uname -a SunOS 5.9 Generic_122300-25 sun4u sparc SUNW,Sun-Fire-V440 (3 Replies)
Discussion started by: scriptor
3 Replies

3. UNIX for Advanced & Expert Users

Manipulate files with find and fuser not working as expected on SunOs

Greetings, For housekeeping, I use the following command: find /some/path -type f -name "*log*" ! -exec fuser -s "{}" 2>/dev/null \; -exec ls -lh {} \; It finds all log files not currently in use by a process and manipulates them. This command always works on linux and redhat machines,... (2 Replies)
Discussion started by: dampio
2 Replies

4. Solaris

SunOs 5.9: why is 'ulimit -c' not working?

I have a situation where the system is dumping a 2g causing filesystem to fill up. We identified the source and working on a solution. However, I wanted to limit the size of the 'core' file. Please examine the test scenario ... cnewtonne@mars> ulimit -f 0 cnewtonne@mars> ls -ltr core*... (2 Replies)
Discussion started by: cnewtonne
2 Replies

5. Solaris

All i/o (ftp) not working on this SunOS 5.10

Hi everyone: I have been trying to simply FTP a file over to this SunOS 5.10 (which is same as Solaris 10 now) and nothing works! I can only Telnet to this via SSH (with my own account/uid), and I can also send simple mail out with mailx, that's all!!! I cannot FTP to it (I think FTP... (7 Replies)
Discussion started by: steve701
7 Replies

6. Shell Programming and Scripting

mailx is not working

i have a file.i want to get that file to my mail.mail services are running.but still i didn't receive the mail. i have used this command. mailx -s file1 muraliinfy04@gmail.com < file2.txt.can anybody help me.it's urgent.I am new to unix. actually file1 i have directed to a file2.txt (8 Replies)
Discussion started by: muraliinfy04
8 Replies

7. Solaris

mailx not working

i am supporting a server running Solaris 5.6.I don't know if the mail is configured on this server. i ran the following commands and got the corresponding output. #which mailx /usr/bin/mailx #ps -ef | grep sendmail root 601 1 0 Jan 10 ? 0:01 /usr/lib/sendmail... (1 Reply)
Discussion started by: asalman.qazi
1 Replies

8. Shell Programming and Scripting

mailx not working

Hi All, I am strugging with mailx. I have a shell script which triggers mail when executed. I have mailx utility installed in system under /usr/bin/mailx but still when that script executes i am not getting mails..any idea why strange behaviour..? Tha:(nks in advance Usha (2 Replies)
Discussion started by: usha rao
2 Replies

9. Solaris

tr -d is not working on SunOS 5.9

i am using sunos 5.9. entityname="india\/delhi" correctpattern="<branch value=\"/`echo $entityname | tr -d '\'`/WORKAREA/\"> echo $correctpattern the output should be <branch value="/india/delhi/WORKAREA/"> This is working fine in command line but not working when i placed these... (1 Reply)
Discussion started by: millan
1 Replies

10. UNIX for Dummies Questions & Answers

SunOS 5.10 - VI Arrow keys not working

Hi I am working on SunOS 5.10 from remote terminal using putty. Also echo $TERM xterm In vi editor when in insert mode arrow keys are not working for cursor movement instead they print A B C and D. Please help. thanks ravs (7 Replies)
Discussion started by: ravashingravi
7 Replies
Login or Register to Ask a Question

Featured Tech Videos