automake distclean does work, but distcheck gives error


 
Thread Tools Search this Thread
Top Forums Shell Programming and Scripting automake distclean does work, but distcheck gives error
# 1  
Old 08-14-2011
[solved]automake distclean does work, but distcheck gives error

When I run autogen.sh(the auto hell stuffs+configure) and type "make distclean", I get a proper result(which can be built).
However, when running autogen.sh and then "make distcheck", I get an error:
...
Code:
rm -f Makefile
ERROR: files left in build directory after distclean:
./src/MediaPlayer.c
./src/GNOME_MPRIS_Applet_vala.stamp
./src/MasterDBus.c
./src/TrackList.c
./src/PlayersList.c
./src/MainApplet.c
./src/Player.c
./src/main.c
./src/PlayerAbilities.c
make[1]: *** [distcleancheck] 1 הלקת
make[1]: Leaving directory `/home/tal/Projects/MPRIS_Applet/GNOME_MPRIS_Applet/gnome-mpris-applet-0.0.1/_build'
make: *** [distcheck] 1 הלקת

Other than that, everything works like magic. But if distcheck say something is wrong, he probably right.
Also, you shell noticed than this scripts compile from vala language if compiler exist, otherwise it use C compiler.
(Vala compiles first to C, and then to binaries)
So, why it keeps failing?

My work(108 kb):gnome-mpris-applet-0.0.1.tar.bz2

Last edited by Tal500; 08-15-2011 at 08:01 AM..
# 2  
Old 08-14-2011
I am working on this bro hold on
# 3  
Old 08-15-2011
Bug

Thanks, someone has already given me the answer.
For it work perfectly, change the if statement in src/Makefile.am to this:
if USE_VALA
GNOME_MPRIS_Applet_PACKAGES=@applet_PACKAGES@
GNOME_MPRIS_Applet_SOURCES = \
$(GNOME_MPRIS_Applet_VALASOURCES)

VALAFLAGS= \
$(GNOME_MPRIS_Applet_PACKAGES)
else
GNOME_MPRIS_Applet_SOURCES = \
$(GNOME_MPRIS_Applet_VALABUILTSOURCES)
endif

And remove the "GNOME_MPRIS_Applet_SOURCES" deceleration after the if.
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Compiling automake-1.15 in Solaris 10 SPARC

Hi there. I have unzipped automake-1.15.tar.gz into a directory on my HDD that has Solaris 10 SPARC OS installed inside a SUN/Oracle SPARC server. I can configure automake-1.15 successfully but when I try to compile automake-1.15 using 'make command, I have the following error message.. ... (4 Replies)
Discussion started by: alphatron150
4 Replies

2. Shell Programming and Scripting

using automake and autoconf with C++

hi, I have written the Makefile.am and autoconf.ac files and am looking to build my project by providing the following commands: $autoreconf -f -i -m $./configure both of the above work fine, but when I give the make command, I get the following error: make all-am make: Entering directory... (0 Replies)
Discussion started by: bacpp
0 Replies

3. Shell Programming and Scripting

automake does not create Makefile.in

hi all, I have written a simple C program hello.c and a Makefile.ac but when i try to run automake it does not create Makefile.in hence I am not able to run ./configure command in my directory. Following are the containts of my prog. hello.c -------- Code: #include<stdio.h> main() {... (0 Replies)
Discussion started by: useless79
0 Replies

4. UNIX for Advanced & Expert Users

KDE Needs Automake >= 1.6.1 -- I have 1.11

Hi, I'm on Fedora-11-x86_64 with KDevelop 3.5.4. I have automake 1.11 installed, but when I attempt to run automake and friends on a new project I get: *** YOU'RE USING automake (GNU automake) 1.11 *** KDE requires automake 1.6.1 or newer I reported(KDevelop) the error Bug: 210084 ... (11 Replies)
Discussion started by: lucelio
11 Replies

5. Solaris

PHP 5.3 compile on Solaris 10 : make distclean :: fatal error

I'm trying to install PHP 5.3 on Solaris 10 . I'm using etc/apache2 and installed mysql 5.1.39. When I tried to compile PHP 5.3, with the following configure text, ./configure --with-mysql=/usr/local/mysql \ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-zlib-dir=/usr/local \... (21 Replies)
Discussion started by: ppa108
21 Replies

6. Programming

Dependencies problem GNU automake

I am using the GNU automake. I have created the Configure.in and Makefile.am files but don't know how to link in my dependencies. I have basically added another project (OpenCV) to my eclipse workspace and want to reference this in the build. I have set Eclipse up to include the Cpp files... (5 Replies)
Discussion started by: hembergb
5 Replies

7. Programming

automake/autoconf problem

hi, i'm fairly new with automake and i ran into a problem that i have found no solution for. so i have a setup where i don't want all the output files generated by the compiler and alike in my src directory, instead i created a build/unix folder and i have build/unix/config set for... (0 Replies)
Discussion started by: Akimaki
0 Replies

8. UNIX for Dummies Questions & Answers

how to give link to new install automake

helo , i m using RHEL 4 and in that automake -2.59 now i install automake-2.61 but when i say # rpm -qa |grep automake it shows only automake-2.59 actually i want to use automake-2.61 so how to resolve this issue amit (5 Replies)
Discussion started by: amitpansuria
5 Replies

9. UNIX for Advanced & Expert Users

automake

hi on machine automake 1.9 are install but i am not able create make file so please tell me what proper command to create make file using automake (1 Reply)
Discussion started by: munnu
1 Replies
Login or Register to Ask a Question

Featured Tech Videos