Need Help With System Recovery After HD Errors


 
Thread Tools Search this Thread
Operating Systems SCO Need Help With System Recovery After HD Errors
# 22  
Old 02-27-2017
Yeah, I needed to take more time with this, but I got a new license from Microlite for version 3 and I ftp'd the edgesco5.elf file over and installed it. Backup Edge did not find my tape drive, so I now figure that I need to install a driver for the SCSI adapter to which it is attached.

The adapter is Adaptec AHA 2940W/2940UW and I found a driver online that I can download, however it says that it is for the 7800 family manager set. I found my old floppy that says the same thing, and there are some commands written on it that appear to be what I should type in at the Boot: prompt, here is what the notes say:

Code:
ahslink pkg=alad325 replace=routine 21

Does that seem like something that would work? Let me know if I should try this before downloading the driver and trying to make a new floppy. Thanks.

Moderator's Comments:
Mod Comment
Please wrap all code, files, input & output/errors in CODE tags.
It makes it easier to read and preserves multiple spaces for indenting or fixed width data.


---------- Post updated at 09:18 AM ---------- Previous update was at 08:41 AM ----------

I just now read that there maybe another way to install the driver now that OpenServer is already installed? Should I use the "installpkg" option instead? I could use some guidance as to how I add my Adaptec SCSI driver so I can access my tape drive. Thanks a bunch!

---------- Post updated at 11:00 AM ---------- Previous update was at 09:18 AM ----------

Well, given enough time I seem to have figured out several things on my own. The Adaptec adapter was already being recognized by SCO, and the tape drive was recognized by the server and gave me the SCSI LUN ID information I needed to perform "mkdev tape" and I have the tape drive operational now! I am going to insert my latest backup tape and get a listing of what is on it so I can decide what I need to restore. I am thinking that I want to restore all directories under / (root), because I have no current tech support for my legacy application, and I don't know how many directories it is using - I am sure it was several.

Are there any directories I should avoid overwriting so I don't affect the current "good" installation of 5.0.6? I am pretty sure I had also installed the supplement 5.0.6a update at some point - will that be restored with my backup or should I reinstall that from the CD first? Any guidance will be helpful. Thanks.

Last edited by rbatte1; 02-27-2017 at 12:51 PM.. Reason: Added CODE tags
# 23  
Old 02-27-2017
Do not restore /etc/conf. You will have to re-install RS506a and any other patches as well. These are important because they ensure that your system is Y2K compliant.
# 24  
Old 02-27-2017
5.0.6a supplements were installed successfully. I am trying to find out exactly what directories are on my backup. I have ran a verify/list function from the edgemenu, and it appears there are no problems with my tape. I did not sit and watch every file name as it was being verified, thinking I would get to see a list afterward - but I can't find the list to check. I know there are the following: /u, /usr, /lost+found, /etc, and more. As they scroll through all of the listings are prefaced with a ./ - is that normal? When I get ready to restore and enter my list of directories, will I use the . before the /? Is it worth the time to hook up the old hard drive just long enough to get the directory names under the / directory? I feel like I'm almost there, I just don't want to do anything wrong with the restore to undo my work so far. Thanks!
# 25  
Old 02-27-2017
There should be a copy of the file listing in /usr/lib/edge/lists/menu
You may have to also check /usr/lib/edge/lists/simple_job.
If you restored everything excep /etc/conf, then you should have everything that was on the old hard drive.
What may be different is that /u, for instance, might have been a file system on the old system, but is now just a directory in the root file system.
# 26  
Old 02-28-2017
I did a full backup of the system after my reinstall, before doing the Restore from my tape. I had to clean the heads of my tape drive, luckily I still had a cleaning tape and it worked. I restored everything except /etc/conf and the job completed "with exceptions" - but I don't know what they were or if important.

The one problem is that /u is a File System, I know this for a fact, but I don't remember what type of File System. After the restore and reboot, it looks like it tried and failed to mount the /u filesystem - it just said "failed to mount". I know this is where most of the inner workings of my legacy application live, so can you tell me what steps to take in order to try and remount this /u file system?

Thanks - you have been VERY helpful and I appreciate it.

---------- Post updated at 04:19 PM ---------- Previous update was at 02:11 PM ----------

Been reading up a little, it looks like I need to run divvy to create the u division on the disk. Old system had root from 539648 - 10000025, and u from 10000026 - 38973679 (40 GB hard drive)

Current system shows root from 539648 -134070446 (140 GB hard drive) I think divvy will let me create the u division and I can probably figure a size. If this is the correct action, should I first delete everything I "restored" to the /u directory? Then would I create and mount the file system, and do a new restore of the /u on the backup tape?

Let me know if I am on the right track, or what else to do. Thanks again.
# 27  
Old 02-28-2017
The boot file system is EAFS, the root and any other (/u) file systems default to HTFS.
You cannot re-size an HTFS partition without losing the data that is on it. So you will not be able to add the /u file system without doing a full backup and standalone restore.
From an operational point of view, it will make no difference if /u is a file system, or simply another directory in the root file system.
If you must, do a full backup, boot from the Edge recovery media, re-size the partitions, and do full restore.

---------- Post updated at 08:02 PM ---------- Previous update was at 07:20 PM ----------

I now what happened. When you restored the old data, you restored /etc/default/filesys, which has the file system configuration. Unfortunately the one that has been restored contains info on /u but that file system no longer exists.
Just use a text editor and remove the references to /u.
# 28  
Old 03-01-2017
My only concern is functionality, and since I was under the false impression that I needed the separate file system, I didn't even check it yesterday. Now that I have, it is working GREAT!! All of the operations that we needed from our old system is basically the ability to look at, print and/or email the historical information that we have going back about 20 to 25 years. All of that is operational and I will be a hero now - thanks for all your help with this.

There are just a couple of "cleanup" issues - SCO keeps complaining that I have software that is not registered - I have entered the license numbers I have, but I remember there was a website you had to go on and get a Registration Key. Is there still a place to do that?

Also, in my tinkering around I was able to get SCO installed on a VM, using VM Workstation version 12.5 in a Windows 7 Pro-64 computer. I chose the VM Workstation 8.x compatibility model for my VM, an IDE hard drive at 0:0 and an IDE CD Rom at 1:0 using the physical drive of the computer. Using the defbootstr command at installation it went like a champ. I even installed the keyboard mouse and the graphic screen/mouse is working. The only problem I have is I can't find instructions about how to install the network card driver. I selected "bridge mode" when I created the VM, and SCO did not recognize my NIC at installation, it is a Realtek PCIe GBE Family NIC on the mother board. I believe it is compatible with 5.0.6a, and I think I found the driver, but I have no clue how to get it installed. My only option is from a CD (I think) and I don't know how to do that. The Software Manager does not recognize what I downloaded and burned to the CD as "software" and I am clueless - could you advise me? I can't find any instructions online. I would like to have this VM as a "backup" plan, I would not use it unless the physical server goes down again. Thanks again for all your help.
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. Red Hat

Linux system hangs giving ntp errors

Hi folks, I am facing issue of my system (host1) getting hanged after throwing following ntpd messages. I am not able to ssh to the server there after. only option is to restart the host: Dec 29 02:58:51 host1 ntpd: time reset -0.207907 s Dec 29 02:58:51 host1 ntpd: synchronisation lost Dec 29... (0 Replies)
Discussion started by: SiddhV
0 Replies

2. UNIX for Advanced & Expert Users

fsck.gfs2 outputs "RG recovery impossible; I can't fix this file system"

I have a CentOS release 5.2 (Final)host running kernel 2.6.18-92.el5 with at raid 10 that had two mirrored drives fail. The drives were re-inserted and now the raid shows healthy (for now). I tried to mount but got an Input/output error. I then attempted a fsck: fsck.gfs2 -y /dev/vg_01/uss_vol... (0 Replies)
Discussion started by: king_hippo
0 Replies

3. UNIX for Advanced & Expert Users

linux system recovery after overriding connect() by "ld.so.preload"

dear fellows; i have used ld.so.preload file to override connect() function, dynamic library overriding, it did worked really fine ...... but i went on to struck in a situation ... within the overrided connect() i have used printf once to see IP and Port to whom the connect request is being... (1 Reply)
Discussion started by: mzeeshan
1 Replies

4. UNIX for Advanced & Expert Users

Data Recovery from file system overwritten with LVM.

Hey peeps, Here is somethin u might find interestin.... Is it possible to recover data from a partition which used to be an ext3 file sytem with some nice forgotten backups, which now is an lvm partion containg root partition of another OS. :) I couldn't create any mess better than this, can... (2 Replies)
Discussion started by: squid04
2 Replies

5. AIX

System recovery

Hi everyone I'm green AIX user or rather beginner (light green). Unfortunately I have to restore my system + data from scratch (things happen) and make it up and running. I've never done it before. Can someone of you provide me with link/procedure/instruction how to do it? Now I know only:... (3 Replies)
Discussion started by: fraydey
3 Replies

6. AIX

make a recovery CD/DVD - system has no writable devices

Hi, Has anyone please got some advise as to how I can make a CD/DVD on an AIX 5.3 system so that it can be fully recoverd just by inserting the backed up system. The system that I need to recover has no writable devices, not even a tape drive (it wasn't specified by me btw). I am trying to... (0 Replies)
Discussion started by: stevek007
0 Replies

7. UNIX for Advanced & Expert Users

Adapter Errors and Link Errors

$ errpt | more IDENTIFIER TIMESTAMP T C RESOURCE_NAME DESCRIPTION 3074FEB7 0802050205 T H fscsi1 ADAPTER ERROR B8113DD1 0802050205 T H fcs1 LINK ERROR B8113DD1 0802050205 T H fcs1 LINK ERROR 3074FEB7 0802050205 T H fscsi0 ADAPTER ERROR B8113DD1 ... (0 Replies)
Discussion started by: mcastill66
0 Replies

8. HP-UX

Automatic system recovery?

Hi all! I've a strange problem. I would use the GNU Make tool on HPUX 11.11. To archive this, i have compiled the sourcecode and renamed HP make in /usr/bin from make to make_old. Now i have make a softlink from /usr/local/bin/make (GNU version) to /usr/bin/make. All things here are ok, but... (1 Reply)
Discussion started by: coredump2003
1 Replies
Login or Register to Ask a Question

Featured Tech Videos