Visit Our UNIX and Linux User Community

SLD: Failed to start the PMD Connection thread. (PM_THREAD_FAILED_TO_START).

Thread Tools Search this Thread
Operating Systems SCO SLD: Failed to start the PMD Connection thread. (PM_THREAD_FAILED_TO_START).
# 1  
Old 03-23-2011
SLD: Failed to start the PMD Connection thread. (PM_THREAD_FAILED_TO_START).


I have a client with an 18 year old SCO Openserver 5.0.5 server.

They can't find their installation media.

They are experiencing an error at login:
*LOGIN: ERROR- Failed to initialize policy manager. (IFOR_PM_FATAL)
The status from the policy manager daemon (PMD - /etc/ifor_pmd) indicates
that a serious error condition has occurred. Login is allowed, but the
system administrator is strongly advised to consult the SCO online Support
Solutions Library (SSL) for assistance; if the SSL is inaccessible,
please contact your SCO Support representative.

Some research on this error indicates an issue with the PMD daemon.

Running a 'ps -ef' shows that the daemon is not running. I tried to start it via a '/etc/ifor_pmd' command and the following message is given:
SLD: Failed to start the PMD Connection thread. (PM_THREAD_FAILED_TO_START).

I'm not sure where to go on this to further debug and/or resolve.

Can anyone in this forum give me some direction.


Bryan Hunt
# 2  
Old 03-24-2011
# 3  
Old 03-24-2011
Tech Alert


Yes, I used that document once in the past to resolve this issue for them. In that case it was the broken/missing link. That is not the case this time.

As I started on step 2, I saw that the daemon wasn't running. That's when I tried to start it manually and got the message:
SLD: Failed to start the PMD Connection thread. (PM_THREAD_FAILED_TO_START).

The message is not desctiptive about *why* the thread failed to start, so I thought I had better reach out and see if anyone could assist with where to check for log files that may indicate the cause of the failure before trying anything else.


Bryan Hunt
# 4  
Old 03-24-2011
Could be simply that the CMOS clock has died, and the date is now earlier than the installation date.
# 5  
Old 03-24-2011


Thanks for the reply.

No, checked the clock and it is correct.

Bryan Hunt
# 6  
Old 03-24-2011
Do you have the serial number and activation key? I have the media.
Error messages should be in /usr/adm/messages, although if there are any they will probably be just as cryptic.
You could also try "authck -a" in single user mode.
# 7  
Old 03-25-2011
Can you launch it in truss/tusc/strace so you can see what it is up to as it tries to start?

Previous Thread | Next Thread
Test Your Knowledge in Computers #764
Difficulty: Medium
A cache miss is a failed attempt to read or write a piece of data in the cache, which results in a main memory access with much shorter latency and increased speed.
True or False?

6 More Discussions You Might Find Interesting

1. Programming

Failed SSL Connection Attempt

The below error message I started seeing using Ubuntu 14.04 and was wondering if the forum has seen it because I cant seem much on the net for this: perl -e 'use IO::Socket::SSL qw(debug3);IO::Socket::SSL->new(PeerAddr=>"",PeerPort=> 443,Proto=>"TCP") or die $!' DEBUG:... (1 Reply)
Discussion started by: metallica1973
1 Replies

2. Programming

Fork thread, Assertion failed. X11.

Hi all. I wrote a program with the Motif Widget Toolkit. It has a button and a scrollbar. When the user hits the button the callback creates a new fork() thread. The new thread sleeps for a while and then changes the position of the scrollbar. It does this in an endless loop. I need the... (2 Replies)
Discussion started by: mghis
2 Replies

3. Solaris

Internet connection failed on solaris 10

Hi, i am new bie on solaris ,i just installed it on vmware. i tryed to connect to the internet from solaris but it failed. during the installation i ignore the DHCP and i assign a fixed ip address to the host. is that has an impact on internet access ? and if so how to add another interface... (3 Replies)
Discussion started by: Mirsol
3 Replies

4. Red Hat

VSFTPD Service Failed to Start

Today I have installed VSFTPD but service is failing to start. We have been using standard FTP successful but need to introduce an FTPS option. I have run YUM install VSFTPD and everything appeared to load ok. (If I run rpm - qa | grep vsftpd I get vsftpd-2.0.5-16.el5_4.1 which I... (4 Replies)
Discussion started by: PaulComins
4 Replies

5. Solaris

ssh connection failed.

When i was connecting the Solaris system by sftp . i got the following error. "Warning: child process (/usr/local/bin/ssh2) exited with code 74." Could any one help, how to fix it ? (1 Reply)
Discussion started by: nag.mi2000
1 Replies

6. SCO

How do I start a thread ?

I am actually trying to find out the following: Using MS Windows, XP PRO, I downloaded an Adaptec SCSi 39160 driver from SCO Unix site. Driver is ad160.btld. I now need to copy this driver to a SCO Unix 5.5 standalone server, via a floppy diskette. I've tried SCO505 Diskimage and it didn't have... (2 Replies)
Discussion started by: mos8001
2 Replies

Featured Tech Videos