Visit Our UNIX and Linux User Community


RPM and dependencies OPENSSH


 
Thread Tools Search this Thread
Operating Systems Linux Red Hat RPM and dependencies OPENSSH
# 1  
Old 01-12-2009
RPM and dependencies OPENSSH

Hello

Sorry, I am not to well versed in RHE and I am having some issues.
I have doen a cursury look around and could not find an answer.

I have 2 RHE4 servers. Both have old versions of OPENSSH along with , server, askpass, askpass-gnome, etc.

I cannot upgrade to our new pkg release of openssh (internal) because of all the dependencied for each of these.

Is --nodeps a safe solution and upgrade each package indivudually? Should I just remove each and install new? A better solution?

Thanks in advance
Mike
# 2  
Old 01-12-2009
Quote:
Originally Posted by mhenryj
Hello

Sorry, I am not to well versed in RHE and I am having some issues.
I have doen a cursury look around and could not find an answer.

I have 2 RHE4 servers. Both have old versions of OPENSSH along with , server, askpass, askpass-gnome, etc.
I cannot upgrade to our new pkg release of openssh (internal) because of all the dependencied for each of these.[/quote]

Use up2date and get the latest.

Quote:
Is --nodeps a safe solution and upgrade each package indivudually? Should I just remove each and install new? A better solution?

Thanks in advance
Mike
Do you really think that would be wise? That is the reason there are dependences, because the program requires other software to work properly.
# 3  
Old 01-13-2009
Lazydog,

You might want to put the error dependencies here that you are encountering. Maybe we can give you advise. I advise you not tp use the --nodeps it may hunt you in the future.

Cheers!
# 4  
Old 01-13-2009
Unfortunately, I am deleted the /var/log/messages and /usr/bin/last files, after that i touch those files but not working still now help me

yours
thakshina
# 5  
Old 01-13-2009
The files I need to update:

# ls
openssh-5.1p1.hpn13v5-1.i386.rpm
openssh-askpass-5.1p1.hpn13v5-1.i386.rpm
openssh-askpass-gnome-5.1p1.hpn13v5-1.i386.rpm
openssh-clients-5.1p1.hpn13v5-1.i386.rpm
openssh-server-5.1p1.hpn13v5-1.i386.rpm

=========================================================
What happens when I try:

# rpm -U openssh-5.1p1.hpn13v5-1.i386.rpm
error: Failed dependencies:
openssh = 3.6.1p2-33.30.3 is needed by (installed) openssh-clients-3.6.1p2-33.30.3
openssh = 3.6.1p2-33.30.3 is needed by (installed) openssh-server-3.6.1p2-33.30.3
openssh = 3.6.1p2-33.30.3 is needed by (installed) openssh-askpass-3.6.1p2-33.30.3
openssh = 3.6.1p2-33.30.3 is needed by (installed) openssh-askpass-gnome-3.6.1p2-33.30.3

=========================================================

Another:

# rpm -U openssh-askpass-5.1p1.hpn13v5-1.i386.rpm
error: Failed dependencies:
openssh = 5.1p1.hpn13v5-1 is needed by openssh-askpass-5.1p1.hpn13v5-1

=========================================================

When I try to upgrade ssh, all these others depend on the orig version of ssh, and the same if I try to update others before ssh.
# 6  
Old 01-13-2009
old version of openssh is blocking the new one

you need telnet/console/rlogin access to the box

run rpm -qa | grep ssh

remove all installed openssh packages (rpm -e, can be done with --nodeps) , and install the new ones like you did

should work

(backup /etc/ssh or /etc/openssh )
# 7  
Old 01-13-2009
Quote:
Originally Posted by csorhand
Lazydog,

You might want to put the error dependencies here that you are encountering. Maybe we can give you advise. I advise you not tp use the --nodeps it may hunt you in the future.

Cheers!
Sorry, mis-quoted. I haven't the problem.

Quote:
Originally Posted by thakshina
Unfortunately, I am deleted the /var/log/messages and /usr/bin/last files, after that i touch those files but not working still now help me

yours
thakshina
Open another thread with your issues. Please do not Hi-jack someone elses tread!

Quote:
Originally Posted by funksen
old version of openssh is blocking the new one

you need telnet/console/rlogin access to the box

run rpm -qa | grep ssh

remove all installed openssh packages (rpm -e, can be done with --nodeps) , and install the new ones like you did

should work

(backup /etc/ssh or /etc/openssh )
Why would you not want to remove the dependencies that you no long need? You should NEVER use the '--nodeps' flag unless you know what you are doing and what you can, and most likely will, break.

The correct solution is to remove all, including dependencies, and install freash.

Code:
rpm -e openssh

This will remove all the file including the dependencies. Then you just install the new version.

Windoze users, please.

mhenryj, why are you not using up2date to update your system?

Previous Thread | Next Thread
Test Your Knowledge in Computers #584
Difficulty: Easy
Binary files generally requires less space and are more efficient to process.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

RPM failed dependencies

I'm trying to package the latest Oracle JDK (1.7.0_51) into an RPM. Packaging works fine but when i try to install via rpm -Uvh xxx.rpm, i get the following: #sudo rpm -ivh Sun_JDK7-1.7.0-51.x86_64.rpm error: Failed dependencies: libavcodec.so.52()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64... (3 Replies)
Discussion started by: asc123321
3 Replies

2. AIX

Rpm issue with autoconf-2.63-1.AIX6.1.noarch.rpm

dears i am trying to install the autoconf-2.63-1.aix6.1.noarch.rpm but its shows the below error message . P700_dev/svn/dependencies>rpm -i autoconf-2.63-1.aix6.1.noarch.rpm error: failed dependencies: m4 is needed by autoconf-2.63-1 P700_dev/svn/dependencies> (6 Replies)
Discussion started by: thecobra151
6 Replies

3. SuSE

How to get RPM Dependencies/libs

Hi All, I wanted to install an rpm package on two suse 10 systems. It installed successfully on one system but on the other it throws an error like error: Failed dependencies: rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by linuxProj-1-1.noarch Now this means that rpnm... (4 Replies)
Discussion started by: dirshah
4 Replies

4. SuSE

RPM implicit dependencies

Hi, I'm having issues with implicit dependencies for my RPM package. This is the error I'm getting: error: Failed dependencies: libclntsh.so.11.1()(64bit) is needed by geomatica-10.4-0.x86_64 Our software has a dynamically loaded library which links to the Oracle's libclntsh.so.11.1... (2 Replies)
Discussion started by: pneveu
2 Replies

5. Shell Programming and Scripting

How to make RPM not write to RPM database if RPM fails to deploy?

How to make RPM not write to RPM database if RPM fails to deploy? IE I create an rpm spec file that contains the following if then exit 1 fi My rpm will fail at deployment, but if I do rpm -qa , I can see the rpm in the rpm db (3 Replies)
Discussion started by: 3junior
3 Replies

6. Red Hat

RPM dependencies fail

Hello, I am trying to install krb5-libs-1.4-4.pp-rh73.i386.rpm on my Red Hat 7.X server, however while installing/upgrading it fails due to dependencies. I checked for these dependencies and i already found them on the server. I wonder why it is giving these errors. I tried copying these... (1 Reply)
Discussion started by: sunny_a_j
1 Replies

7. Shell Programming and Scripting

Extract RPM name from path to .rpm file

It's the end of the day and I just can't get my head around this. I'm trying to extract just the name of the RPM from the path to a .rpm file. So from: /home/me/rpm/RPMS/i386/nagios-our-plugins-1.2-6.i386.rpmI need to extract 'nagios-our-plugins'. I can't get the awk syntax right: awk '{... (5 Replies)
Discussion started by: aussieos
5 Replies

8. UNIX for Advanced & Expert Users

Recompile openssh and build an rpm

I am needing to recompile openssh to hide the ssh banner which I found I can do in the version.h. I know.. I know, but its a requirement of some dumb security company so the company I work for can get their blessing. Anyway. I am going to upgrade in the process and have downloaded the source... (2 Replies)
Discussion started by: creedog
2 Replies

9. SuSE

How to install .src.rpm ? ( source rpm )

Hi, I have got few RPM's from rpmfind.net ( mainly gcc ). But it seems to be src files instead of the image. so I think we have to build the src files according to target machine using rpmbuild. Can any one help me with 1) Various options of rpm build that have to be taken care 2)... (3 Replies)
Discussion started by: Sivaswami
3 Replies

10. Linux

Failed dependencies of rpm / how does RPM check for ?

Hey, I've a problem installing a package. rpm -ivh brings the errors: libjvm.so is needed by libverify.so is needed by But I have installed the Java SDK like requested and the files are on the disk. But I have no idea how to find out, why rpm cann't find them. I have also... (2 Replies)
Discussion started by: mod
2 Replies

Featured Tech Videos