Visit Our UNIX and Linux User Community


Red Hat 7 cannot recognize ethernet adapter


 
Thread Tools Search this Thread
Operating Systems Linux Red Hat Red Hat 7 cannot recognize ethernet adapter
# 1  
Old 07-11-2018
Red Hat 7 cannot recognize ethernet adapter

Hello community, I have a Proliant HP DL380P with the following network adapters:
  • NetXtreme BCM5719 Gigabit Ethernet PCIe (Ethernet 1Gb 4-port 331FLR Adapter)
  • 82580 Gigabit Network Connection (NC365T 4-port Ethernet Server Adapter)
I installed Red Hat 7.2 but it recognizes only the NetXtreme adapter. Every cable/interface connected to the other adapter (82580) is not recognized by the OS. How can I solve this?

Code:
https://pastebin.com/frPnPff5



[/CODE]---------- Post updated at 11:47 PM ---------- Previous update was at 01:56 PM ----------

lspci show :
Code:
04:00.0 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
        Subsystem: Hewlett-Packard Company NC365T 4-port Ethernet Server Adapter
        Physical Slot: 1
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin D routed to IRQ 52
        NUMA node: 0
        Region 0: Memory at f7f80000 (64-bit, non-prefetchable) [size=512K]
        Region 4: Memory at f7f70000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
                Address: 0000000000000000  Data: 0000
                Masking: 00000000  Pending: 00000000
        Capabilities: [70] MSI-X: Enable+ Count=10 Masked-
                Vector table: BAR=4 offset=00000000
                PBA: BAR=4 offset=00002000
        Capabilities: [a0] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 512 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+ SlotPowerLimit 0.000W
                DevCtl: Report errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
                        MaxPayload 256 bytes, MaxReadReq 4096 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
                LnkCap: Port #0, Speed 5GT/s, Width x4, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
                        ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 5GT/s, Width x4, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Range ABCD, TimeoutDis+, LTR+, OBFF Not Supported
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
                LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
                         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
        Capabilities: [e0] Vital Product Data
pcilib: sysfs_read_vpd: read failed: Input/output error
                Not readable
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
                UESvrt: DLP- SDES+ TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
                AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [140 v1] Device Serial Number f4-ce-46-ff-ff-a8-a1-2f
        Capabilities: [1a0 v1] Transaction Processing Hints
                Device specific mode supported
                Steering table in TPH capability structure
        Capabilities: [1c0 v1] Latency Tolerance Reporting
                Max snoop latency: 0ns
                Max no snoop latency: 0ns
        Kernel driver in use: igb
        Kernel modules: igb

But really I don't know what does it mean or how can I solve it Smilie

Last edited by Lord Spectre; 07-11-2018 at 03:27 AM..
# 2  
Old 07-11-2018
You getting any message in # dmesg ?

List out your modules.

Code:
# lsmod , # modinfo igb

In your case Interface with tg3 drivers working fine.

Interface with igb not working. Have you tried removing module and install it? Or replacing with any other modules?

Thanks & Regards,
Babin Lonston
# 3  
Old 07-11-2018
Thank you for reply babinlonston,

Here the lsmod output
Code:
https://pastebin.com/Jg8tsa6D

Here the modinfo:
Code:
https://pastebin.com/yq94rD2x

And here the dmesg
Code:
https://pastebin.com/dvt6L1wa

I don't think it's an hardware fault, because I have the same behaviour on other server DL380P G8

I'm really getting crazy Smilie

Last edited by Lord Spectre; 07-11-2018 at 06:07 AM..
# 4  
Old 07-11-2018
These 3 Users Gave Thanks to hicksd8 For This Post:
# 5  
Old 07-11-2018
Thank you I downloaded the igb-5.3.5.18.tar.gz driver and I seen it supports Red Hat Enterprise Linux 7.2, perfect for me. Now, how can I install it on RHEL 7? Smilie
# 6  
Old 07-11-2018
@Lord Spectre,

An instruction will be there in READEME file check for that and make sure to not skip any steps.

Thanks & Regards,
Bobin Lonston
# 7  
Old 07-11-2018
Thank you, but can build RPM due to:
Code:
make: Entering directory `/root/rpmbuild/BUILD/igb-5.3.5.18/src'
common.mk:102: *** Kernel header files not in any of the expected locations.
common.mk:103: *** Install the appropriate kernel development package, e.g.
common.mk:104: *** kernel-devel, for building kernel modules and try again.  Stop.
make: Leaving directory `/root/rpmbuild/BUILD/igb-5.3.5.18/src'
error: Bad exit status from /var/tmp/rpm-tmp.TZXs4M (%build)

Can someone build the RPM for me? Smilie

Previous Thread | Next Thread
Test Your Knowledge in Computers #619
Difficulty: Medium
In Python, variables may not be used by just assigning them a value. Declaration and data type definition is required in Python.
True or False?

10 More Discussions You Might Find Interesting

1. SCO

Can not recognize network adapter SCO UNIX in HP z400

hi .I've installed an operating system SCO in HP Z400 and network cards ZyXEL model FN312 with Chipset RTL8139D put it on .network card installed but do not display network card with command ifconfig -a in list and just show loopback. show message : dlpid:unable to open network adapter driver... (14 Replies)
Discussion started by: moein.mojtaba
14 Replies

2. Solaris

Qlogic 10G Ethernet adapter not working

Hi Community, i have one issue with 10 fiber ethernet adapter. here is my details: root@new-bpel.example.com #dladm show-dev bge0 link: unknown speed: 0 Mbps duplex: unknown bge1 link: up speed: 1000 Mbps duplex: full qlge2 link:... (4 Replies)
Discussion started by: bentech4u
4 Replies

3. AIX

How to check the ethernet status for vlan and lhea adapter in client servers?

Hi Techies, I have a doubt. ent0 Available Logical Host Ethernet Port (lp-hea) ent1 Available Logical Host Ethernet Port (lp-hea) ent2 Available Logical Host Ethernet Port (lp-hea) ent3 Available Logical Host Ethernet Port (lp-hea) ent4 Available... (4 Replies)
Discussion started by: jayadeava
4 Replies

4. Hardware

Need Sun 10-Gigabit Ethernet Adapter CD or ixge driver

Hi, Does anybody have a "Sun 10-Gigabit Ethernet Adapter installation CD" or driver ixge for Sun 10-Gigabit Ethernet PCI-X adapter? I need it but can't find it anywhere. So if you know where I can download it or purchase it, please let me know. (Already tried Oracle's website, don't have it) ... (5 Replies)
Discussion started by: Lhao
5 Replies

5. Red Hat

Ethernet Adapter not detected.

Hi, I have installed Oracle Enterprise Linux 5 in my PC. After the installation the Ethernet Card is not got detected. But I could able to get the details using the command lspci -a: 01:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0). But I could... (4 Replies)
Discussion started by: chidhu.anu
4 Replies

6. AIX

Setting up an Integrated Virtual Ethernet adapter

All I am trying allocate an IVE to an LPAR (not a VIO) running AIX 7.1. I am getting the error: HSCL068A Explanation Logical port can not be assigned to Logical Partition because this Logical Partition is not the promiscuous LPAR for the physical port. Has anyone encountered this... (1 Reply)
Discussion started by: johnf
1 Replies

7. AIX

Temporarily disabling unused ethernet adapter

Hi, In our AIX 5.2 server , we have one unused ethernet adapter which doesn't have cable connection . For this interface , we are getting alerts in errpt . Could you suggesthow to stop this alert ? And sametime i would like to keep this device in ODM . Is there... (1 Reply)
Discussion started by: sekarsamy
1 Replies

8. Solaris

How to install ethernet adapter on Sun Sparc M4000

hi all, How to install onboard ethernet card on Sun SPARC M4000 server? (3 Replies)
Discussion started by: Tlg13team
3 Replies

9. Solaris

Ethernet Adapter Question

I have a Dual Boot system - XP with Solaris 10. I built the system from the ground up with different components and the Ethernet Card built into the Motherboard is a Marvell Yukon Gigabit Ethernet 10/100/1000 T-base, RJ-45 Copper. I am unable to go to the Web as the Ethernet Card is still not... (2 Replies)
Discussion started by: tubbyrana
2 Replies

10. UNIX for Dummies Questions & Answers

How to change the MAC adress in ethernet adapter for SUN

I have installed in the server a quad ethernet adapter, I'm using two interfaces with two different IP networks, both interfaces are connected to a switch, the switch report that is receiving the same MAC address in both ports so must of the times I have connectivity problems. Any idea to change... (1 Reply)
Discussion started by: mono673
1 Replies

Featured Tech Videos