Today (Saturday) We will make some minor tuning adjustments to MySQL.

You may experience 2 up to 10 seconds "glitch time" when we restart MySQL. We expect to make these adjustments around 1AM Eastern Daylight Saving Time (EDT) US.


Red Hat 7 cannot recognize ethernet adapter


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Red Hat 7 cannot recognize ethernet adapter

Hello community, I have a Proliant HP DL380P with the following network adapters:
  • NetXtreme BCM5719 Gigabit Ethernet PCIe (Ethernet 1Gb 4-port 331FLR Adapter)
  • 82580 Gigabit Network Connection (NC365T 4-port Ethernet Server Adapter)
I installed Red Hat 7.2 but it recognizes only the NetXtreme adapter. Every cable/interface connected to the other adapter (82580) is not recognized by the OS. How can I solve this?

Code:
https://pastebin.com/frPnPff5



[/CODE]---------- Post updated at 11:47 PM ---------- Previous update was at 01:56 PM ----------

lspci show :
Code:
04:00.0 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
        Subsystem: Hewlett-Packard Company NC365T 4-port Ethernet Server Adapter
        Physical Slot: 1
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin D routed to IRQ 52
        NUMA node: 0
        Region 0: Memory at f7f80000 (64-bit, non-prefetchable) [size=512K]
        Region 4: Memory at f7f70000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
                Address: 0000000000000000  Data: 0000
                Masking: 00000000  Pending: 00000000
        Capabilities: [70] MSI-X: Enable+ Count=10 Masked-
                Vector table: BAR=4 offset=00000000
                PBA: BAR=4 offset=00002000
        Capabilities: [a0] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 512 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+ SlotPowerLimit 0.000W
                DevCtl: Report errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
                        MaxPayload 256 bytes, MaxReadReq 4096 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
                LnkCap: Port #0, Speed 5GT/s, Width x4, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
                        ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 5GT/s, Width x4, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Range ABCD, TimeoutDis+, LTR+, OBFF Not Supported
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
                LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
                         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
        Capabilities: [e0] Vital Product Data
pcilib: sysfs_read_vpd: read failed: Input/output error
                Not readable
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
                UESvrt: DLP- SDES+ TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
                AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [140 v1] Device Serial Number f4-ce-46-ff-ff-a8-a1-2f
        Capabilities: [1a0 v1] Transaction Processing Hints
                Device specific mode supported
                Steering table in TPH capability structure
        Capabilities: [1c0 v1] Latency Tolerance Reporting
                Max snoop latency: 0ns
                Max no snoop latency: 0ns
        Kernel driver in use: igb
        Kernel modules: igb

But really I don't know what does it mean or how can I solve it Smilie

Last edited by Lord Spectre; 07-11-2018 at 02:27 AM..
# 2  
You getting any message in # dmesg ?

List out your modules.

Code:
# lsmod , # modinfo igb

In your case Interface with tg3 drivers working fine.

Interface with igb not working. Have you tried removing module and install it? Or replacing with any other modules?

Thanks & Regards,
Babin Lonston
# 3  
Thank you for reply babinlonston,

Here the lsmod output
Code:
https://pastebin.com/Jg8tsa6D

Here the modinfo:
Code:
https://pastebin.com/yq94rD2x

And here the dmesg
Code:
https://pastebin.com/dvt6L1wa

I don't think it's an hardware fault, because I have the same behaviour on other server DL380P G8

I'm really getting crazy Smilie

Last edited by Lord Spectre; 07-11-2018 at 05:07 AM..
# 4  
These 3 Users Gave Thanks to hicksd8 For This Post:
# 5  
Thank you I downloaded the igb-5.3.5.18.tar.gz driver and I seen it supports Red Hat Enterprise Linux 7.2, perfect for me. Now, how can I install it on RHEL 7? Smilie
# 7  
Thank you, but can build RPM due to:
Code:
make: Entering directory `/root/rpmbuild/BUILD/igb-5.3.5.18/src'
common.mk:102: *** Kernel header files not in any of the expected locations.
common.mk:103: *** Install the appropriate kernel development package, e.g.
common.mk:104: *** kernel-devel, for building kernel modules and try again.  Stop.
make: Leaving directory `/root/rpmbuild/BUILD/igb-5.3.5.18/src'
error: Bad exit status from /var/tmp/rpm-tmp.TZXs4M (%build)

Can someone build the RPM for me? Smilie
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Can not recognize network adapter SCO UNIX in HP z400
moein.mojtaba
hi .I've installed an operating system SCO in HP Z400 and network cards ZyXEL model FN312 with Chipset RTL8139D put it on .network card installed but do not display network card with command ifconfig -a in list and just show loopback. show message : dlpid:unable to open network adapter driver...... SCO
14
SCO
Qlogic 10G Ethernet adapter not working
bentech4u
Hi Community, i have one issue with 10 fiber ethernet adapter. here is my details: root@new-bpel.example.com #dladm show-dev bge0 link: unknown speed: 0 Mbps duplex: unknown bge1 link: up speed: 1000 Mbps duplex: full qlge2 link:...... Solaris
4
Solaris
Ethernet Adapter not detected.
chidhu.anu
Hi, I have installed Oracle Enterprise Linux 5 in my PC. After the installation the Ethernet Card is not got detected. But I could able to get the details using the command lspci -a: 01:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0). But I could...... Red Hat
4
Red Hat
Setting up an Integrated Virtual Ethernet adapter
johnf
All I am trying allocate an IVE to an LPAR (not a VIO) running AIX 7.1. I am getting the error: HSCL068A Explanation Logical port can not be assigned to Logical Partition because this Logical Partition is not the promiscuous LPAR for the physical port. Has anyone encountered this...... AIX
1
AIX
Ethernet Adapter Question
tubbyrana
I have a Dual Boot system - XP with Solaris 10. I built the system from the ground up with different components and the Ethernet Card built into the Motherboard is a Marvell Yukon Gigabit Ethernet 10/100/1000 T-base, RJ-45 Copper. I am unable to go to the Web as the Ethernet Card is still not...... Solaris
2
Solaris

Featured Tech Videos