Visit Our UNIX and Linux User Community


LVextend problem

 
Thread Tools Search this Thread
Operating Systems Linux Red Hat LVextend problem
# 1  
Old 09-14-2017
LVextend problem

So, we are facing problem with extending LV...
We had 2x300GB in mirror on IBM Xserver for rootvg.
We failed one of the disks and replaced it with 600GB, rebuild it and did it with the other disk the same...
Extended Virtual drive on RAID to 600GB. After that we have shut down the server and removed one of the disks. The Array was marked as degraded, but never the less, we could boot to OS. PVresize worked like a charm, but after lvextend server started to act strangely...after reboot it did't make it to OS anymore... Any ideas why this could be a problem? And how to extend it successfully?
We made a "recovery" plan, inserted other (good) disk in the server, imported foreign config, started the OS, inserted "non working OS" disk and did a rebuild. So we have some kind of reversible plan, but would like to increase the size of rootvg. We are running TSM on this server and all other disk slots are occupied (otherwise we would make desired sized rootvg on other disks).
Anyone faced the same problem?
# 2  
Old 09-14-2017
I always try to keep the rootvg to a minimum, after all, how do you plan to use mksysb to save a bootable OS media for an emergency recovery?

Just 8Gb should be plenty for AIX operating system with space to spare. Make the OS disk simple.

Keep all your user personal space, and application space in a separate volume group.

I know that there are costs with having more media, but it's well worth it. You need to ask yourself 'Is 1,000 GBP / $2,000 USD etc. worth losing my server for?' and do the job well. Of course, it will then be tempting to fill the rootvg with other stuff, just because there is space there, but you are immediately compromising yourself.

The other way to do this would be to have the disks mirrored by the hardware and provide logical disks to the operating system. That way, you get the best of both worlds, but you need to know you can tell when a disk has failed and has left you exposed.


Can you confirm:-
  • how your resized?
  • if the logical volume copies were synchronised or were any stale?
  • if you re-created the boot loader for the OS on the new disk(s)?
  • if you put the disk into the boot list?
  • what you can see from SMS / firmware prompt?

Hopefully we can help you here.



Kind regards,
Robin

Previous Thread | Next Thread
Test Your Knowledge in Computers #275
Difficulty: Easy
OpenSolaris is the only version of the System V variant of UNIX available as open source.
True or False?

10 More Discussions You Might Find Interesting

1. IP Networking

Router problem or ISP problem ?

Hi everyone, I am experiencing discontinuity of Internet service, this started 1 month ago. Everything worked very well for 1 year of intensive use, but now, I have problems reaching my gateway. The gateway is not my router but a node belonging to my ISP and I share the same public IP with... (3 Replies)
Discussion started by: remic
3 Replies

2. UNIX for Dummies Questions & Answers

sed Or Grep Problem OR Terminal Problem?

I don't know if you guys get this problem sometimes at Terminal but I had been having this problem since yesterday :( Maybe I overdid the Terminal. Even the codes that used to work doesn't work anymore. Here is what 's happening: * I wanted to remove lines containing digits so I used this... (25 Replies)
Discussion started by: Nexeu
25 Replies

3. UNIX for Advanced & Expert Users

Lv not useable after lvextend - high I/O

Hello, on an Ubuntu 12.04 NAS there are some lvm's VG #PV #LV #SN Attr VSize VFree vg01 1 2 0 wz--n- 930,45g 411,83g LV VG Attr LSize Origin Snap% Move Log Copy% Convert lv-iscsi vg01 -wi-a- 500,00g lv-root vg01... (0 Replies)
Discussion started by: darktux
0 Replies

4. IP Networking

Problem with forwarding emails (SPF problem)

Hi, This is rather a question from a "user" than from a sys admin, but I think this forum is apropriate for the question. I have an adress with automatic email forwarding and for some senders (two hietherto), emails are bouncing. This has really created a lot of problems those two time so I... (0 Replies)
Discussion started by: carwe
0 Replies

5. SuSE

lvextend on ext3 resizing

Hi all IM very curious about one thing Im currently playing with a test server SLES x64 SP2, and I got to a serious issue which is really sorry for the word pissing me off. :mad: I created an pv, then vg and finaly some lv's which is fine. I mounted then and everything worked fine... (0 Replies)
Discussion started by: kl1ngac1k
0 Replies

6. Solaris

lvextend in solaris 10

Hi all, I wish to extend my logical volumn, previously i am using the command lvextend in HPUX, but hows in solaris 10 ? Thank you (1 Reply)
Discussion started by: SmartAntz
1 Replies

7. AIX

user login problem & Files listing problem.

1) when user login to the server the session got colosed. How will resolve? 2) While firing the command ls -l we are not able to see the any files in the director. but over all view the file system using the command df -g it is showing 91% used. what will be the problem? Thanks in advance. (1 Reply)
Discussion started by: pernasivam
1 Replies

8. Shell Programming and Scripting

ssh script problem problem

Hi Please help me with the following problem with my script. The following block of code is not repeating in the while loop and exiting after searching for first message. input_file ========== host001-01 host001-02 2008-07-23 13:02:04,651 ConnectionFactory - Setting session state... (2 Replies)
Discussion started by: pcjandyala
2 Replies

9. Shell Programming and Scripting

problem with dd command or maybe AFS problem

Hi, folks. Sorry for bothering, but maybe someone could help me please. The problem is the following: there is some script that copies files from local file system to AFS. The copying is performed with dd command. The script copies data into some AFS volumes. The problem appeared with one... (0 Replies)
Discussion started by: Anta
0 Replies

10. UNIX for Advanced & Expert Users

SSH Problem auth problem

Hi, Just recently we seem to be getting the following error message relating to SSH when we run the UNIX script in background mode: warning: You have no controlling tty. Cannot read confirmation.^M warning: Authentication failed.^M Disconnected; key exchange or algorithm negotiation... (1 Reply)
Discussion started by: budrito
1 Replies

Featured Tech Videos