Visit The New, Modern Unix Linux Community


RPM Install error: libc.so.6 is needed by


 
Thread Tools Search this Thread
Operating Systems Linux Red Hat RPM Install error: libc.so.6 is needed by
# 1  
RPM Install error: libc.so.6 is needed by

I have an application rpm which when installed is failing to get installed with error
Code:
error: Failed dependencies:
        libc.so.6 is needed by testSam-4.7.x86_64
        libc.so.6(GLIBC_2.0) is needed by testSam-4.7.x86_64
        libc.so.6(GLIBC_2.1) is needed by testSam-4.7.x86_64

The system has RHEL 7.3 with glibc 2.17.

Code:
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)

# rpm -qf /lib64/libc.so.6
glibc-2.17-157.el7.x86_64

So we see the application built using older glibc(it needs glibc between 2.0 and 2.1) is failing to run on a system having newer glibc 2.17.

How to get rid of this issue and run the application on systems having newer glibc?
I guess there are some glibc backward compatibility packs which will help us run such applications on systems having newer glibc.
From where can I download such compatibility packs?
Moderator's Comments:
Mod Comment Please use CODE tags (not ICODE tags) when displaying full-line and multi-line sample input, output, and code segments.

Last edited by Don Cragun; 05-18-2017 at 10:11 PM.. Reason: Change ICODE tags to CODE tags.
# 2  
GLIBC_2.0 seems no longer supported in RH 7:
Code:
nm /lib64/libc.so.6 | grep GLIBC_2.0

Maybe your application rpm is for RH 5 / CentOS 5?

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #648
Difficulty: Medium
Window Maker was written from scratch by Tim Berners-Lee, best known as the inventor of the World Wide Web.
True or False?

10 More Discussions You Might Find Interesting

1. HP-UX

Help needed HP UX 11.11i new install on C8000 Desktop messaging system error CAN'T FIX

Hi, I have a HP UX C8000 box , have installed 11.11i from 4 x cds numerous times to try to get a functioning Network or to try and get rid of this error on start up, after new install and 1st startup I get an error "The desktop messaging system could not be started" and then advice about... (12 Replies)
Discussion started by: C8000
12 Replies

2. Red Hat

INSTALL RPM's IN RHEL 5.5

After checking the dependencies from below command:- yum deplist gcc Update:- Now when I tried to install the very first dependency , it gave the below error, I guess something is wrong with YUM server itself :P ... (1 Reply)
Discussion started by: manish131081
1 Replies

3. UNIX for Dummies Questions & Answers

Can't install rpm package with --prefix in new path.Error: package is not relocatable

Hello, i have downloaded an rpm package "hadoop-0.20.205.0-1.amd64.rpm" in /usr/local/ directory. I'm trying to install the rpm package in a new path/location (/usr/local/hadoop-0.20.205), but i can't. I did: 1st try: Didn't work sudo rpm -i --prefix=/usr/local/hadoop-0.20.205... (1 Reply)
Discussion started by: g_p
1 Replies

4. UNIX for Dummies Questions & Answers

RPM install problem

I'm trying to install mysql on a server, but I keep getting an error. Can anyone offer any help? Below I've listed a bunch of info that you might find helpful. Here are the commands I'm using. $ ls MySQL-client-community-5.1.35-0.rhel3.i386.rpm... (2 Replies)
Discussion started by: wsetchell
2 Replies

5. UNIX for Dummies Questions & Answers

RPM uninstall/install

Running FC5 on a Dell desktop. When I compile a LaTex file, it goes fine but only outlines blank boxes where figs should be. When I send the figs.eps and Tex file to a friend, his compiles and imbeds the fig. in the text of the DVI output using my files without add'nl control cards. I conclude... (1 Reply)
Discussion started by: blann
1 Replies

6. SuSE

How to install .src.rpm ? ( source rpm )

Hi, I have got few RPM's from rpmfind.net ( mainly gcc ). But it seems to be src files instead of the image. so I think we have to build the src files according to target machine using rpmbuild. Can any one help me with 1) Various options of rpm build that have to be taken care 2)... (3 Replies)
Discussion started by: Sivaswami
3 Replies

7. Shell Programming and Scripting

How to install expect rpm?

Hi , I am tryin to install expect rpm on my linux machine. I have the source file expect-5.42.1-1.src.rpm I am doin this rpm -ivh expect-5.42.1-1.src.rpm But I am gettin this error warning: expect-5.42.1-1.src.rpm: V3 DSA signature : NOKEY, key ID db42a60e error: cannot... (1 Reply)
Discussion started by: eamani_sun
1 Replies

8. Red Hat

rpm needed

Dear all i want to install oracle10g on Red Hat Advance Server 3 the following are the required rpm for oracle software compat-db-4.0.14-5.1 compat-gcc-7.3-2.96.128 compat-libstdc++-7.3-2.96.128 compat-gcc-c++-7.3-2.96.128 compat-libstdc++-devel-7.3-2.96.128 setarch-1.3-1 ... (0 Replies)
Discussion started by: maooah
0 Replies

9. UNIX for Advanced & Expert Users

Help needed to build an RPM?

I use Fedora Core 6. ->Our application has a Binary file and few .SO files. So i would like to build an RPM FILE for this with .SPEC file. ->Even i need to set some Envirnoment variables. Can any one give me the steps to Build an RPM?(A bit more clearly please as I am very new to... (1 Reply)
Discussion started by: platso
1 Replies

10. HP-UX

Urgent Help needed for Installing RPM on HP-UX

I am working on a HP-UX PARISC 64 architecture. I am trying to install RPM but without success. Has any body successfully installed RPM on the above architecture. I couldnt find a compatible depot file. I tried to compile the source code for rpm-4.0 package. All the dependencies are... (3 Replies)
Discussion started by: sjcekk
3 Replies

Featured Tech Videos