Slow login with rexec.


 
Thread Tools Search this Thread
Operating Systems Linux Red Hat Slow login with rexec.
# 1  
Old 06-02-2016
Slow login with rexec.

Hi all,
Im replacing an old linux enterprise redhat 4.5 by a new one linux enterprise redhat 6.
In both I use rexec as a communication between the front end and the user.

In the old one, when the user connects, the communication establishes quickly (less than 3 sec). But in the new one, the communication establishes very slow (30 sec. aprox.).

I have reviewed the configurations and the only difference is:
in the old one, the parameter of log_on_success += USERID and log_on_failure += USERID does not exists.
But if I disable those parameters in /etc/xinet.d/rexec in the new one, I can not log.

Anybody have faced a similar problem?
Thanks in advance
Code:
# default: off
# description: Rexecd is the server for the rexec(3) routine.  The server \
#       provides remote execution facilities with authentication based \
#       on user names and passwords.
service exec
{
        socket_type             = stream
        wait                    = no
        user                    = root
        log_on_success          += USERID
        log_on_failure          += USERID
        server                  = /usr/sbin/in.rexecd
        disable                 = no
        server_args             = -D
}

# 2  
Old 06-03-2016
In SLES !

Quote:
Originally Posted by mig28mx
Hi all,
Im replacing an old linux enterprise redhat 4.5 by a new one linux enterprise redhat 6.
In both I use rexec as a communication between the front end and the user.

In the old one, when the user connects, the communication establishes quickly (less than 3 sec). But in the new one, the communication establishes very slow (30 sec. aprox.).

I have reviewed the configurations and the only difference is:
in the old one, the parameter of log_on_success += USERID and log_on_failure += USERID does not exists.
But if I disable those parameters in /etc/xinet.d/rexec in the new one, I can not log.

Anybody have faced a similar problem?
Thanks in advance
Code:
# default: off
# description: Rexecd is the server for the rexec(3) routine.  The server \
#       provides remote execution facilities with authentication based \
#       on user names and passwords.
service exec
{
        socket_type             = stream
        wait                    = no
        user                    = root
        log_on_success          += USERID
        log_on_failure          += USERID
        server                  = /usr/sbin/in.rexecd
        disable                 = no
        server_args             = -D
}

Hello,

in Suse (SLES) it's:
Code:
# default: off
# description:
# Rexecd is the server for the rexec program. The server provides remote
# execution facilities with authentication based on user names and
# passwords.
#
service exec
{
        socket_type     = stream
        protocol        = tcp
        flags           = NAMEINARGS
        wait            = no
        user            = root
        group           = root
        log_on_success  += USERID
        log_on_failure  += USERID
        server          = /usr/sbin/tcpd
        server_args     = /usr/sbin/in.rexecd
        disable         = no
        instances       = 1
}

Maybe you'll Need some more Parameters in the new one.

Regards

Last edited by RudiC; 06-03-2016 at 01:25 PM.. Reason: Code tags added
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

RCP slow down and blocks login, telnet, rsh, etc on target server

Hello I have a LPAR AIX 6.1 on Power VM, Vio 2.2.3 and when I execute a rcp to this machine, I cant, simultaneosly, rlogin, telnet, rsh to this same LPARt. This commands stay hanged till the copy end, and Imeddiatlely the comand is executed (rlogin, telnet, rhs, etc). Someone can give me... (1 Reply)
Discussion started by: artur_dietrich
1 Replies

2. UNIX for Advanced & Expert Users

OEL 6.3 :Slow login due to /etc/ssh/sshd_config configuration

Version: Oracle Enterprise Linux 6.3 Running on VMWare Workstation When I login to my Linux VM from putty, the third line prompting for password comes only after few seconds. login as: root Access denied root@192.168.0.235's password: ---> It takes around 5 seconds to get this prompt I... (1 Reply)
Discussion started by: John K
1 Replies

3. Solaris

Open Indiana 151a - Slow SSH Login

Hi, I have the following issue, when I tried to login to an Openindiana remote server through ssh It takes to long to ask me for the password. So i tried -v and I realize that sshd hangs here " debug1: SSH2_MSG_SERVICE_ACCEPT received " for at least 2 minutes. Then I can log in and everything is... (2 Replies)
Discussion started by: piukeman
2 Replies

4. Shell Programming and Scripting

Net::SSH::Perl slow to login.

I have some sample code that's supposed to ssh to another machine using Net::SSH::Perl, execute a command, and print the output of that command. It's very basic, and it works. However, I noticed that upon logging in: $ssh->login('username','password'); It takes roughly 10-13 seconds to... (2 Replies)
Discussion started by: mrwatkin
2 Replies

5. Solaris

Slow login via SSH

Hi Guys and Girls, I know this is a common question but I've searched and we've tried the suggestions without luck. When I log into the box via SSH from a windows machine I get a 1 min 20 sec delay. If we add my IP address and machine name to /etc/hosts then I get an instant login. I would be happy... (12 Replies)
Discussion started by: MikeKulls
12 Replies

6. Solaris

Slow Login

Hi All, I have problem when i write my user name to login to my server late (about 10 min) to give me field of password if u know how i can solve it? Thanks (4 Replies)
Discussion started by: mass1123
4 Replies

7. UNIX for Dummies Questions & Answers

Really slow login... any ideas why?

Hi, Quick question, I'm messing about with a test box at work (system v) Basically I telnet to the server. Get the following : SunOS 5.9 login: (my name) Password: (my password) Last login: Thu Feb..... yada yada (At this stage it takes over a minute to come to display the... (5 Replies)
Discussion started by: kenny123m
5 Replies

8. UNIX for Dummies Questions & Answers

Painfully Slow SSH login on Solaris box

Running open solaris on a e420 that I recently picked up. Having issues sshing to it from either of my Linux boxes as its very slow to login (from the solaris box to the linux box it connects just fine. Here is the output of ssh -vvv. I have hightlighted where it seems the slowdown is. Does... (0 Replies)
Discussion started by: creedog
0 Replies

9. Solaris

Solaris 9 slow login thru ssh & ftp

When I ssh to my box, an Ultra 5. I get prompted for password immediately. I enter it and have to wait sometimes a full minute for it to prompt for a password. The same thing happens when i try to ftp to the box, it will say connected, but it takes forever to prompt for password, and... (2 Replies)
Discussion started by: BG_JrAdmin
2 Replies

10. Solaris

Rexec

How is rexec enabled on a Solaris 8? How can I check if rexec is installed? (1 Reply)
Discussion started by: pmj1970
1 Replies
Login or Register to Ask a Question

Featured Tech Videos