Visit Our UNIX and Linux User Community


RPM failed dependencies

 
Thread Tools Search this Thread
Operating Systems Linux Red Hat RPM failed dependencies
# 1  
Old 03-26-2014
RPM failed dependencies

I'm trying to package the latest Oracle JDK (1.7.0_51) into an RPM. Packaging works fine but when i try to install via rpm -Uvh xxx.rpm, i get the following:
Code:
#sudo rpm -ivh Sun_JDK7-1.7.0-51.x86_64.rpm 
error: Failed dependencies:
libavcodec.so.52()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libavcodec.so.52(LIBAVCODEC_52)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libavcodec.so.53()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libavcodec.so.53(LIBAVCODEC_53)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libavformat.so.52()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libavformat.so.52(LIBAVFORMAT_52)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libavformat.so.53()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libavformat.so.53(LIBAVFORMAT_53)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libc.so.6(GLIBC_2.11)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libc.so.6(GLIBC_2.7)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libc.so.6(GLIBC_2.8)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libgio-2.0.so.0()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libxml2.so.2(LIBXML2_2.4.30)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libxml2.so.2(LIBXML2_2.6.0)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libxml2.so.2(LIBXML2_2.6.6)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libxslt.so.1(LIBXML2_1.0.11)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libxslt.so.1(LIBXML2_1.0.22)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libxslt.so.1(LIBXML2_1.0.24)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64
libxslt.so.1(LIBXML2_1.1.9)(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64

now if i include AuthReqProv:no in my spec file, i don't run into this issue when installing. the other workaround is that i just install with the --nodeps option.

not sure why this is happening or if it is an issue. how does a package build properly but not install properly? is it worse to set AuthReqProv:no during the rpm build or not to set it and install the rpm with --nodeps?

any ideas on how to resolve these dependencies?

thanks in advance

Last edited by Scott; 03-26-2014 at 07:49 PM.. Reason: Please use code tags. Thanks.
# 2  
Old 03-26-2014
When you built the RPM did you specify the dependencies in the .spec file?
# 3  
Old 03-26-2014
no, i did not. this seems to be rpm trying to resolve shared lib dependencies on its own.
# 4  
Old 03-27-2014
You'll need to add some 'Requires:' lines, just before the %description (atm on Windows, so shoot me for incorrect namings):

In the like of:

Code:
Requires:  PACKAGE_that_provies_libavcodec.so.52
..
%Description

To figure out which package provides that libavcodec, try:
Code:
yum provides *libavcodec.so.52*

Hope this helps

Previous Thread | Next Thread
Test Your Knowledge in Computers #488
Difficulty: Medium
Some languages are interpreted, not compiled, and the source code is contained in a file usually referred to as a text-based assembly unit.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Cpio: copy failed - No space left on device when I use rpm

Hello, I want to install GCC gcc-4.8.1-2.src.rpm for AIX 6.1 when I lance my command rpm -i gcc-4.8.1-2.src.rpm I have this error unpacking of archive failed on file gcc-4.8.1.tar.bz2: cpio: copy failed - No space left on device I checked the free space and I am surpise becouse I have... (7 Replies)
Discussion started by: tatab355
7 Replies

2. AIX

Rpm issue with autoconf-2.63-1.AIX6.1.noarch.rpm

dears i am trying to install the autoconf-2.63-1.aix6.1.noarch.rpm but its shows the below error message . P700_dev/svn/dependencies>rpm -i autoconf-2.63-1.aix6.1.noarch.rpm error: failed dependencies: m4 is needed by autoconf-2.63-1 P700_dev/svn/dependencies> (6 Replies)
Discussion started by: thecobra151
6 Replies

3. Linux

Failed dependencies

Hi all, i'm trying to upgrade pandorafms to the new version 4.0.3-130118, actually i have installed on my machine the version 3.0.0-8.1.el5, the error i'm getting when trying to update its the following rpm -Uvh pandorafms_agent_unix-4.0.3-130118.noarch.rpm error: Failed dependencies: ... (1 Reply)
Discussion started by: charli1
1 Replies

4. Red Hat

Failed dependencies loop forever

Hello All, I was trying to install one rpm and it failed due to missing dependencies, when I try to look at the dependencies and try to install them it is asking for 100+ dependencies, did any one ever face this problem? how can we fix this? rpm -ivh /var/tmp/erlang-R15B-02.1.el6.x86_64.rpm... (0 Replies)
Discussion started by: lovesaikrishna
0 Replies

5. SuSE

How to get RPM Dependencies/libs

Hi All, I wanted to install an rpm package on two suse 10 systems. It installed successfully on one system but on the other it throws an error like error: Failed dependencies: rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by linuxProj-1-1.noarch Now this means that rpnm... (4 Replies)
Discussion started by: dirshah
4 Replies

6. SuSE

RPM implicit dependencies

Hi, I'm having issues with implicit dependencies for my RPM package. This is the error I'm getting: error: Failed dependencies: libclntsh.so.11.1()(64bit) is needed by geomatica-10.4-0.x86_64 Our software has a dynamically loaded library which links to the Oracle's libclntsh.so.11.1... (2 Replies)
Discussion started by: pneveu
2 Replies

7. Shell Programming and Scripting

How to make RPM not write to RPM database if RPM fails to deploy?

How to make RPM not write to RPM database if RPM fails to deploy? IE I create an rpm spec file that contains the following if then exit 1 fi My rpm will fail at deployment, but if I do rpm -qa , I can see the rpm in the rpm db (3 Replies)
Discussion started by: 3junior
3 Replies

8. Red Hat

RPM dependencies fail

Hello, I am trying to install krb5-libs-1.4-4.pp-rh73.i386.rpm on my Red Hat 7.X server, however while installing/upgrading it fails due to dependencies. I checked for these dependencies and i already found them on the server. I wonder why it is giving these errors. I tried copying these... (1 Reply)
Discussion started by: sunny_a_j
1 Replies

9. Red Hat

RPM and dependencies OPENSSH

Hello Sorry, I am not to well versed in RHE and I am having some issues. I have doen a cursury look around and could not find an answer. I have 2 RHE4 servers. Both have old versions of OPENSSH along with , server, askpass, askpass-gnome, etc. I cannot upgrade to our new pkg release of... (8 Replies)
Discussion started by: mhenryj
8 Replies

10. Linux

Failed dependencies of rpm / how does RPM check for ?

Hey, I've a problem installing a package. rpm -ivh brings the errors: libjvm.so is needed by libverify.so is needed by But I have installed the Java SDK like requested and the files are on the disk. But I have no idea how to find out, why rpm cann't find them. I have also... (2 Replies)
Discussion started by: mod
2 Replies

Featured Tech Videos