BONDING with Flapping issue!

 
Thread Tools Search this Thread
Operating Systems Linux Red Hat BONDING with Flapping issue!
# 1  
Old 02-27-2014
Wrench BONDING with Flapping issue!

Hi team,

I'm running into a problem configuring bonding on an CentOS 64bit on DELL Server. I'm connecting eth0 and eth1
to a Cisco 2948 (CatOS 8.1(3)) and receiving flapping notices. The
ethernet address is that of the primary interface. I have tried
several different modes, including balance-rr (0), active-backup (1),
and balance-alb (6). All have the same problem. More detailed info
follows..

Code:
2.6.9-34.ELsmp #1 SMP Wed Mar 8 00:27:03 CST 2006 i686 i686 i386 GNU/ 
Linux

Code:
[root at centos-test ~]# cat /etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
IPADDR=192.168.100.71
NETMASK=255.255.255.0
NETWORK=192.168.100.0
BROADCAST=192.168.100.255
GATEWAY=192.168.100.1
ONBOOT=yes
BOOTPROTO=none
USERCTL=no

[root at centos-test ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

[root at centos-test ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

[root at centos-test~]# cat /etc/modprobe.conf
alias eth0 tg3
alias eth1 tg3
alias bond0 bonding
options bond0 mode=0 miimon=100
alias scsi_hostadapter cciss
alias usb-controller ohci-hcd

[root at centos-test ~]# modinfo tg3
filename:       /lib/modules/2.6.9-34.ELsmp/kernel/drivers/net/tg3.ko
author:         David S. Miller (davem at redhat.com) and Jeff Garzik  
(jgarzik at pobox.com)
description:    Broadcom Tigon3 ethernet driver
license:        GPL
version:        3.43f 7AC5B2FE640CA3E42CEB7C1
parm:           tg3_debug:Tigon3 bitmapped debugging message enable  
value
vermagic:       2.6.9-34.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4

Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ -----  
------------
2/11 Port 11            connected  256        normal a-full a-100  
10/100BaseTX
2/12 Port 12            connected  256        normal a-full a-100  
10/100BaseTX

2006 Jun 22 16:01:01 EDT -05:00 %ETHC-5-PORTTOSTP:Port 2/11 joined  
bridge port 2/11
2006 Jun 22 16:01:01 EDT -05:00 %ETHC-5-PORTTOSTP:Port 2/12 joined  
bridge port 2/12
2006 Jun 22 16:01:02 EDT -05:00 %SYS-4-P2_WARN: 1/Host  
00:14:38:4c:e1:ee is flapping between port 2/12 and port 2/11
2006 Jun 22 16:01:19 EDT -05:00 %SYS-4-P2_WARN: 1/Host  
00:14:38:4c:e1:ee is flapping between port 2/11 and port 2/12


Last edited by Scrutinizer; 02-27-2014 at 06:01 AM.. Reason: code tags
# 2  
Old 02-27-2014
Got this by googling:
If you are using the load balancing channel bonding, your router may complaint that the MAC address is flip flopping because the same MAC address is appearing in two different links.
If the use of load balancing is purely for redundancy, consider using active standby mode (mode=1). If not, most likely you have to work on your router configuration.
# 3  
Old 03-01-2014
I have tried doing this already, using mode=1 and the rest modes, but still have the same flapping in the switches that I have, I have no idea if there any other options in the Linux Server box should I stick with! Thanks anyway..
# 4  
Old 03-01-2014
Please check your LAN switch settings.
Further, there might be a bug in your NIC driver - a kernel patch might help.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Linux

Issue in Bonding during Reboot(Linux)

Respected Members, We encountered an issue during node reboot when eth1 and eth5 of bond1 were behaving unusual(both eth1 and eth5 were in unknown states and ifdown and ifup were used to rectify). Please find the messages and configuration files as below and please let me know for any other... (0 Replies)
Discussion started by: Mudit Bansal
0 Replies

2. Red Hat

Network bonding

Dear All , Very recently we have configured Network bonding in our Linux Server Redhat Linux 5.x. After configuring , we restarted the network services , the link was down after that , we could not login in to the Server. So after that , we logged in to console and tried to... (2 Replies)
Discussion started by: jegaraman
2 Replies

3. Red Hat

Network Bonding Issue

I have one production system where my customized application runs.The applications require seamless network connectivity with different machines connected in LAN and WAN. As these applications are very critical, it is very much required to have a seamless network activity.The applications are... (4 Replies)
Discussion started by: Anjan Ganguly
4 Replies

4. IP Networking

Is bond0 ready and a bonding interface? - 4G Bonding Router Problems (RPI)

HI all, First post on the forum, and my first proper project on the Paspberry Pi, so sorry if this is in the wrong place. I am trying to turn my Pi in to a 3G/4G Bonding router. I have been researching and trying this for a week or so now. The basic plan is to have up to 6 ZTE MF823 USB... (0 Replies)
Discussion started by: elliottlc
0 Replies

5. Red Hat

Bonding a Bond with LACP

Does anyone know if it's possible to bond two bonds together? My situation is I have two older Cisco switches that cannot carry a LACP (bond level 4) aggregated between them, but separate aggregates can be setup on the switches themselves. In order to have redundancy of two switches I would... (0 Replies)
Discussion started by: christr
0 Replies

6. Hardware

Flapping (reconnecting) external USB drive

Hi gurus, during playing movie via VLC or SMPlayer I get several time the error that file cannot be read. File was stored on external USB disk. During this error I get another dialogue message that says the new removable disk was connected..., just as if power goes off and on again or if I power on... (1 Reply)
Discussion started by: wakatana
1 Replies

7. Linux

ethernet bonding

I need to enable Ethernet Bonding on three systems, connected together via switch. What I tried ended up with failure, slaves cannot be detected n added to bon0. Here's what I did: created file /etc/modprobe.d/bonding.d and added the following to it: alias bond0 bonding options bonding... (2 Replies)
Discussion started by: dr_mabuse
2 Replies

8. IP Networking

Bonding of IP tunnels

Hello. Our Company is spreaded over Germany. There are main offices an branch offices. These offices are mostly connecte via multiple sdsl. We build a IPSEC VPN Infrastructure using Aastaro Security Gateways appliances. It seemed that only one VPN Connetion between to offices could be... (0 Replies)
Discussion started by: mschwadorf
0 Replies

9. IP Networking

Channel bonding Issue - Bond0 interface not getting up in on RHEL6

Hello, I am trying to set up Channel Bonding on a RHEL6 Virtual Box VM. I have 2 ethernet cards on the machine which are set up in Internal Network mode. I followed all the steps exactly as mentioned in the RHEL6 deployment Guide, but for some reason i think results are not correct. Here are my... (13 Replies)
Discussion started by: Rohit Bhanot
13 Replies

10. Red Hat

IP Bonding

Hi, What is IP bonding in Linux. What are its advantages How to create a IP bonding in redhat Linux. (1 Reply)
Discussion started by: chetansingh23
1 Replies
Login or Register to Ask a Question

Featured Tech Videos