Visit The New, Modern Unix Linux Community


DHCP lease problem

 
Thread Tools Search this Thread
Operating Systems Linux Red Hat DHCP lease problem
# 1  
MySQL DHCP lease problem

Hi frnds

I am testing DHCP server on vmware.I have two REDHAT 9 vmware machine.DHCP is installed on one machine and second machine is using as a client .I have configured DHCP with Ip Address ,Mask and Gateway.But client machine is not getting ip address.When i type ifconfig command on client it shows 127.0.0.1 loop back address and when i type service network restart it shows "Determining ip info for eth0....failed; no link present.check cable ?

please help me

Thanks
# 2  
I don't think it's a RedHat issue. Are you using ESX or Workstation for testing? In either case, shutdown the vm. Remove the virtual NIC from the vm config and then re-add it. Do make sure that the NIC is on the same network as the DHCP server. Otherwise things will not work.
This User Gave Thanks to admin_xor For This Post:
# 3  
I would also seriously recommend NOT using Red Hat 9 for your testing. As it has been end of lifed and support has been terminated, I would suggest you go with a distribution that is not 9 years old at this point.
This User Gave Thanks to mark54g For This Post:
# 4  
MySQL

I am using ESX .one more thing is my xp vmware client getting ip address from DHCP but my linux client having the above problem.I have re added the Nic but still same problem .
# 5  
What's the Adpater Type you selected: E1000? Also, as Mark said, we need to consider the age of the OS version you are using. Is the NIC showing up is you do an "ifconfig -a"? Is yes, what happens when you manually assign the IP? Can you ping the DHCP server after manually assigning the IP?
# 6  
Dear Vaibhav.T,
please make sure that your file on client machine
Code:
/etc/sysconfig/network-scripts/ifcfg-eth0  (plz replace 0 with your NIC number)

have the following line with the same arguments
Code:
BOOTPROTO=dhcp

# 7  
Dear All

Thanks for Reply.problem has solved.

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #758
Difficulty: Easy
The Amiga was a family of personal computers introduced by Microsoft in 1985.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Solaris 10- DHCP lease time increase

HI Admins, can anyone tell me how can I increase the lease time in Solaris 10. I want to use that dhcp address for 4 weeks. (2 Replies)
Discussion started by: snchaudhari2
2 Replies

2. IP Networking

Problem with script execution from a DHCP event

Hi, I'm installing a DHCPD Server with the packages from a distro SLES11 SP1 (dhcp-server-3.1.1-7.12). And a DNS Server with PowerDNS: pdns-recursor-3.3-1 pdns-static-3.0-1 The DHCP update de DNS Server, but PowerDNS is not RFC 2135 compliant, and I have to update the MySQL register... (5 Replies)
Discussion started by: bypper
5 Replies

3. UNIX for Dummies Questions & Answers

remove duplicate entries from dhcp.lease

Hi, I have to parse the dhcp.lease file and have to keep the most recent entry and remove the rest and also the number of lines between any two leases might not always be the same. eg: lease 5.5.5.252 { starts Wed Jul 27 09:48:39 2011 ends Wed Jul 27 21:48:39 2011 tstp Wed Jul... (1 Reply)
Discussion started by: bitspradp
1 Replies

4. IP Networking

DHCP lease under SuSE is not working., limited at 10 minutes

Hi, I got a strange issue here: We are using ISC DHCP v4 which is default in Open SuSE 11.4. These two options 'default-lease-time' and 'max-lease-time' are set in all subnets, with values between 43200 (12 hours) to 518400 (144 hours). See partial dhcpd.conf below please. Now the lease... (5 Replies)
Discussion started by: aixlover
5 Replies

5. UNIX for Advanced & Expert Users

DHCP lease under SuSE is not working. Why?

Hi, I got a strange issue here: We are using ISC DHCP v4 which is default in Open SuSE 11.4. These two options 'default-lease-time' and 'max-lease-time' are set in all subnets, with values between 43200 (12 hours) to 518400 (144 hours). See partial dhcpd.conf below please. Now the lease time... (0 Replies)
Discussion started by: aixlover
0 Replies

6. UNIX for Dummies Questions & Answers

DHCP problem and eth1 problem

At work I am trying to get this one Linux machine (let's call it ctesgm07) to behave like another Linux machine that we have (let's call it test007). test007 returns the following version info: cat /etc/debian_version: lenny/sid uname -a: Linux test007 2.6.27-7-generic #1 SMP Tue Nov 4... (0 Replies)
Discussion started by: sllinux
0 Replies

7. Red Hat

RHEL5 Kickstart NFS & DHCP Problem

I just finished setting up a Kickstart Server for our RHEL 5 installs. It's configured to use the PXE boot and NFS for the installation. Everything works fine when I just build one machine at a time. The installation works from begining to end. But when I try the install three machines at... (5 Replies)
Discussion started by: apfistler
5 Replies

8. IP Networking

Solaris Virtual Interface Problem in DHCP

Hi all, I am experiencing a problem with dhcp broadcast packages. these broadcast packages are seen on bge1 and bge1:1 interfaces but somehow they are not seen at bge771001 interface which is second virtual interface on the bge1 interface. I have a server on which I configured it as working... (2 Replies)
Discussion started by: ironoxide
2 Replies

9. UNIX for Dummies Questions & Answers

DHCP Problem

OS RHEL 5.1 After edit config file, daemon dhcpd does not run (( /etc/dhcpd.conf: ddns-update-style none; option domain-name "whitehouse.gov"; option domain-name-servers 10.0.0.1; option ntp-servers 10.0.0.2; default-lease-time 21600; max-lease-time 43200; subnet 10.0.0.0 netmask... (1 Reply)
Discussion started by: jess_t03
1 Replies

10. UNIX for Dummies Questions & Answers

DHCP Problem

I just installed Mandrake (Caldera) Verion 7.0 on my PC. The problem is I can not grab the and IP from my Router (running DHCP Server). I went to the root# and type linuxconf and it pops up for me the GUI, I have select "Enable" and "DHCP" but when I in Root#, type "ifconfig" it shows me the IP... (5 Replies)
Discussion started by: tony3101
5 Replies

Featured Tech Videos