Ethtool script not running on boot.

 
Thread Tools Search this Thread
Operating Systems Linux Red Hat Ethtool script not running on boot.
# 1  
Old 10-20-2011
Ethtool script not running on boot.

Hi, there is an incompatibility between my NIC and my Western Digital Powerline adapters which appears to cause autonegotiation to fail intermittently, most often following a reboot. Running the following Ethtool script will establish a connection immediately:

#!/bin/sh

# chkconfig: 345 85 15

ETHTOOL="/usr/sbin/ethtool"

DEV="eth0"
SPEED="100 duplex full"
case "$1" in
start)
echo -n "Setting eth0 speed 100 duplex full...";
$ETHTOOL -s $DEV speed $SPEED;
echo " done.";;
stop)
;;
esac
exit 0

I have tried placing this script in /etc/init.d, and it is shown as a selected option when running
ntsysv but to no avail.

The recommended method for Fedora is to add
ETHTOOL_OPTS="speed 100 duplex full autoneg off" to /etc/sysconfig/network-scripts/ifcfg-NameOfConnection which again is not working.

I'm running Fedora 15 64-bit, NIC = Intel 82562V-2 10/100.


If anyone is able to help out then they would probably save my hair from being wrenched out. Thanks

# 2  
Old 10-20-2011
does the directive:

Code:
ETHTOOL_OPTS

not work in your /etc/sysconfig/network-scripts/ifcfg-ethX file?

that is how most people go about adding those options sanely.
This User Gave Thanks to mark54g For This Post:
# 3  
Old 10-20-2011
Thanks but afraid that didn't work either, here's my config:

HWADDR=00:21:9B:0E:C7:4D
TYPE=Ethernet
BOOTPROTO=none
IPADDR0=192.168.1.10
PREFIX0=24
GATEWAY0=192.168.1.254
DNS1=192.168.1.254
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="Wired connection 1"
UUID=90bf39e6-4141-4839-a978-6156ba608ac0
ONBOOT=yes
ETHTOOL_OPTS="speed 100 duplex full autoneg off"
# 4  
Old 10-20-2011
Is there new firmware or new drivers for your cards/adapters?
# 5  
Old 10-21-2011
Can u try upgrade the latest firmware in to your and try this .... !
# 6  
Old 10-21-2011
No new firmware available so probably no fix for the underlying incompatibility but I'll give Intel's proprietary drivers a try as they may include a configuration utility - this is how I solved the problem on my Windows 7 install.

Probably won't have a chance to do this until quite a bit later today.

---------- Post updated at 04:11 PM ---------- Previous update was at 08:19 AM ----------

Can't compile the intel e100 driver - it keeps failing and advising that it can't install on kernel's older than 2.4 when I'm using 2.6.40. Removed the coding from the Makefile that stops it proceeding but I have no faith in the installed result as there was a long list of errors following make install.

Driver in use is intel's e1000e.

To be honest I'm about ready to give up on this and just purchase a new NIC, it's been an ongoing problem for some time.
# 7  
Old 10-21-2011
how are you doing this? Why is it trying to compile the E100 driver when you are using a gigabit adapter?
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Ethtool command not working

Hi All, I am trying to find my NIC card speed in centos 5. But i am unable to get the info using ethtool command. # ethtool eth0 Settings for eth0: Link detected: yes and even tried to look for the file # cd /sys/class/net/eth0/speed files which is also not available.... (8 Replies)
Discussion started by: sravani25
8 Replies

2. Red Hat

Can't boot RHEL7.2 due to "Start Job is Running"

Dear community, as already done tons of times, I prepare the RedHat installation on VMWare, then clone it with clonezilla, and finally restore it on final server. Due to different hrdware, I have to boot from rhel-server-7.4-x86_64-boot.iso cd and rewrite the initramfs that contains the hardware... (3 Replies)
Discussion started by: Lord Spectre
3 Replies

3. Shell Programming and Scripting

Script will keep checking running status of another script and also restart called script at night

I am using blow script :-- #!/bin/bash FIND=$(ps -elf | grep "snmp_trap.sh" | grep -v grep) #check snmp_trap.sh is running or not if then # echo "process found" exit 0; else echo "process not found" exec /home/Ketan_r /snmp_trap.sh 2>&1 & disown -h ... (1 Reply)
Discussion started by: ketanraut
1 Replies

4. UNIX for Dummies Questions & Answers

check service is running at boot

dears am having solaris 10, and i would like to know if the NTP service is running when the OS staritng?on the other hand how can i make it start at the boot up?note the ntp is managed by the SMF in solaris 10. thanks a lot (2 Replies)
Discussion started by: thehero
2 Replies

5. Programming

ethtool problem

Hi, I'm using ethtool to change network settings: Just for the experiment, i want to change speed to 10, instead of 100, I type: ethtool -s eth0 speed 10 duplex full autoneg off and to view settings i type: ethtool eth0, and get this: Settings for eth0: Supported ports: ... (4 Replies)
Discussion started by: alex889
4 Replies

6. Shell Programming and Scripting

ethtool : command not found

Hi, I am uising Suse linux on my system and i tried : man ethtool and i got the manual for ethtool but when i tried to use the command as: ethtool -a eth0 it says Command not found. also, i tried rpm -qa|grep ethtool i got: ethtool-3-15.2 so,it means my system has ethtool server or... (4 Replies)
Discussion started by: salil2012
4 Replies

7. Solaris

Running from Shell Vs running from RC script

Hi, i have a script which need to do behave differently when run as a startup process from init.d/ rc2.d script and when run manually from shell. How do i distinguish whether my script is run by init process or by shell?? Will the command /proc/$$/psinfo | grep "myscript" work well???... (2 Replies)
Discussion started by: vickylife
2 Replies

8. Ubuntu

system not booting after running local boot scripts

I have two systems in my computer . I update the ubuntu system these days and always interrupt it and exit the system . now the system cannot boot after Running local boot scripts(/etc/rc.local), it just stops there. i have to terminate the gnome display manager. what can i do with it ? thank... (0 Replies)
Discussion started by: tcb3210
0 Replies

9. Filesystems, Disks and Memory

Compile a code for running on boot

How can I compile a code that can be runned on boot:?? (2 Replies)
Discussion started by: d4n1l0d
2 Replies

10. UNIX for Dummies Questions & Answers

Running a program on boot!

Hi there! I tried to search for something like this here but couldn't find anything. I need to run a specific program when linux starts up. I need to run it after the rp-pppoe has started because this prog needs internet connection. I start the program by entering ./dynix start (its in my home... (4 Replies)
Discussion started by: D-Lexy
4 Replies
Login or Register to Ask a Question

Featured Tech Videos