Visit Our UNIX and Linux User Community


problem with Dependencies package !

 
Thread Tools Search this Thread
Operating Systems Linux Red Hat problem with Dependencies package !
# 1  
Old 06-16-2009
problem with Dependencies package !

Dear Friends ,

I am using RHEL 5 server . In Linux when I am going to install 'mod_ssl' rpm then I got the following error :

[root@station1 Server]# rpm -ivh mod_ssl-2.2.3-6.el5.i386.rpm --aid --force
warning: mod_ssl-2.2.3-6.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
libdistcache.so.1 is needed by mod_ssl-2.2.3-6.el5.i386
libnal.so.1 is needed by mod_ssl-2.2.3-6.el5.i386

In this moment , how can I find the related rpm of the above two dependencies and remove my problem ?

Advice me plz .. ..
# 2  
Old 06-16-2009
where did you get the rpms and why are you using a force flag on an rpm?

You are asking to break things.

First off, I'd need the output of the following commands:

cat /etc/redhat-release

arch

uname -va

Last edited by Neo; 06-22-2009 at 07:18 AM.. Reason: removed extra words
# 3  
Old 06-21-2009
problem with Dependencies package !

Thx friends for your kind reply ... I am using Redhat Ent 5 Linux . In RHEL 5 , I got the above problem sometimes . Plz help me , how I can solve the problem .

The output of the above commands :

[root@server ~]# uname -va
Linux server.example.com 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21 EST 2007 i686 i686 i386 GNU/Linux
[root@server ~]# arch
i686
[root@server ~]#
# 4  
Old 06-21-2009
where did you get the RPM?

The nokey error suggests that you got it from an unsigned source. Also, you should search google for the name of the rpms that contain the information you require. I would not use non Red Hat RPMs with the closest alternative being CentOS binary rpm packages.

Do an updatedb

then run the locate command like this:

locate libnal

locate libdistcache

you may have to make links to them in their current directories to the libnal.so.1 and libdistcache.so.1 if they exist.

You should also do an rpm -qa | grep -i distcache

If that is not installed, get that rpm from a reputable source
# 5  
Old 06-22-2009
problem with Dependencies package !

Friends ,

I am trying to install RPM from RHEL 5 enterprise DVD . I am trying with several DVD of RHEL 5 but face the same problem . But in RHEL4 , i never face such types of problem .

Thx friend for ur kind co-operation ... ..

Last edited by shipon_97; 06-22-2009 at 05:27 AM..
# 6  
Old 06-22-2009
If yum is available, use it. It will resolve the dependencies automatically. I know it is available on RHEL 5.3. Not use about earlier releases.

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Cygwin setup old package problem.

Hi there, I am in need to compile an old project for cygwin, but it needs some old packages to compile. I tried to download the x86 setup.exe from cygwin web site. Then downloaded the old packages from various sites and put it in an empty directory I run the setup.exe file and install from local... (1 Reply)
Discussion started by: lucky7456969
1 Replies

2. Emergency UNIX and Linux Support

Problem when trying to remove a package using rpm command - error: package is not installed

Hello, i have installed a package by using the command sudo rpm -i filepackage.rpm package filepackage is already installed when i try to remove it, i get an error saying "is not installed": sudo rpm -e filepackage.rpm error: package filepackage is not installed How can... (4 Replies)
Discussion started by: g_p
4 Replies

3. Solaris

php package installation problem

can u tell me the procedure to install php 5 using package .. i downloaded php-5.2.1-sol10-x86-local.gz from sunfreeware i have added package using pkgadd -d php-5.2.1-sol10-x86-local then i have added these two lines in httpd.conf LoadModule php5_module modules/libphp5.so... (7 Replies)
Discussion started by: senkerth
7 Replies

4. UNIX for Advanced & Expert Users

Problem with TCL package

Following error encountered while executing characterizationEngine.tcl :confused::confused: $ ./characterizationEngine.tcl Tcl Client is running Ixia Software version: 5.60 Can't find tclx.tcl in the following directories: /usr/lib/tclX8.3 /usr/lib/tclX8.3 /usr/lib/tclX8.3... (0 Replies)
Discussion started by: hiten.r.chauhan
0 Replies

5. UNIX for Dummies Questions & Answers

Problem while installing WAS ND package

Hi everyone, Hope u doing good. I am trying to installl WebSphere Application Server(WAS) ND package, i got problem at initial level I hope, the problem is with Mozilla browzer. Can anyone trobleshoot the problem An error occurred while starting the launchpad for a WebSphere Application ... (0 Replies)
Discussion started by: sarfraz
0 Replies

6. Programming

Dependencies problem GNU automake

I am using the GNU automake. I have created the Configure.in and Makefile.am files but don't know how to link in my dependencies. I have basically added another project (OpenCV) to my eclipse workspace and want to reference this in the build. I have set Eclipse up to include the Cpp files... (5 Replies)
Discussion started by: hembergb
5 Replies

7. Solaris

Problem in instaling package SUNWman

Hi All, I am trying to install the package from CD rom and i am unable to do. i have located the package in CD and its there however when i am trying to run pkgadd -d /cdrom/sol_10_508_sparc_5/Solaris_10/Product/SUNWman i am getting error pkgadd: ERROR: no packages were found in... (4 Replies)
Discussion started by: kumarmani
4 Replies

8. Solaris

Problem with solaris 10 installation package

Hi, I want to install man pages package from solaris 10. Solaris 10 has already been installed on my servor but I have to add the man pages packages. I search for a long time on internet this package but I didn't find a compatible one... So I downloaded Solaris 10 from Sun site to get this... (12 Replies)
Discussion started by: MasterapocA
12 Replies

9. Linux

Help needed in dependencies problem in Fedora 8 VM

hi, I have installed a VM for Fedora 8 running on Windows Xp. And I have the following error:- Error: Missing Dependency: libgsl.so.0 is needed by package test Error: Missing Dependency: /usr/bin/gcc is needed by package test Error: Missing Dependency: libgslcblas.so.0 is needed by... (3 Replies)
Discussion started by: ahjiefreak
3 Replies

10. UNIX for Advanced & Expert Users

Solaris Package Manager problem

i'm trying to run Patch Manager, but i'm getting the following problem when i try and run "pprosvc" with either the -l, -d, or -i options. Assessing patches needed for your system...... (8 Replies)
Discussion started by: xyyz
8 Replies

Featured Tech Videos