installing gcc-3.1 on Irix 6.5.15


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Question installing gcc-3.1 on Irix 6.5.15

I am trying to install gcc-3.1 in an SGI Indigo2 running Irix 6.5.15.

When I try to configure gcc-3.1 I keep getting the following message:

Created "Makefile in gcc/ using "mh-frag"
cc ERROR: cannot exec /usr/lib32/cmplrs/fec
*** The command 'cc -o conftest -g conftest.c' failed
*** You must set the environment variable CC to a working compiler

What does this mean and how do I fix it?



If I ignore this message and type: make bootstrap , I get the error message:

make: 'Makefile' line 1245: Syntax error

What does this mean and how do I fix it?

Mike
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #683
Difficulty: Medium
According to both NetMarketShare and WikiMedia, Safari has a desktop market share of over 6% in 2019.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Installing gcc on Fedora

I am trying to install gcc4.8.2 on fedora but have encountered problems. This is the error I got when running configure configure: error: Building GCC requires GMP 4.2+, MPFR 2.4.0+ and MPC 0.8.0+. So I went along to install the three of them I installed gmp-4.3.2 which went ok ... (14 Replies)
Discussion started by: kristinu
14 Replies

2. Solaris

GCC installing

dear, please just didn't understand the problem that appears when i try to install ./configure here is the message that appears in unix when installing gcc root@ccbtest # ./configure checking build system type... /bin/bash: ./config.guess: No such file or directory configure: error: cannot... (3 Replies)
Discussion started by: semaan
3 Replies

3. Solaris

Help with installing gcc on Solaris 10

I want to install gcc for Solaris 10 to an alternate location besides /usr/local/bin, so I can't use the pre-compiled package from sunfreeware.com. So I assume I need to compile gcc for myself and specify --prefix. How can I accomplish this? Am I pretty much out of luck trying to compile... (3 Replies)
Discussion started by: srhadden
3 Replies

4. UNIX for Advanced & Expert Users

Installing GCC and other utils

I have a platform whose base is Linux but not everything is available on that. Only necessary executables are available and any individual executable can run on that. It is 32-bit and uname -a shows Linux 2.6.11.11. Problem is I am trying to install gcc compiler on that to debug an issue. Even... (1 Reply)
Discussion started by: radiatejava
1 Replies

5. Solaris

Installing gcc - recieve error message gcc : cannot execute

AIM- Install Oracle 11g on Solaris using VMWare Steps 1.Logged on as root 2.Created subfolders /usr/local/bin & /usr/local/bin/gcc 3.Downloaded gcc & libiconv & unzipped them on my harddrive & burnt them on CD 4.Copied files from CD to /usr/local/bin/gcc 5.Terminal (root) pkgadd d... (8 Replies)
Discussion started by: Ackers
8 Replies

6. Solaris

Error when installing GCC

GCC 3.4.6 was installed in Solaris 2.8. I ran the commands ./configure and make. When running make install I got the below mentioned errors at the end. Please help me in resolving the same. make: *** Error 1 make: Leaving directory `/gmsp/antony/gcc-3.4.6/sparc-sun-solaris2.8/sparcv9/libf2c'... (1 Reply)
Discussion started by: chrisanto_2000
1 Replies

7. Programming

Installing gcc

Hi all I'm trying to install the latest version of gcc but I keep getting this message on make; gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -I./../zlib -I./../include -W -Wall -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -g -O2 -c jartool.c jartool.c:234: getopt.h: No... (3 Replies)
Discussion started by: squeakywheel
3 Replies

8. UNIX for Dummies Questions & Answers

Installing Cable Modem on Irix Machine.

Ok I am new to this and wondering if there is any way of connecting a cable modem to an SGI that is running IRIX 6.5 and how to do it... (1 Reply)
Discussion started by: Acidjack
1 Replies

9. UNIX for Dummies Questions & Answers

Problem installing gcc

Hi! I have downloaded a precompiled gcc package but Im having problems installing it. It is supposed to install in /usr/local and there is plenty of space left there but during the installation I get the following error message No space left on device. Is it some kind of temp folder that is out... (2 Replies)
Discussion started by: alfabetman
2 Replies

10. Programming

Help!(Installing GCC.)

(Installing GCC: Configuration) In the document of Installing GCC, there is a sentence I don't understand: " Second, when configuring a native system, either cc or gcc must be in your path or you must set CC in your environment before running configure. Otherwise the configuration scripts... (2 Replies)
Discussion started by: wwz
2 Replies
PERLIRIX(1)						 Perl Programmers Reference Guide					       PERLIRIX(1)

NAME
README.irix - Perl version 5 on Irix systems DESCRIPTION
This document describes various features of Irix that will affect how Perl version 5 (hereafter just Perl) is compiled and/or runs. Building 32-bit Perl in Irix Use sh Configure -Dcc='cc -n32' to compile Perl 32-bit. Don't bother with -n32 unless you have 7.1 or later compilers (use cc -version to check). (Building 'cc -n32' is the default.) Building 64-bit Perl in Irix Use sh Configure -Dcc='cc -64' -Duse64bitint This requires require a 64-bit MIPS CPU (R8000, R10000, ...) You can also use sh Configure -Dcc='cc -64' -Duse64bitall but that makes no difference compared with the -Duse64bitint because of the "cc -64". You can also do sh Configure -Dcc='cc -n32' -Duse64bitint to use long longs for the 64-bit integer type, in case you don't have a 64-bit CPU. If you are using gcc, just sh Configure -Dcc=gcc -Duse64bitint should be enough, the Configure should automatically probe for the correct 64-bit settings. About Compiler Versions of Irix Some Irix cc versions, e.g. 7.3.1.1m (try cc -version) have been known to have issues (coredumps) when compiling perl.c. If you've used -OPT:fast_io=ON and this happens, try removing it. If that fails, or you didn't use that, then try adjusting other optimization options (-LNO, -INLINE, -O3 to -O2, etcetera). The compiler bug has been reported to SGI. (Allen Smith <easmith@beatrice.rutgers.edu>) Linker Problems in Irix If you get complaints about so_locations then search in the file hints/irix_6.sh for "lddflags" and do the suggested adjustments. (David Billinghurst <David.Billinghurst@riotinto.com.au>) Malloc in Irix Do not try to use Perl's malloc, this will lead into very mysterious errors (especially with -Duse64bitall). Building with threads in Irix Run Configure with -Duseithreads which will configure Perl with the new Perl 5.8.0 "interpreter threads", see threads. The old Perl 5.005 threads is obsolete, unmaintained, and its use is discouraged. If you really want it, run Configure with the -Dusethreads -Duse5005threads options as described in INSTALL. For either thread model and for Irix 6.2, you have to have the following patches installed: 1404 Irix 6.2 Posix 1003.1b man pages 1645 Irix 6.2 & 6.3 POSIX header file updates 2000 Irix 6.2 Posix 1003.1b support modules 2254 Pthread library fixes 2401 6.2 all platform kernel rollup IMPORTANT: Without patch 2401, a kernel bug in Irix 6.2 will cause your machine to panic and crash when running threaded perl. Irix 6.3 and later are okay. Thanks to Hannu Napari <Hannu.Napari@hut.fi> for the IRIX pthreads patches information. AUTHOR
Jarkko Hietaniemi <jhi@iki.fi> Please report any errors, updates, or suggestions to perlbug@perl.org. perl v5.8.0 2003-02-18 PERLIRIX(1)

Featured Tech Videos