Need some help with lost data on external drive

Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Need some help with lost data on external drive

Hi all,

I would really appreciate some assistance with some lost data on external drive. The external is a Seagate Goflex 3TB drive, Desktop hard drive | External Desktop hard drives | FreeAgent | GoFlex Desk | Seagate

The purpose of the drive is to do time machine backups to it from my mac. I also have three folders on the drive (software, movies and computer training stuff). Those are supposed to be backed up to the cloud to my crash plan account. But they aren't there; that's another story. I'm kicking myself now, because I know better.

The drive has been making some weird noises lately. It is still under warranty for another month or so, luckily. I have started the RMA process. They are shipping me a new drive, and once I get it I will ship the old one back to them. In the meantime, I need to get my stuff off that drive to another one to restore.

The drive is encrypted with file vault. So it won't allow me to mount it on a Windows system. My neighbor is a Mac guy too, so I sent him a message asking him if I can mount the drive on his system in order to see if I can see the files on his system.

As you can see from the output, there is definitely data on it, since about 26% is being used.

Code:
$ df -h /Volumes/Data/
Filesystem Size Used Avail Capacity iused ifree %iused Mounted on
/dev/disk4 2.7Ti 724Gi 2.0Ti 26% 94949497 271238073 26% /Volumes/Data

This shows the directories:
Code:
$ ls /Volumes/Data/
Backups.backupdb	Movies	 tmbootpicker.efi
Computer_Training	Software

This is showing the size of what's in the directories:
Code:
$ for j in `ls /Volumes/Data/`; do du -sh /Volumes/Data/$j; done
16K	/Volumes/Data/.DS_Store
168K	/Volumes/Data/.DocumentRevisions-V100
1.3M	/Volumes/Data/.Spotlight-V100
0B	/Volumes/Data/.TemporaryItems
0B	/Volumes/Data/.Trashes
920K	/Volumes/Data/.VolumeIcon.icns
8.0K	/Volumes/Data/.disk_label
8.0K	/Volumes/Data/.disk_label_2x
8.0K	/Volumes/Data/.fseventsd
8.0K	/Volumes/Data/Backups.backupdb
692M	/Volumes/Data/Computer_Training
0B	/Volumes/Data/Movies
0B	/Volumes/Data/Software
120K	/Volumes/Data/tmbootpicker.efi

So you can see that all of the above doesn't equal to the 724GB that is being used.

Am I missing something? Can anyone offer any assistance?

Last edited by Scrutinizer; 08-26-2014 at 01:17 PM.. Reason: code tags
# 2  
If you keep poking at your drive while it is "making funny noises" you are going to lose it completely. Make a raw dd copy if you have to, but get the contents off!

Either that, or stop poking at it until you have something to copy it onto.
This User Gave Thanks to Corona688 For This Post:
# 3  
Quote:
Originally Posted by Corona688
If you keep poking at your drive while it is "making funny noises" you are going to lose it completely. Make a raw dd copy if you have to, but get the contents off!

Either that, or stop poking at it until you have something to copy it onto.
I agree, that I was not thinking clearly at this time.

I do have some good news to report, though. I have the drive mounted, and I am in the process of copying the data off.

---------- Post updated at 01:31 PM ---------- Previous update was at 01:08 PM ----------

I tried to manually copy the folders from one drive to another.

I tried to copy files from the failing drive to another drive. I get this error, "The operation can't be completed because the item XYZ is in use."

So then I try to open the terminal and issue this command:

Code:
$ cp -R /Volumes/Data/Software /Volumes/DATA2/

And it starts, then errors out.

So then I tried to tar up the directory. That started, then would error out.

I was going to try the dd command like suggested, but the destination disk was smaller than the amount that I had on the source disk. I am not familiar with that command, and I couldn't see how to copy a specific directory over.

So then after I was about to cry (not really...well almost), I realized that rsync would probably work.

So I kicked this off, and I got one directory to sync over to my other drive. I will do the other one now. I didn't want to tempt it, and just did the most important data first.

Code:
rsync -larP --exclude ".DS_Store" --exclude ".TemporaryItems" --exclude ".Trashes" /Volumes/Data/Software /Volumes/Data2/Software >> /Users/<snipped>/Desktop/rsync.log 2>&1

# 4  
tar shouldn't die halfway, just continue and print warnings. GNU tar, anyway. Good luck.
This User Gave Thanks to Corona688 For This Post:
# 5  
Quote:
Originally Posted by Corona688
tar shouldn't die halfway, just continue and print warnings. GNU tar, anyway. Good luck.
Maybe it wasn't an error, and more of a message. This is what I was seeing when I tried the tar:

tar: Truncated input file (needed 3256915968 bytes, only 3256910848 available)
tar: Error exit delayed from previous errors.
# 6  
It means what it says, it had trouble reading one (or more) of the input files, as one might exepct of a dying hard drive. But it didn't actually quit, it waited until it was done to quit with error.
This User Gave Thanks to Corona688 For This Post:
# 7  
Quote:
Originally Posted by Corona688
It means what it says, it had trouble reading one (or more) of the input files, as one might exepct of a dying hard drive. But it didn't actually quit, it waited until it was done to quit with error.
Thanks.

I learned a huge lesson from this. And the ironic thing is that I was in the process to get all of my stuff backed up just in case. This was the last of those drives.

I'm trying to get more organized.
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

9 More Discussions You Might Find Interesting

1. Solaris

How i can backup data's to External Drive in Solaris 10/11?

Hello all, I'm new member and it's a very important for me. I need to backup data's from 3 server ( V880, M5000m and V490) I dont have a chance to use NFS. So i need to backup to Usb External Drive, can you help me with this issue? I dont have any experience about backup, but i need to... (1 Reply)
Discussion started by: sahkel
1 Replies

2. UNIX for Advanced & Expert Users

External hard drive

I have connected an external hard drive. I can't find it. Both ls /media, fdisk -l and ls /dev show nothing. TIA (3 Replies)
Discussion started by: Meow613
3 Replies

3. Red Hat

Usb external drive

Hi Guys I am using RHEL5 O/S. We have mounted the usb external hard drive to the server as root. I want the user oracle to be able to write into this external hard drive. How do i do that ? Please Help!!! (1 Reply)
Discussion started by: Phuti
1 Replies

4. Debian

Unable to mount external drive

Trying to mount an external 160GB Toshiba drive but.... this is my dmesg tail output: usb 2-2: new high speed USB device using ehci_hcd and address 3 usb 2-2: New USB device found, idVendor=13fd, idProduct=1618 usb 2-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0 usb 2-2:... (4 Replies)
Discussion started by: Ridson
4 Replies

5. Filesystems, Disks and Memory

Partitioning External Drive

I am about to set up another triple boot drive, but this one is connected to my MacBook with a USB adapter. I want to be sure that I do not overwrite data on my laptop's internal drive. This is the command I used for the internal drive, which was found in an Ubuntu forum, but the sizes were changed... (0 Replies)
Discussion started by: MacInAction
0 Replies

6. AIX

external DDS4 Tape Drive

Hi folks, I've got a little problem concerning my external dds4 tape drive. I've got 2 rs6000 systems, one has a external dds4 tape drive attached, I want to attach the tape drive to the other rs6000 system so that i can restore data from the 1st rs6000 on to the second. Does anybody has... (3 Replies)
Discussion started by: Erik Rooijmans
3 Replies

7. UNIX for Dummies Questions & Answers

External SCSI hard drive

Someone gave me a small external SCSI hard drive for my SunOS 5.8 test system. How do I make Unix see the hard drive? (2 Replies)
Discussion started by: FredSmith
2 Replies

8. UNIX for Dummies Questions & Answers

Lost CDROM drive

I haven't used the cdrom (actually dvdrom) drive on my server in months. I put the dvd in the drive but can't see it. I did an: iostat -En but don't see anything that says cdrom or dvd, what could be the problem? Thanks! (1 Reply)
Discussion started by: FredSmith
1 Replies

9. Filesystems, Disks and Memory

Lost Data Lost Admin

First time so excuse my ignorance please. I may not be accurately describing the issue. I have inherited a small lab mostly SUN V120s. We lost power and are trying to recover. Nope no backups... The primary issue I have is 1 box is an Oracle Server. It has 2 36Gb harddrives. I am able to... (3 Replies)
Discussion started by: murphsr
3 Replies

Featured Tech Videos