Query: drv_priv
OS: ultrix
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
drv_priv(9F) Kernel Functions for Drivers drv_priv(9F) NAME
drv_priv - determine driver privilege SYNOPSIS
#include <sys/types.h> #include <sys/cred.h> #include <sys/ddi.h> int drv_priv(cred_t *cr); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
cr Pointer to the user credential structure. DESCRIPTION
drv_priv() provides a general interface to the system privilege policy. It determines whether the credentials supplied by the user creden- tial structure pointed to by cr identify a process that has the {PRIV_SYS_DEVICES} privilege asserted in its effective set. This function should be used only when file access modes, special minor device numbers, and the device policy (see privileges(5), add_drv(1M)) are insuf- ficient to provide protection for the requested driver function. It is intended to replace all calls to suser() and any explicit checks for effective user ID = 0 in driver code. RETURN VALUES
This routine returns 0 if it succeeds, EPERM if it fails. CONTEXT
drv_priv() can be called from user or interrupt context. SEE ALSO
add_drv(1M), update_drv(1M), privileges(5) Writing Device Drivers SunOS 5.10 29 Jan 2003 drv_priv(9F)
Related Man Pages |
---|
drv_priv(9f) - sunos |
drv_priv(9f) - debian |
drv_priv(9f) - osx |
drv_priv(9f) - xfree86 |
drv_priv(9f) - posix |
Similar Topics in the Unix Linux Community |
---|
Lost root password / Can't login as root |
How do you detect keystrokes in canonical mode? |
PHP Write Man Pages to MySQL DB |