sunos man page for usb_get_current_frame_number

Query: usb_get_current_frame_number

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

usb_get_current_frame_number(9F)			   Kernel Functions for Drivers 			  usb_get_current_frame_number(9F)

NAME
usb_get_current_frame_number - Return current logical usb frame number
SYNOPSIS
#include <sys/usb/usba.h> usb_frame_number_t usb_get_current_frame_number(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
dip Pointer to the device's dev_info structure.
DESCRIPTION
The usb_get_current_frame_number() function retrieves the current logical USB frame number. Isochronous requests can be started on a particular numbered frame. An offset number of frames (typically between 4 and 10) can be added to the current logical frame number to specify the number of an upcoming frame to start an isochronous request. The USB specification requires that the frame frequency (the period between start-of-frame packets) is one millisecond. The Solaris oper- ating environment USB implementation uses a running counter of the number of milliseconds since boot as the current logical frame number.
RETURN VALUES
On success, the usb_get_current_frame_number() function returns the current USB frame number. On failure it returns 0. The function fails if dip is NULL.
CONTEXT
May be called from user, kernel or interrupt context.
EXAMPLES
usb_pipe_handle_t handle; usb_frame_number_t offset = 10; usb_isoc_req_t *isoc_req; isoc_req = usb_alloc_isoc_req(...); ... ... isoc_req->isoc_frame_no = usb_get_current_frame_number(dip) + offset; isoc_req->isoc_attributes = USB_ATTRS_ISOC_START_FRAME; ... ... if (usb_pipe_isoc_xfer(handle, isoc_req, 0) != USB_SUCCESS) { ... }
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), usb_alloc_isoc_req(9F), usb_get_max_pkts_per_isoc_request(9F), usb_pipe_isoc_xfer(9F), usb_pipe_get_max_bulk_trans- fer_size(9F), usb_isoc_request(9S) SunOS 5.10 25 July 2004 usb_get_current_frame_number(9F)
Related Man Pages
usb_pipe_stop_isoc_polling(9f) - opensolaris
usb_alloc_intr_req(9f) - sunos
usb_get_current_frame_number(9f) - sunos
usb_pipe_stop_isoc_polling(9f) - sunos
usb_request_attributes(9s) - sunos
Similar Topics in the Unix Linux Community
Not able to create any file name start with &quot;-&quot; hyphen in Solaris
T5220 not able to boot from USB