Query: usb_get_addr
OS: sunos
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
usb_get_addr(9F) Kernel Functions for Drivers usb_get_addr(9F)NAMEusb_get_addr - Retrieve device USB addressSYNOPSIS#include <sys/usb/usba.h> int usb_get_addr(dev_info_t *dip);INTERFACE LEVELSolaris DDI specific (Solaris DDI)PARAMETERSdip Pointer to the device's dev_info structure.DESCRIPTIONThe usb_get_addr() function returns the current USB bus address for debugging purposes. The returned address is unique for a specific USB bus, and may be replicated if multiple host controller instances are present on the system.RETURN VALUESOn success: USB device address. On failure: returns 0. Fails if dip is NULL.CONTEXTMay be called from user, kernel or interrupt context.EXAMPLESint usb_addr; usb_addr = usb_get_addr(dip);ATTRIBUTESSee attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+SEE ALSOattributes(5), usb_pipe_open(9F) SunOS 5.10 Feb 9 2004 usb_get_addr(9F)
Similar Topics in the Unix Linux Community |
---|
Sunray, Solaris, Webcams |
Does Solaris Volume Manager support USB flash drives? |