sunos man page for unbufcall

Query: unbufcall

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

unbufcall(9F)						   Kernel Functions for Drivers 					     unbufcall(9F)

NAME
unbufcall - cancel a pending bufcall request
SYNOPSIS
#include <sys/stream.h> void unbufcall(bufcall_id_t id);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
id Identifier returned from bufcall(9F) or esbbcall(9F) .
DESCRIPTION
unbufcall cancels a pending bufcall() or esbbcall() request. The argument id is a non-zero identifier for the request to be cancelled. id is returned from the bufcall() or esbbcall() function used to issue the request. unbufcall() will not return until the pending callback is cancelled or has run. Because of this, locks acquired by the callback routine should not be held across the call to unbufcall() or deadlock may result.
RETURN VALUES
None.
CONTEXT
unbufcall() can be called from user or interrupt context.
SEE ALSO
bufcall(9F), esbbcall(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 18 Feb 1998 unbufcall(9F)
Related Man Pages
unbufcall(9f) - sunos
esbbcall(9f) - sunos
unbufcall(9f) - centos
unbufcall(9f) - xfree86
unbufcall(9f) - bsd
Similar Topics in the Unix Linux Community
The 500 Mile Email
Is UNIX an open source OS ?
Once upon an uptime.
Best performance UNIX just for HOST Virtualization?
Outputting sequences based on length with sed