sunos man page for rmalloc_wait

Query: rmalloc_wait

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

rmalloc_wait(9F)					   Kernel Functions for Drivers 					  rmalloc_wait(9F)

NAME
rmalloc_wait - allocate space from a resource map, wait if necessary
SYNOPSIS
#include <sys/map.h> #include <sys/ddi.h> unsigned long rmalloc_wait(struct map *mp, size_t size);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
mp Pointer to the resource map from which space is to be allocated. size Number of units of space to allocate.
DESCRIPTION
rmalloc_wait() requests an allocation of space from a resource map. rmalloc_wait() is similar to the rmalloc(9F) function with the excep- tion that it will wait for space to become available if necessary.
RETURN VALUES
rmalloc_wait() returns the base of the allocated space.
CONTEXT
This function can be called from user or interrupt context. However, in most cases rmalloc_wait() should be called from user context only.
SEE ALSO
rmalloc(9F), rmallocmap(9F), rmfree(9F), rmfreemap(9F) Writing Device Drivers SunOS 5.10 28 Apr 1992 rmalloc_wait(9F)
Related Man Pages
bp_mapin(9f) - opensolaris
rmfree(9f) - opensolaris
rmalloc(9f) - sunos
rmalloc(9f) - opensolaris
rmallocmap_wait(9f) - opensolaris
Similar Topics in the Unix Linux Community
Storing string with space (urgent)
Replace long space to become one space?