sunos man page for repoutsw

Query: repoutsw

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

outb(9F)						   Kernel Functions for Drivers 						  outb(9F)

NAME
outb, outw, outl, repoutsb, repoutsw, repoutsd - write to an I/O port
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void outb(int port, unsigned char value); void outw(int port, unsigned short value); void outl(int port, unsigned long value); void repoutsb(int port, unsigned char *addr, int count); void repoutsw(int port, unsigned short *addr, int count); void repoutsd(int port, unsigned long *addr, int count);
INTERFACE LEVEL
The functions described here are obsolete. For the outb(), outw(), and outl() functions use, respectively, ddi_put8(9F), ddi_put16(9F), and ddi_put32(9F) instead. For repoutsb(), repoutsw(), andrepoutsl(), use, respectively, ddi_rep_put8(9F), ddi_rep_put16(9F), and ddi_rep_put32(9F) instead.
PARAMETERS
port A valid I/O port address. value The data to be written to the I/O port. addr The address of a buffer from which the values will be fetched. count The number of values to be written to the I/O port.
DESCRIPTION
These routines write data of various sizes to the I/O port with the address specified by port. The outb(), outw(), and outl() functions write 8 bits, 16 bits, and 32 bits of data respectively, writing the data specified by value. The repoutsb(), repoutsw(), and repoutsd() functions write multiple 8-bit, 16-bit, and 32-bit values, respectively. count specifies the number of values to be written. addr is a pointer to a buffer from which the output values are fetched.
CONTEXT
These functions may be called from user or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |x86 | +-----------------------------+-----------------------------+ |Stability Level |Obsolete | +-----------------------------+-----------------------------+
SEE ALSO
isa(4), attributes(5), ddi_put8(9F), ddi_put16(9F), ddi_put32(9F), ddi_rep_put8(9F), ddi_rep_put16(9F), ddi_rep_put32(9F), inb(9F) Writing Device Drivers SunOS 5.10 18 Nov 2004 outb(9F)
Related Man Pages
outb(9f) - sunos
outw(9f) - sunos
repoutsd(9f) - sunos
repoutsw(9f) - sunos
outl(9f) - opensolaris
Similar Topics in the Unix Linux Community
The 500 Mile Email
How to convert number to english?
Using awk to remove lines from file that match text
Best performance UNIX just for HOST Virtualization?