sunos man page for qenable

Query: qenable

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

qenable(9F)						   Kernel Functions for Drivers 					       qenable(9F)

NAME
qenable - enable a queue
SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> void qenable(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue to be enabled.
DESCRIPTION
qenable() adds the queue pointed to by q to the list of queues whose service routines are ready to be called by the STREAMS scheduler.
CONTEXT
qenable() can be called from user or interrupt context.
EXAMPLES
See the dupb(9F) function page for an example of the qenable().
SEE ALSO
dupb(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 qenable(9F)
Related Man Pages
qenable(8b) - minix
qenable(8b) - x11r4
qenable(8b) - redhat
qenable(8b) - linux
qenable(8b) - bsd
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
How to convert number to english?
Merge and Sort tabular data from different text files
Once upon an uptime.
Outputting sequences based on length with sed