sunos man page for numtos

Query: numtos

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

stoi(9F)						   Kernel Functions for Drivers 						  stoi(9F)

NAME
stoi, numtos - convert between an integer and a decimal string
SYNOPSIS
#include <sys/ddi.h> int stoi(char **str); void numtos(unsigned long num, char *s);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
str Pointer to a character string to be converted. num Decimal number to be converted to a character string. s Character buffer to hold converted decimal number.
DESCRIPTION
stoi() stoi() returns the integer value of a string of decimal numeric characters beginning at **str. No overflow checking is done. *str is updated to point at the last character examined. numtos() numtos() converts a long into a null-terminated character string. No bounds checking is done. The caller must ensure there is enough space to hold the result.
RETURN VALUES
stoi() returns the integer value of the string str.
CONTEXT
stoi() can be called from user or interrupt context.
SEE ALSO
Writing Device Drivers
NOTES
stoi() handles only positive integers; it does not handle leading minus signs. SunOS 5.10 3 Mar 1994 stoi(9F)
Related Man Pages
kstat_named_init(9f) - opensolaris
ddi_strtoull(9f) - opensolaris
kstat_named_setstr(9f) - sunos
sprintf(9f) - sunos
ddi_strtol(9f) - opensolaris
Similar Topics in the Unix Linux Community
Is UNIX an open source OS ?
How to convert number to english?
Once upon an uptime.
Sort only numbers within a string