sunos man page for ldi_dump

Query: ldi_dump

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_dump(9F)						   Kernel Functions for Drivers 					      ldi_dump(9F)

NAME
ldi_dump - Issue a dump request to a device
SYNOPSIS
#include <sys/sunldi.h> int ldi_dump(ldi_handle_t lh, caddr_t addr, daddr_t blkno, int nblk);
PARAMETERS
lh Layered handle. addr Area dump address. blkno Block offset to dump memory. nblk Number of blocks to dump.
DESCRIPTION
The ldi_dump() function passes a dump request to the device entry point specified by the layered handle. This operation is supported for block devices.
RETURN VALUES
The ldi_dump() function returns 0 upon success. If a failure occurs before the request is passed on to the device, the possible return val- ues are shown below. Otherwise any other error number may be returned by the device. EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device.
CONTEXT
These functions may be called from user or kernel context. SunOS 5.10 3 June 2003 ldi_dump(9F)
Related Man Pages
dump(9e) - opensolaris
ldi_read(9f) - sunos
ldi_write(9f) - sunos
ldi_strategy(9f) - opensolaris
ldi_read(9f) - opensolaris
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
How to convert number to english?
Best performance UNIX just for HOST Virtualization?
UNIX Environment Setup - (Just starting!)