sunos man page for ioc_convert_from

Query: ioc_convert_from

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

IOC_CONVERT_FROM(9F)					   Kernel Functions for Drivers 				      IOC_CONVERT_FROM(9F)

NAME
IOC_CONVERT_FROM - determine if there is a need to translate M_IOCTL contents.
SYNOPSIS
#include <sys/stream.h> uint_t IOC_CONVERT_FROM(struct iocblk *iocp);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
iocp A pointer to the M_IOCTL control structure.
DESCRIPTION
The IOC_CONVERT_FROM macro is used to see if the contents of the current M_IOCTL message had its origin in a different C Language Type Model.
RETURN VALUES
IOC_CONVERT_FROM() returns the following values: IOC_ILP32 This is an LP64 kernel and the M_IOCTL originated in an ILP32 user process. IOC_NONE The M_IOCTL message uses the same C Language Type Model as this calling module or driver.
CONTEXT
IOC_CONVERT_FROM() can be called from user or interrupt context.
SEE ALSO
ddi_model_convert_from(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Nov 1996 IOC_CONVERT_FROM(9F)
Related Man Pages
mcopyin(9f) - sunos
mioc2ack(9f) - sunos
mkiocb(9f) - sunos
miocack(9f) - sunos
mcopyout(9f) - opensolaris
Similar Topics in the Unix Linux Community
The 500 Mile Email
Is UNIX an open source OS ?
Best performance UNIX just for HOST Virtualization?
UNIX Environment Setup - (Just starting!)