sunos man page for getq

Query: getq

OS: sunos

Section: 9f

Links: sunos man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

getq(9F)						   Kernel Functions for Drivers 						  getq(9F)

NAME
getq - get the next message from a queue
SYNOPSIS
#include <sys/stream.h> mblk_t *getq(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue from which the message is to be retrieved.
DESCRIPTION
getq() is used by a service ( srv(9E)) routine to retrieve its enqueued messages. A module or driver may include a service routine to process enqueued messages. Once the STREAMS scheduler calls srv() it must process all enqueued messages, unless prevented by flow control. getq() obtains the next available message from the top of the queue pointed to by q. It should be called in a while loop that is exited only when there are no more messages or flow control prevents further processing. If an attempt was made to write to the queue while it was blocked by flow control, getq() back-enables (restarts) the service routine once it falls below the low water mark.
RETURN VALUES
If there is a message to retrieve, getq() returns a pointer to it. If no message is queued, getq() returns a NULL pointer.
CONTEXT
getq() can be called from user or interrupt context.
EXAMPLES
See dupb(9F).
SEE ALSO
srv(9E), bcanput(9F), canput(9F), dupb(9F), putbq(9F), putq(9F), qenable(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 12 Nov 1992 getq(9F)
Related Man Pages
getq(9f) - debian
getq(9f) - centos
getq(9f) - php
getq(9f) - minix
getq(9f) - bsd
Similar Topics in the Unix Linux Community
Help with sed
awk length count
How to delete blank line/s before and after a search pattern?
[Bash] passing variables to executable doesn't work