sunos man page for geterror

Query: geterror

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

geterror(9F)						   Kernel Functions for Drivers 					      geterror(9F)

NAME
geterror - return I/O error
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> #include <sys/ddi.h> int geterror(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to a buf(9S) structure.
DESCRIPTION
geterror() returns the error number from the error field of the buffer header structure.
RETURN VALUES
An error number indicating the error condition of the I/O request is returned. If the I/O request completes successfully, 0 is returned.
CONTEXT
geterror() can be called from user or interrupt context.
SEE ALSO
buf(9S) Writing Device Drivers SunOS 5.10 11 Apr 1991 geterror(9F)
Related Man Pages
bioerror(9f) - centos
bioerror(9f) - php
bioerror(9f) - debian
bioerror(9f) - hpux
bioerror(9f) - posix
Similar Topics in the Unix Linux Community
How to mount/umount disk from a non-root account
Oracle (11gr2) calling unix commands (aix)
Incompatiblity of the code due to CC compiler version mismatch.
Change value for POSIX
Please Help Test New Registration Page