sunos man page for ddi_driver_name

Query: ddi_driver_name

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_driver_name(9F)					   Kernel Functions for Drivers 				       ddi_driver_name(9F)

NAME
ddi_driver_name - return normalized driver name
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> const char *ddi_driver_name(dev_info_t *devi);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip A pointer to the device's dev_info structure.
DESCRIPTION
ddi_driver_name() returns the normalized driver name. This name is typically derived from the device name property or the device compatible property. If this name is a driver alias, the corresponding driver name is returned.
RETURN VALUES
ddi_driver_name() returns the actual name of the driver bound to a device.
CONTEXT
ddi_driver_name() can be called from kernel, or interrupt context.
SEE ALSO
ddi_get_name(9F) Writing Device Drivers
WARNINGS
The name returned by ddi_driver_name() is read-only. SunOS 5.10 2 Dec 1998 ddi_driver_name(9F)
Related Man Pages
usb_client_detach(9f) - opensolaris
ddi_binding_name(9f) - mojave
ddi_binding_name(9f) - suse
ddi_binding_name(9f) - hpux
ddi_binding_name(9f) - freebsd
Similar Topics in the Unix Linux Community
The 500 Mile Email
Merge and Sort tabular data from different text files
How do I remove or hide SunOS version/release from remote login prompt?
Best performance UNIX just for HOST Virtualization?