sunos man page for db_base

Query: db_base

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DB_BASE(9F)						   Kernel Functions for Drivers 					       DB_BASE(9F)

NAME
DB_BASE, DB_LIM, DB_REF, DB_TYPE - Data block access macros
SYNOPSIS
#include <sys/stream.h> #include <sys/strsun.h> uchar_t *DB_BASE(mblk_t *mp); uchar_t *DB_LIM(mblk_t *mp); uchar_t DB_TYPE(mblk_t *mp); uchar_t DB_REF(mblk_t *mp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
mp Message block to be accessed.
DESCRIPTION
These macros provide compact access to public members of the datab(9S) structure associated with the specified message block. In all cases, these macros are equivalent to directly accessing the underlying fields of the datab(9S) associated with the specified mes- sage block. Specifically: DB_BASE(mp) is equivalent to mp->b_datap->db_base. DB_LIM(mp) is equivalent to mp->b_datap->db_lim. DB_TYPE(mp) is equivalent to mp->b_datap->db_type. DB_REF(mp) is equivalent to mp->b_datap->db_ref.
CONTEXT
These functions can be called from user, kernel or interrupt context.
SEE ALSO
msgb(9S), datab(9S) STREAMS Programming Guide SunOS 5.10 9 June 2004 DB_BASE(9F)
Related Man Pages
db_ref(9f) - sunos
db_type(9f) - sunos
mblkl(9f) - sunos
mblktail(9f) - sunos
datamsg(9f) - centos
Similar Topics in the Unix Linux Community
libmapmalloc