sunos man page for csx_parse_cistpl_manfid

Query: csx_parse_cistpl_manfid

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

csx_Parse_CISTPL_MANFID(9F)				   Kernel Functions for Drivers 			       csx_Parse_CISTPL_MANFID(9F)

NAME
csx_Parse_CISTPL_MANFID - parse Manufacturer Identification tuple
SYNOPSIS
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_MANFID(client_handle_t ch, tuple_t *tu, cistpl_manfid_t *cm);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F). cm Pointer to a cistpl_manfid_t structure which contains the parsed CISTPL_MANFID tuple information upon return from this function.
DESCRIPTION
This function parses the Manufacturer Identification tuple, CISTPL_MANFID, into a form usable by PC Card drivers. The CISTPL_MANFID tuple is used to describe the information about the manufacturer of a PC Card. There are two types of information, the PC Card's manufacturer and a manufacturer card number.
STRUCTURE MEMBERS
The structure members of cistpl_manfid_t are: uint32_t manf; /* PCMCIA assigned manufacturer code */ uint32_t card; /* manufacturer information (part number and/or revision) */
RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNKNOWN_TUPLE Parser does not know how to parse tuple. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.
CONTEXT
This function may be called from user or kernel context.
SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 20 Dec 1996 csx_Parse_CISTPL_MANFID(9F)
Related Man Pages
csx_parse_cistpl_jedec_c(9f) - sunos
csx_parse_cistpl_linktarget(9f) - sunos
csx_parse_cistpl_vers_1(9f) - sunos
csx_parse_cistpl_jedec_c(9f) - opensolaris
csx_parse_cistpl_vers_2(9f) - opensolaris
Similar Topics in the Unix Linux Community
Command to Analyze a PCMCIA Card
memory manufacturer command
Utilization of Ethernet Card
SD Card Throughput exceeds - On using &quot;dd&quot; command
Specilix Card Comfiguration