sunos man page for csx_mapmempage

Query: csx_mapmempage

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

csx_MapMemPage(9F)					   Kernel Functions for Drivers 					csx_MapMemPage(9F)

NAME
csx_MapMemPage - map the memory area on a PC Card
SYNOPSIS
#include <sys/pccard.h> int32_t csx_MapMemPage(window_handle_t wh, map_mem_page_t *mp);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
wh Window handle returned from csx_RequestWindow(9F). mp Pointer to a map_mem_page_t structure.
DESCRIPTION
This function maps the memory area on a PC Card into a page of a window allocated with the csx_RequestWindow(9F) function.
STRUCTURE MEMBERS
The structure members of map_mem_page_t are: uint32_t CardOffset; /* card offset */ uint32_t Page; /* page number */ The fields are defined as follows: CardOffset The absolute offset in bytes from the beginning of the PC Card to map into system memory. Page Used internally by Card Services; clients must set this field to 0 before calling this function.
RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_OFFSET Offset is invalid. CS_BAD_PAGE Page is not zero. CS_NO_CARD No PC Card in socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.
CONTEXT
This function may be called from user or kernel context.
SEE ALSO
csx_ModifyWindow(9F), csx_ReleaseWindow(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_MapMemPage(9F)
Related Man Pages
csx_parse_cistpl_date(9f) - sunos
csx_validatecis(9f) - sunos
csx_mapmempage(9f) - opensolaris
csx_releaseconfiguration(9f) - opensolaris
csx_validatecis(9f) - opensolaris
Similar Topics in the Unix Linux Community
map Page Down and Page up to ] and [
Excessive Page INs
Command to Analyze a PCMCIA Card
Mac OS X: Reading system memory usage in Activity Monitor