sunos man page for csx_getmappedaddr

Query: csx_getmappedaddr

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

csx_GetMappedAddr(9F)					   Kernel Functions for Drivers 				     csx_GetMappedAddr(9F)

NAME
csx_GetMappedAddr - return mapped virtual address
SYNOPSIS
#include <sys/pccard.h> int32_t csx_GetMappedAddr(acc_handle_t handle, void **addr);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
handle The access handle returned from csx_RequestIO(9F), csx_RequestWindow(9F), or csx_DupHandle(9F). addr The virtual or I/O port number represented by the handle.
DESCRIPTION
This function returns the mapped virtual address or the mapped I/O port number represented by the handle, handle.
RETURN VALUES
CS_SUCCESS The resulting address or I/O port number can be directly accessed by the caller. CS_FAILURE The resulting address or I/O port number can not be directly accessed by the caller; the caller must make all accesses to the mapped area via the common access functions. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.
CONTEXT
This function may be called from user, kernel, or interrupt context.
SEE ALSO
csx_DupHandle(9F), csx_Get8(9F), csx_Put8(9F), csx_RepGet8(9F), csx_RepPut8(9F), csx_RequestIO(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_GetMappedAddr(9F)
Related Man Pages
csx_get32(9f) - sunos
csx_get8(9f) - sunos
csx_get16(9f) - opensolaris
csx_get8(9f) - opensolaris
csx_put16(9f) - opensolaris
Similar Topics in the Unix Linux Community
How to convert number to english?
UNIX fun stuff - echo and dc - obfuscate/garble a string sort of
How do I remove or hide SunOS version/release from remote login prompt?
Using awk to remove lines from file that match text
Outputting sequences based on length with sed