sunos man page for clrbuf

Query: clrbuf

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

clrbuf(9F)						   Kernel Functions for Drivers 						clrbuf(9F)

NAME
clrbuf - erase the contents of a buffer
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void clrbuf(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buf(9S) structure.
DESCRIPTION
clrbuf() zeros a buffer and sets the b_resid member of the buf(9S) structure to 0. Zeros are placed in the buffer starting at bp->b_un.b_addr for a length of bp->b_bcount bytes. b_un.b_addr and b_bcount are members of the buf(9S) data structure.
CONTEXT
clrbuf() can be called from user or interrupt context.
SEE ALSO
getrbuf(9F), buf(9S) Writing Device Drivers SunOS 5.10 27 Jan 1993 clrbuf(9F)
Related Man Pages
buf(9s) - opensolaris
bioinit(9f) - sunos
bioinit(9f) - minix
bioinit(9f) - osx
bioinit(9f) - suse
Similar Topics in the Unix Linux Community
The 500 Mile Email
Outputting sequences based on length with sed
Sort only numbers within a string
UNIX Environment Setup - (Just starting!)