sunos man page for bzero

Query: bzero

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bzero(9F)						   Kernel Functions for Drivers 						 bzero(9F)

NAME
bzero - clear memory for a given number of bytes
SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> void bzero(void *addr, size_t bytes);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
addr Starting virtual address of memory to be cleared. bytes The number of bytes to clear starting at addr.
DESCRIPTION
bzero() clears a contiguous portion of memory by filling it with zeros.
CONTEXT
bzero() can be called from user or interrupt context.
SEE ALSO
bcopy(9F), clrbuf(9F), kmem_zalloc(9F) Writing Device Drivers
WARNINGS
The address range specified must be within the kernel space. No range checking is done. If an address outside of the kernel space is selected, the driver may corrupt the system in an unpredictable way. SunOS 5.10 1 May 1996 bzero(9F)
Related Man Pages
bcopy(3c) - opensolaris
bcmp(3c) - opensolaris
bcmp(3) - osf1
bcmp(3c) - sunos
bstring(3) - freebsd
Similar Topics in the Unix Linux Community
bzero in socket
C bzero() to memset() issue